aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-05-13 19:16:29 +0800
committerSteve Wills <swills@FreeBSD.org>2019-05-13 19:16:29 +0800
commit226cb5b61d4a5c7c6a6f6a01b1acb20d610f01ce (patch)
treeac50c1b77f4152cc779600c7c296ee4f54cd5702
parent19c1a45e18c73f79d39be68b78ac16df7fd282a9 (diff)
downloadfreebsd-ports-226cb5b61d4a5c7c6a6f6a01b1acb20d610f01ce.tar.gz
freebsd-ports-226cb5b61d4a5c7c6a6f6a01b1acb20d610f01ce.tar.zst
freebsd-ports-226cb5b61d4a5c7c6a6f6a01b1acb20d610f01ce.zip
MFH: r498656 r499790 r501547
Patch to add missing config and take the maintainership Two new variables was added to instance_config.cfg file in version 2.8.13 to allow the addition and removal of users from groups. I am also taking over the maintainership of this packages as previously discussed with Helen. Bump PORTREVISION. PR: 236500 Submitted by: Lucas Kanashiro <lucas.kanashiro@collabora.com> Approved by: Helen Koike <helen.koike@collabora.com> (maintainer) sysutils/py-google-compute-engine: update to 20190416 [1] This fixes a python3 runtime issue [1] While here, pull in missing dependency in python3 case [2] PR: 237505 [1] PR: 237203 [2] Submitted by: Lucas Kanashiro <lucas.kanashiro@collabora.com> (maintainer) [1] Submitted by: Miroslav Lachman <000.fbsd@quip.cz> [2] Approved by: Lucas Kanashiro <lucas.kanashiro@collabora.com> (maintainer) [2] sysutils/py-google-compute-engine: fix daemons in python 2.7 case PR: 237845 Reviewed by: koobs Approved by: implicit (portmgr, python, jfi blanket) Approved by: ports-secteam (implicit)
Notes
Notes: svn path=/branches/2019Q2/; revision=501552
-rw-r--r--sysutils/py-google-compute-engine/Makefile24
-rw-r--r--sysutils/py-google-compute-engine/distinfo6
-rw-r--r--sysutils/py-google-compute-engine/files/google_accounts_daemon.in2
-rw-r--r--sysutils/py-google-compute-engine/files/google_clock_skew_daemon.in2
-rw-r--r--sysutils/py-google-compute-engine/files/google_instance_setup.in2
-rw-r--r--sysutils/py-google-compute-engine/files/google_network_daemon.in2
-rw-r--r--sysutils/py-google-compute-engine/files/google_startup.in2
-rw-r--r--sysutils/py-google-compute-engine/files/instance_configs.cfg.distro.sample2
8 files changed, 25 insertions, 17 deletions
diff --git a/sysutils/py-google-compute-engine/Makefile b/sysutils/py-google-compute-engine/Makefile
index b4c805b6e526..54b19e27632f 100644
--- a/sysutils/py-google-compute-engine/Makefile
+++ b/sysutils/py-google-compute-engine/Makefile
@@ -2,10 +2,11 @@
PORTNAME= google-compute-engine
DISTVERSION= 2.8.13
+PORTREVISION= 4
CATEGORIES= sysutils python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= helen.koike@collabora.com
+MAINTAINER= lucas.kanashiro@collabora.com
COMMENT= Guest Environment for Google Compute Engine
LICENSE= APACHE20
@@ -17,24 +18,29 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto>0:devel/py-boto@${PY_FLAVOR} \
google_oslogin_control:sysutils/google-compute-engine-oslogin \
sudo:security/sudo
+.if ${FLAVOR:Upy36:Mpy3*}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}distro>0:sysutils/py-distro@${PY_FLAVOR}
+.endif
+
USES= python shebangfix
USE_PYTHON= autoplist concurrent distutils
+WRKSRC_SUBDIR= packages/python-google-compute-engine
+
NO_ARCH= yes
-SHEBANG_FILES= scripts/google_set_multiqueue scripts/google_optimize_local_ssd
+SHEBANG_FILES= ../google-compute-engine/src/usr/bin/google_optimize_local_ssd \
+ ../google-compute-engine/src/usr/bin/google_set_multiqueue
USE_GITHUB= yes
GH_ACCOUNT= GoogleCloudPlatform
GH_PROJECT= compute-image-packages
-GH_TAGNAME= 20190124
+GH_TAGNAME= 20190416
-USE_RC_SUBR= google_instance_setup \
- google_accounts_daemon \
- google_clock_skew_daemon \
- google_network_daemon \
- google_startup
+USE_RC_SUBR= google_accounts_daemon google_clock_skew_daemon \
+ google_instance_setup google_network_daemon google_startup
-SUB_LIST= PYTHON_CMD="${PYTHON_CMD}"
+SUB_LIST= PYTHON_CMD="${PYTHON_CMD}" \
+ PYTHON_VER="${PYTHON_VER}"
REINPLACE_ARGS= -i ''
post-install:
diff --git a/sysutils/py-google-compute-engine/distinfo b/sysutils/py-google-compute-engine/distinfo
index 353b734b4aee..0e754c97b24a 100644
--- a/sysutils/py-google-compute-engine/distinfo
+++ b/sysutils/py-google-compute-engine/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1551668922
-SHA256 (GoogleCloudPlatform-compute-image-packages-2.8.13-20190124_GH0.tar.gz) = 09637f951245729c66eb5b7b9ed49bead31349b29829baf5c8a4e5d45405a2f4
-SIZE (GoogleCloudPlatform-compute-image-packages-2.8.13-20190124_GH0.tar.gz) = 126211
+TIMESTAMP = 1556025006
+SHA256 (GoogleCloudPlatform-compute-image-packages-2.8.13-20190416_GH0.tar.gz) = cef65af726b7c32db9035266804e0393b54196fabd1007026554bae2d9540de4
+SIZE (GoogleCloudPlatform-compute-image-packages-2.8.13-20190416_GH0.tar.gz) = 130216
diff --git a/sysutils/py-google-compute-engine/files/google_accounts_daemon.in b/sysutils/py-google-compute-engine/files/google_accounts_daemon.in
index d6b6fa4b8e5c..bc7f60c003b2 100644
--- a/sysutils/py-google-compute-engine/files/google_accounts_daemon.in
+++ b/sysutils/py-google-compute-engine/files/google_accounts_daemon.in
@@ -24,7 +24,7 @@ load_rc_config "${name}"
: ${google_accounts_daemon_enable:="NO"}
command_interpreter="%%PYTHON_CMD%%"
-command=%%PREFIX%%/bin/${name}
+command=%%PREFIX%%/bin/${name}-%%PYTHON_VER%%
pidfile=/var/run/${name}.pid
start_cmd="google_accounts_daemon_start"
diff --git a/sysutils/py-google-compute-engine/files/google_clock_skew_daemon.in b/sysutils/py-google-compute-engine/files/google_clock_skew_daemon.in
index 66a71daa0c15..1cb56c19df2a 100644
--- a/sysutils/py-google-compute-engine/files/google_clock_skew_daemon.in
+++ b/sysutils/py-google-compute-engine/files/google_clock_skew_daemon.in
@@ -21,7 +21,7 @@ load_rc_config "${name}"
: ${google_clock_skew_daemon_enable:="NO"}
command_interpreter="%%PYTHON_CMD%%"
-command=%%PREFIX%%/bin/${name}
+command=%%PREFIX%%/bin/${name}-%%PYTHON_VER%%
pidfile=/var/run/${name}.pid
start_cmd="google_clock_skew_daemon_start"
diff --git a/sysutils/py-google-compute-engine/files/google_instance_setup.in b/sysutils/py-google-compute-engine/files/google_instance_setup.in
index 689fbbf45728..39c368f0b77c 100644
--- a/sysutils/py-google-compute-engine/files/google_instance_setup.in
+++ b/sysutils/py-google-compute-engine/files/google_instance_setup.in
@@ -21,7 +21,7 @@ load_rc_config "${name}"
: ${google_instance_setup_enable:="NO"}
command_interpreter="%%PYTHON_CMD%%"
-command=%%PREFIX%%/bin/${name}
+command=%%PREFIX%%/bin/${name}-%%PYTHON_VER%%
pidfile=/var/run/${name}.pid
run_rc_command "$1"
diff --git a/sysutils/py-google-compute-engine/files/google_network_daemon.in b/sysutils/py-google-compute-engine/files/google_network_daemon.in
index da9b44538519..8944b8a70ac7 100644
--- a/sysutils/py-google-compute-engine/files/google_network_daemon.in
+++ b/sysutils/py-google-compute-engine/files/google_network_daemon.in
@@ -21,7 +21,7 @@ load_rc_config "${name}"
: ${google_network_daemon_enable:="NO"}
command_interpreter="%%PYTHON_CMD%%"
-command=%%PREFIX%%/bin/${name}
+command=%%PREFIX%%/bin/${name}-%%PYTHON_VER%%
pidfile=/var/run/${name}.pid
start_cmd="google_network_daemon_start"
diff --git a/sysutils/py-google-compute-engine/files/google_startup.in b/sysutils/py-google-compute-engine/files/google_startup.in
index a3fd8004d557..1e6a8531d03b 100644
--- a/sysutils/py-google-compute-engine/files/google_startup.in
+++ b/sysutils/py-google-compute-engine/files/google_startup.in
@@ -24,7 +24,7 @@ load_rc_config "${name}"
: ${google_startup_enable:="NO"}
command_interpreter="%%PYTHON_CMD%%"
-command=%%PREFIX%%/bin/google_metadata_script_runner
+command=%%PREFIX%%/bin/google_metadata_script_runner-%%PYTHON_VER%%
command_startup_args="--script-type startup"
command_shutdown_args="--script-type shutdown"
pidfile=/var/run/${name}.pid
diff --git a/sysutils/py-google-compute-engine/files/instance_configs.cfg.distro.sample b/sysutils/py-google-compute-engine/files/instance_configs.cfg.distro.sample
index 2ad0c261d5c0..0c018cc01407 100644
--- a/sysutils/py-google-compute-engine/files/instance_configs.cfg.distro.sample
+++ b/sysutils/py-google-compute-engine/files/instance_configs.cfg.distro.sample
@@ -1,4 +1,6 @@
[Accounts]
+gpasswd_add_cmd = pw groupmod {group} -m {user}
+gpasswd_remove_cmd = pw groupmod {group} -d {user}
useradd_cmd = pw useradd {user} -m
userdel_cmd = pw userdel {user} -r
usermod_cmd = pw usermod {user} -G {groups}