aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-05-11 02:57:19 +0800
committerJan Beich <jbeich@FreeBSD.org>2019-05-11 02:57:19 +0800
commit514ac130e008a8e72531672a84b1c4959e286939 (patch)
tree7e1636fce6f8e9a5f9df3e4f4a7957faf4ce1f3d
parent436530a1a0ae6b309c0ada56da425b42a96b653e (diff)
downloadfreebsd-ports-514ac130e008a8e72531672a84b1c4959e286939.tar.gz
freebsd-ports-514ac130e008a8e72531672a84b1c4959e286939.tar.zst
freebsd-ports-514ac130e008a8e72531672a84b1c4959e286939.zip
MFH: r501193
multimedia/x265: backport some SVTHEVC fixes Approved by: ports-secteam blanket
Notes
Notes: svn path=/branches/2019Q2/; revision=501194
-rw-r--r--multimedia/x265/Makefile2
-rw-r--r--multimedia/x265/distinfo4
-rw-r--r--multimedia/x265/files/patch-source_encoder_api.cpp45
3 files changed, 6 insertions, 45 deletions
diff --git a/multimedia/x265/Makefile b/multimedia/x265/Makefile
index 5a504abd6abc..efd5f6e152c5 100644
--- a/multimedia/x265/Makefile
+++ b/multimedia/x265/Makefile
@@ -3,6 +3,7 @@
PORTNAME= x265
PORTVERSION= 3.0
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= https://downloads.videolan.org/pub/videolan/x265/ \
https://mirror.leaseweb.com/videolan/x265/ \
@@ -12,6 +13,7 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
PATCH_SITES= http://hg.videolan.org/${PORTNAME}/raw-rev/
PATCHFILES+= 878541319ea1:-p1 a41325fc854f:-p1 # SVT-HEVC
+PATCHFILES+= 31ab7e09a3b5:-p1 e16999096b48:-p1 # SVT-HEVC
MAINTAINER= mi@aldan.algebra.com
COMMENT= H.265/High Efficiency Video Coding (HEVC) format
diff --git a/multimedia/x265/distinfo b/multimedia/x265/distinfo
index d555c822ffa0..94fb1b962dd2 100644
--- a/multimedia/x265/distinfo
+++ b/multimedia/x265/distinfo
@@ -5,3 +5,7 @@ SHA256 (878541319ea1) = cb135430143d4d0df4e1d7e5b9d7994f0b6279796f44f7b8b6e5159c
SIZE (878541319ea1) = 86799
SHA256 (a41325fc854f) = 5fb5a2d97cecf9920f5800364534f56584dbf805f1e215de9dbdeca025eb3ec8
SIZE (a41325fc854f) = 912
+SHA256 (31ab7e09a3b5) = ecf6349c12cdb060ccbd7dfcf013599208cd9239b1fbc877318f3a779b98b7aa
+SIZE (31ab7e09a3b5) = 2927
+SHA256 (e16999096b48) = 7e4cdeb59d172ab0b04c03356ad05a38bec1802f44b64ce56bf3694efe06cc82
+SIZE (e16999096b48) = 1105
diff --git a/multimedia/x265/files/patch-source_encoder_api.cpp b/multimedia/x265/files/patch-source_encoder_api.cpp
deleted file mode 100644
index 6b65641169f5..000000000000
--- a/multimedia/x265/files/patch-source_encoder_api.cpp
+++ /dev/null
@@ -1,45 +0,0 @@
-source/encoder/api.cpp:432:17: error: cannot jump from this
- goto statement to its label
- goto fail;
- ^
-source/encoder/api.cpp:436:36: note: jump bypasses variable
- initialization
- EB_H265_ENC_CONFIGURATION* svtParam = (EB_H265_ENC_CONFIGURATION*)encoder->m_svtAppData->svtHevcParams;
- ^
-source/encoder/api.cpp:413:17: error: cannot jump from this
- goto statement to its label
- goto fail;
- ^
-source/encoder/api.cpp:436:36: note: jump bypasses variable
- initialization
- EB_H265_ENC_CONFIGURATION* svtParam = (EB_H265_ENC_CONFIGURATION*)encoder->m_svtAppData->svtHevcParams;
- ^
-source/encoder/api.cpp:406:21: error: cannot jump from this
- goto statement to its label
- goto fail;
- ^
-source/encoder/api.cpp:436:36: note: jump bypasses variable
- initialization
- EB_H265_ENC_CONFIGURATION* svtParam = (EB_H265_ENC_CONFIGURATION*)encoder->m_svtAppData->svtHevcParams;
- ^
-3 errors generated.
-
---- source/encoder/api.cpp.orig 2019-01-23 09:47:18 UTC
-+++ source/encoder/api.cpp
-@@ -355,6 +355,7 @@ int x265_encoder_encode(x265_encoder *enc, x265_nal **
- static unsigned char picSendDone = 0;
- numEncoded = 0;
- static int codedNal = 0, eofReached = 0;
-+ EB_H265_ENC_CONFIGURATION* svtParam = NULL;
-
- if (encoder->m_param->bEnableSvtHevc)
- {
-@@ -433,7 +434,7 @@ int x265_encoder_encode(x265_encoder *enc, x265_nal **
- }
- }
-
-- EB_H265_ENC_CONFIGURATION* svtParam = (EB_H265_ENC_CONFIGURATION*)encoder->m_svtAppData->svtHevcParams;
-+ svtParam = (EB_H265_ENC_CONFIGURATION*)encoder->m_svtAppData->svtHevcParams;
- if (eofReached && svtParam->codeEosNal == 0 && !codedNal)
- {
- EB_BUFFERHEADERTYPE *outputStreamPtr = 0;