aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-05-19 08:51:42 +0800
committerJan Beich <jbeich@FreeBSD.org>2019-05-19 08:51:42 +0800
commitda115906d51b0c0895b82f93f064ca16f71c91f4 (patch)
tree974ff727f03af8a5f6b4f302e8c0cdec3a0cbca2
parent76a617a8b229fb09461ea20722338e16e060125f (diff)
downloadfreebsd-ports-da115906d51b0c0895b82f93f064ca16f71c91f4.tar.gz
freebsd-ports-da115906d51b0c0895b82f93f064ca16f71c91f4.tar.zst
freebsd-ports-da115906d51b0c0895b82f93f064ca16f71c91f4.zip
MFH: r501995
mail/thunderbird: update to 60.7.0 Changes: https://www.thunderbird.net/thunderbird/60.7.0/releasenotes/ Reported by: Repology Approved by: ports-secteam blanket
Notes
Notes: svn path=/branches/2019Q2/; revision=502000
-rw-r--r--mail/thunderbird/Makefile3
-rw-r--r--mail/thunderbird/distinfo6
-rw-r--r--mail/thunderbird/files/patch-a-bug150279950
3 files changed, 54 insertions, 5 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index b56470782902..0fc6ce8aa431 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= thunderbird
-DISTVERSION= 60.6.1
-PORTREVISION= 2
+DISTVERSION= 60.7.0
CATEGORIES= mail news net-im ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build2/source
diff --git a/mail/thunderbird/distinfo b/mail/thunderbird/distinfo
index 8fa5c298ba8a..e06e6a3e675f 100644
--- a/mail/thunderbird/distinfo
+++ b/mail/thunderbird/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1553477967
-SHA256 (thunderbird-60.6.1.source.tar.xz) = 17aef9232a76bdc812422883c02b01b4ecb7633c3ee9870da5e4ec0e20ba5f67
-SIZE (thunderbird-60.6.1.source.tar.xz) = 288706632
+TIMESTAMP = 1558094849
+SHA256 (thunderbird-60.7.0.source.tar.xz) = 377ca762624df103dd768dc36b7632537b46aa83ddc9d336a157cadcde8bb51d
+SIZE (thunderbird-60.7.0.source.tar.xz) = 285728804
diff --git a/mail/thunderbird/files/patch-a-bug1502799 b/mail/thunderbird/files/patch-a-bug1502799
new file mode 100644
index 000000000000..105da6a3e21c
--- /dev/null
+++ b/mail/thunderbird/files/patch-a-bug1502799
@@ -0,0 +1,50 @@
+commit f57498276d74
+Author: Andrea Marchesini <amarchesini@mozilla.com>
+Date: Wed May 15 22:00:00 2019 -0700
+
+ Bug 1502799 - Reintroduce serialize_function, disabled by mistake by previous patches, r=emilio
+---
+ servo/components/style/gecko_string_cache/namespace.rs | 1 -
+ servo/components/style_traits/values.rs | 3 ---
+ 2 files changed, 4 deletions(-)
+
+diff --git servo/components/style/gecko_string_cache/namespace.rs servo/components/style/gecko_string_cache/namespace.rs
+index 71d2fce8ff6b..92288574e145 100644
+--- servo/components/style/gecko_string_cache/namespace.rs
++++ servo/components/style/gecko_string_cache/namespace.rs
+@@ -11,7 +11,6 @@ use std::fmt;
+ use std::ops::Deref;
+ use string_cache::{Atom, WeakAtom};
+
+-/// aaa
+ #[macro_export]
+ macro_rules! ns {
+ () => { $crate::string_cache::Namespace(atom!("")) };
+diff --git servo/components/style_traits/values.rs servo/components/style_traits/values.rs
+index 40209772a790..d6bd05b7b40e 100644
+--- servo/components/style_traits/values.rs
++++ servo/components/style_traits/values.rs
+@@ -135,7 +135,6 @@ where
+ }
+ }
+
+-/*
+ #[macro_export]
+ macro_rules! serialize_function {
+ ($dest: expr, $name: ident($( $arg: expr, )+)) => {
+@@ -153,7 +152,6 @@ macro_rules! serialize_function {
+ }
+ }
+ }
+-*/
+
+ /// Convenience wrapper to serialise CSS values separated by a given string.
+ pub struct SequenceWriter<'a, 'b: 'a, W: 'b> {
+@@ -406,7 +404,6 @@ impl_to_css_for_predefined_type!(::cssparser::RGBA);
+ impl_to_css_for_predefined_type!(::cssparser::Color);
+ impl_to_css_for_predefined_type!(::cssparser::UnicodeRange);
+
+-/// Define an enum type with unit variants that each correspond to a CSS keyword.
+ #[macro_export]
+ macro_rules! define_css_keyword_enum {
+ (pub enum $name:ident { $($variant:ident = $css:expr,)+ }) => {