aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-05-24 17:05:37 +0800
committerKubilay Kocak <koobs@FreeBSD.org>2019-05-24 17:05:37 +0800
commite46730fdbeaa65d4f058480d80a5d77f6c1d16b0 (patch)
treee61be4ba3f1443fd4dfef0242096e6ce775b3890
parentcb08c16c9128540ad7b5824098ed307fdcaa8eab (diff)
downloadfreebsd-ports-e46730fdbeaa65d4f058480d80a5d77f6c1d16b0.tar.gz
freebsd-ports-e46730fdbeaa65d4f058480d80a5d77f6c1d16b0.tar.zst
freebsd-ports-e46730fdbeaa65d4f058480d80a5d77f6c1d16b0.zip
MFH: r499452 devel/py-fabric: Update to 1.14.1
- Rejig test invocation to exclude a test that hangs - Update pkg-descr WWW to https://, where it redirects to Changelog: https://www.fabfile.org/changelog-v1.html PR: 235194 Submitted by: Dani <i.dani outlook com> Approved by: ports-secteam (blanket: bugfix release(s))
Notes
Notes: svn path=/branches/2019Q2/; revision=502434
-rw-r--r--devel/py-fabric/Makefile11
-rw-r--r--devel/py-fabric/distinfo6
-rw-r--r--devel/py-fabric/pkg-descr2
3 files changed, 10 insertions, 9 deletions
diff --git a/devel/py-fabric/Makefile b/devel/py-fabric/Makefile
index 8c69834ccec6..007971ab3453 100644
--- a/devel/py-fabric/Makefile
+++ b/devel/py-fabric/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= fabric
-PORTVERSION= 1.13.2
+PORTVERSION= 1.14.1
PORTEPOCH= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
@@ -15,17 +15,18 @@ COMMENT= Simple, Pythonic remote execution and deployment
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}paramiko>=1.10:security/py-paramiko@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}paramiko>=1.10:security/py-paramiko@${PY_FLAVOR} # <3.0
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}fudge>0:devel/py-fudge@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}Jinja2>=0.6:devel/py-Jinja2@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR}
USES= python:2.7
-USE_PYTHON= distutils autoplist
+USE_PYTHON= distutils concurrent autoplist
NO_ARCH= yes
do-test:
- @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m nose -v \
+ --exclude=test_nested_execution_with_explicit_ports
.include <bsd.port.mk>
diff --git a/devel/py-fabric/distinfo b/devel/py-fabric/distinfo
index 1f218da14cd5..da201a341357 100644
--- a/devel/py-fabric/distinfo
+++ b/devel/py-fabric/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1500111944
-SHA256 (Fabric-1.13.2.tar.gz) = 98af64a1fe19d9c6a229265aec4e9fdaf3127ac2000db3e2e19007927b23244d
-SIZE (Fabric-1.13.2.tar.gz) = 219507
+TIMESTAMP = 1554010618
+SHA256 (Fabric-1.14.1.tar.gz) = 66097883bb3e5beecacae92b82b2bd489d10a8fd4f06ce1cb27019de2e6d76a8
+SIZE (Fabric-1.14.1.tar.gz) = 220463
diff --git a/devel/py-fabric/pkg-descr b/devel/py-fabric/pkg-descr
index 7335f69588a2..39a31b532253 100644
--- a/devel/py-fabric/pkg-descr
+++ b/devel/py-fabric/pkg-descr
@@ -7,4 +7,4 @@ of servers in parallel or serially. These commands are grouped in tasks
This is called remote automation, and the primary use case is deploying
applications to multiple similar hosts.
-WWW: http://fabfile.org
+WWW: https://www.fabfile.org