aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2018-03-27 02:28:12 +0800
committerVasil Dimov <vd@FreeBSD.org>2018-03-27 02:28:12 +0800
commit0b17f813db4b72fd655bcaf01706e67deaa2bcad (patch)
treece9ce0d29a20fce6952f87cda478dc1eeb5a52ba
parent501e833084c55c82cf9bb42441e0ac6c82016319 (diff)
downloadfreebsd-ports-0b17f813db4b72fd655bcaf01706e67deaa2bcad.tar.gz
freebsd-ports-0b17f813db4b72fd655bcaf01706e67deaa2bcad.tar.zst
freebsd-ports-0b17f813db4b72fd655bcaf01706e67deaa2bcad.zip
Set default BDB version in bitcoin slave ports
In c465619 a new single-choice option was introduced in net-p2p/bitcoin where exactly one variant must be chosen (BDB version). But the bitcoin slave ports net-p2p/bitcoin-daemon and net-p2p/bitcoin-utils set OPTIONS_DEFAULT=... (with missing BDB version) and the master port uses OPTIONS_DEFAULT?=...somebdbversion... so the choice of the master port is not inherited by the slaves. Fix this by explicitly setting the BDB version in both slave ports. Reported by: Dan Langille
Notes
Notes: svn path=/head/; revision=465623
-rw-r--r--net-p2p/bitcoin-daemon/Makefile4
-rw-r--r--net-p2p/bitcoin-utils/Makefile4
2 files changed, 6 insertions, 2 deletions
diff --git a/net-p2p/bitcoin-daemon/Makefile b/net-p2p/bitcoin-daemon/Makefile
index 15fc32728a79..c79dc1d09a56 100644
--- a/net-p2p/bitcoin-daemon/Makefile
+++ b/net-p2p/bitcoin-daemon/Makefile
@@ -11,7 +11,9 @@ NOT_FOR_ARCHS= powerpc powerpc64 sparc64
NOT_FOR_ARCHS_REASON= does not support big-endian architectures
OPTIONS_DEFINE= DEBUG HARDENING TESTS UPNP WALLET ZMQ
-OPTIONS_DEFAULT= HARDENING UPNP WALLET
+# BDBMODERN is a choice for BDBVER, introduced via OPTIONS_SINGLE=BDBVER
+# from ${MASTERDIR}/Makefile
+OPTIONS_DEFAULT= BDBMODERN HARDENING UPNP WALLET
USERS= bitcoin
GROUPS= bitcoin
diff --git a/net-p2p/bitcoin-utils/Makefile b/net-p2p/bitcoin-utils/Makefile
index 3830afccd4fe..0738be8a44d4 100644
--- a/net-p2p/bitcoin-utils/Makefile
+++ b/net-p2p/bitcoin-utils/Makefile
@@ -10,7 +10,9 @@ NOT_FOR_ARCHS= powerpc powerpc64 sparc64
NOT_FOR_ARCHS_REASON= does not support big-endian architectures
OPTIONS_DEFINE= DEBUG HARDENING TESTS
-OPTIONS_DEFAULT= HARDENING TESTS
+# BDBMODERN is a choice for BDBVER, introduced via OPTIONS_SINGLE=BDBVER
+# from ${MASTERDIR}/Makefile
+OPTIONS_DEFAULT= BDBMODERN HARDENING TESTS
CONFIGURE_ARGS= --without-daemon \
--without-gui \