aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2018-03-26 04:49:08 +0800
committerGuido Falsi <madpilot@FreeBSD.org>2018-03-26 04:49:08 +0800
commit1f5755641b7a2a59af91753c2313af2441393a05 (patch)
treeaac2fdbb62541149ba637807b22bcabe7853b81c
parentd17e47575bd1a05fbb78708af5fa784765b4b8f0 (diff)
downloadfreebsd-ports-1f5755641b7a2a59af91753c2313af2441393a05.tar.gz
freebsd-ports-1f5755641b7a2a59af91753c2313af2441393a05.tar.zst
freebsd-ports-1f5755641b7a2a59af91753c2313af2441393a05.zip
Update asterisk-g72x to 1.4.2
Notes
Notes: svn path=/head/; revision=465546
-rw-r--r--net/asterisk-g72x/Makefile3
-rw-r--r--net/asterisk-g72x/distinfo6
-rw-r--r--net/asterisk-g72x/files/patch-codec__g72x.c41
3 files changed, 4 insertions, 46 deletions
diff --git a/net/asterisk-g72x/Makefile b/net/asterisk-g72x/Makefile
index 27be7cf2f077..baca0588dab2 100644
--- a/net/asterisk-g72x/Makefile
+++ b/net/asterisk-g72x/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= asterisk-g72x
-PORTVERSION= 1.4
-PORTREVISION= 1
+PORTVERSION= 1.4.2
CATEGORIES= net
MASTER_SITES= http://asterisk.hosting.lv/src/
diff --git a/net/asterisk-g72x/distinfo b/net/asterisk-g72x/distinfo
index 1d9bce122c94..a19bf0f9f41e 100644
--- a/net/asterisk-g72x/distinfo
+++ b/net/asterisk-g72x/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1475740880
-SHA256 (asterisk-g72x-1.4.tar.bz2) = 0b4959c757c33d5cf0038f40ed94e7bfc00fd0dc22821d48742fe930cc24ae54
-SIZE (asterisk-g72x-1.4.tar.bz2) = 125990
+TIMESTAMP = 1521966069
+SHA256 (asterisk-g72x-1.4.2.tar.bz2) = 0c6cb1a61d408c882ce3fe10db4d467407ce3863f672a91aa7d3aea082a23fbc
+SIZE (asterisk-g72x-1.4.2.tar.bz2) = 125789
diff --git a/net/asterisk-g72x/files/patch-codec__g72x.c b/net/asterisk-g72x/files/patch-codec__g72x.c
deleted file mode 100644
index 57432f53805e..000000000000
--- a/net/asterisk-g72x/files/patch-codec__g72x.c
+++ /dev/null
@@ -1,41 +0,0 @@
---- codec_g72x.c.orig 2016-10-05 19:27:27 UTC
-+++ codec_g72x.c
-@@ -215,7 +215,7 @@ static int lintog72x_new(struct ast_trans_pvt *pvt)
- apiG723Encoder_Init(state->coder, G723Encode_DefaultMode);
- #endif
- #else
-- state->coder = initBcg729EncoderChannel();
-+ state->coder = initBcg729EncoderChannel(0);
- #endif
- return 0;
- }
-@@ -320,7 +320,7 @@ static int g72xtolin_framein(struct ast_trans_pvt *pvt
- #if !G72X_BCG729
- apiG729Decode(state->coder, (unsigned char *)lost_frame, g729_frame_type(0), dst + pvt->samples);
- #else
-- bcg729Decoder(state->coder, (unsigned char *)lost_frame, 1, dst + pvt->samples);
-+ bcg729Decoder(state->coder, (unsigned char *)lost_frame, 0, 1, 0, 0, dst + pvt->samples);
- #endif
- pvt->samples += G729_SAMPLES;
- pvt->datalen += 2 * G729_SAMPLES; /* 2 bytes/sample */
-@@ -339,7 +339,7 @@ static int g72xtolin_framein(struct ast_trans_pvt *pvt
- #if !G72X_BCG729
- apiG729Decode(state->coder, (unsigned char *)f->FRAME_DATA + x, g729_frame_type(framesize), dst + pvt->samples);
- #elif G72X_9
-- bcg729Decoder(state->coder, (unsigned char *)f->FRAME_DATA + x, 0, dst + pvt->samples);
-+ bcg729Decoder(state->coder, (unsigned char *)f->FRAME_DATA + x, 0, 0, framesize == 2 ? 1 : 0, 0, dst + pvt->samples);
- #endif
- pvt->samples += G729_SAMPLES;
- pvt->datalen += 2*G729_SAMPLES;
-@@ -447,8 +447,9 @@ static struct ast_frame *lintog72x_frameout(struct ast
- datalen += (g723_sendrate == G723_RATE_63) ? 24 : 20;
- #endif
- #else
-- bcg729Encoder(state->coder, state->buf + samples, (unsigned char *)(pvt->OUTBUF_G72X) + datalen);
-- datalen += G729_FRAME_LEN;
-+ uint8_t framesize;
-+ bcg729Encoder(state->coder, state->buf + samples, (unsigned char *)(pvt->OUTBUF_G72X) + datalen, &framesize);
-+ datalen += framesize; // VAD is disabled, it's G729_FRAME_LEN
- #endif
- samples += G72X_SAMPLES;
- pvt->samples -= G72X_SAMPLES;