aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-26 15:18:44 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-26 15:18:44 +0800
commit32ef21607abf49c581e59953205f21af8a10f164 (patch)
tree3b049e339ae7ba7acc4a8ad57f0c2ed9f9b8ba0d
parentea914080355ac70146fa7fbe4555237a023cceef (diff)
downloadfreebsd-ports-32ef21607abf49c581e59953205f21af8a10f164.tar.gz
freebsd-ports-32ef21607abf49c581e59953205f21af8a10f164.tar.zst
freebsd-ports-32ef21607abf49c581e59953205f21af8a10f164.zip
New port: math/py-cvxopt: Python software for convex optimization
Notes
Notes: svn path=/head/; revision=465560
-rw-r--r--math/Makefile1
-rw-r--r--math/py-cvxopt/Makefile30
-rw-r--r--math/py-cvxopt/distinfo3
-rw-r--r--math/py-cvxopt/pkg-descr9
4 files changed, 43 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index c56bfe971c6f..b24a5855152f 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -631,6 +631,7 @@
SUBDIR += py-cdecimal
SUBDIR += py-colormath
SUBDIR += py-cryptominisat
+ SUBDIR += py-cvxopt
SUBDIR += py-fastcluster
SUBDIR += py-ffc
SUBDIR += py-fiat
diff --git a/math/py-cvxopt/Makefile b/math/py-cvxopt/Makefile
new file mode 100644
index 000000000000..c94d37e21fde
--- /dev/null
+++ b/math/py-cvxopt/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= cvxopt
+DISTVERSION= 1.1.9
+CATEGORIES= math python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python software for convex optimization
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libblas.so:math/blas \
+ liblapack.so:math/lapack \
+ libumfpack.so:math/suitesparse
+
+USES= python
+USE_GITHUB= yes
+USE_PYTHON= distutils autoplist
+
+CFLAGS+= -I${LOCALBASE}/include/suitesparse
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/cvxopt/*.so
+ # workaround: empty directory is installed: https://github.com/cvxopt/cvxopt/issues/111
+ @${RMDIR} ${STAGEDIR}${PREFIX}/cvxopt
+ @${REINPLACE_CMD} -e 's|${PREFIX}/cvxopt||' ${_PYTHONPKGLIST}
+
+.include <bsd.port.mk>
diff --git a/math/py-cvxopt/distinfo b/math/py-cvxopt/distinfo
new file mode 100644
index 000000000000..42df7397411d
--- /dev/null
+++ b/math/py-cvxopt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522033973
+SHA256 (cvxopt-cvxopt-1.1.9_GH0.tar.gz) = 09997fec809179c9bb9fe8cdd202ad6ecb675f890658219022f492e0797122ee
+SIZE (cvxopt-cvxopt-1.1.9_GH0.tar.gz) = 1872932
diff --git a/math/py-cvxopt/pkg-descr b/math/py-cvxopt/pkg-descr
new file mode 100644
index 000000000000..00208a0ad4f8
--- /dev/null
+++ b/math/py-cvxopt/pkg-descr
@@ -0,0 +1,9 @@
+CVXOPT is a free software package for convex optimization based on the Python
+programming language. It can be used with the interactive Python interpreter,
+on the command line by executing Python scripts, or integrated in other software
+via Python extension modules. Its main purpose is to make the development of
+software for convex optimization applications straightforward by building on
+Python's extensive standard library and on the strengths of Python as a
+high-level programming language.
+
+WWW: https://github.com/cvxopt/cvxopt