aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-27 03:42:16 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-27 03:42:16 +0800
commit372ca09a433cadc62c50da619bb387cfb1016187 (patch)
tree683177f65c4166446ea6ba5e768590c0ea4edb7c
parent7308a63f1e6c965ae4189acb0df69118448c9427 (diff)
downloadfreebsd-ports-372ca09a433cadc62c50da619bb387cfb1016187.tar.gz
freebsd-ports-372ca09a433cadc62c50da619bb387cfb1016187.tar.zst
freebsd-ports-372ca09a433cadc62c50da619bb387cfb1016187.zip
New port: devel/py-itypes: Simple immutable types for Python
PR: 226940 Submitted by: Kai <freebsd_ports@k-worx.org>
Notes
Notes: svn path=/head/; revision=465632
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-itypes/Makefile18
-rw-r--r--devel/py-itypes/distinfo3
-rw-r--r--devel/py-itypes/pkg-descr11
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0f767e29f242..0f774bcce618 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4534,6 +4534,7 @@
SUBDIR += py-isodate
SUBDIR += py-isort
SUBDIR += py-iterpipes
+ SUBDIR += py-itypes
SUBDIR += py-jaraco.classes
SUBDIR += py-jaraco.functools
SUBDIR += py-jaraco.itertools
diff --git a/devel/py-itypes/Makefile b/devel/py-itypes/Makefile
new file mode 100644
index 000000000000..39c75c726e92
--- /dev/null
+++ b/devel/py-itypes/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= itypes
+DISTVERSION= 1.1.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= Simple immutable types for Python
+
+LICENSE= BSD2CLAUSE
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-itypes/distinfo b/devel/py-itypes/distinfo
new file mode 100644
index 000000000000..6741dc453920
--- /dev/null
+++ b/devel/py-itypes/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522057993
+SHA256 (itypes-1.1.0.tar.gz) = c6e77bb9fd68a4bfeb9d958fea421802282451a25bac4913ec94db82a899c073
+SIZE (itypes-1.1.0.tar.gz) = 2188
diff --git a/devel/py-itypes/pkg-descr b/devel/py-itypes/pkg-descr
new file mode 100644
index 000000000000..d43b53c6b2cb
--- /dev/null
+++ b/devel/py-itypes/pkg-descr
@@ -0,0 +1,11 @@
+Basic immutable container types for Python.
+
+A simple implementation that's designed for simplicity over performance.
+
+Use these in circumstances where it may result in more comprehensible code,
+or when you want to create custom types with restricted, immutable interfaces.
+
+For an alternative implementation designed for performance, please see
+"pyrsistent".
+
+WWW: https://github.com/tomchristie/itypes