aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-30 07:45:54 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-30 07:45:54 +0800
commit3cfd0e689d78623d8cd0309bf313eadd090d3296 (patch)
treea9c6957f9ed09529bd3cf070a9589a9a309d0e68
parent9bb086d8551fdd7359a988c70736c36818eb36a0 (diff)
downloadfreebsd-ports-3cfd0e689d78623d8cd0309bf313eadd090d3296.tar.gz
freebsd-ports-3cfd0e689d78623d8cd0309bf313eadd090d3296.tar.zst
freebsd-ports-3cfd0e689d78623d8cd0309bf313eadd090d3296.zip
New port: math/py-symcxx: Minimal symbolic manipulation python package written in C++
Notes
Notes: svn path=/head/; revision=465939
-rw-r--r--math/Makefile1
-rw-r--r--math/py-symcxx/Makefile26
-rw-r--r--math/py-symcxx/distinfo3
-rw-r--r--math/py-symcxx/pkg-descr7
4 files changed, 37 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index e32a243dab5a..cc46afefd348 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -676,6 +676,7 @@
SUBDIR += py-seaborn
SUBDIR += py-statsmodels
SUBDIR += py-svgmath
+ SUBDIR += py-symcxx
SUBDIR += py-symeig
SUBDIR += py-sympy
SUBDIR += py-theano
diff --git a/math/py-symcxx/Makefile b/math/py-symcxx/Makefile
new file mode 100644
index 000000000000..59496a505b58
--- /dev/null
+++ b/math/py-symcxx/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= symcxx
+DISTVERSION= 0.1.9
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Minimal symbolic manipulation python package written in C++
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYNUMPY}
+
+USES= fortran python # fortran because otherwise "import numpy" fails with wrong libgcc_s.so message
+USE_PYTHON= distutils autoplist
+
+post-patch:
+ @truncate -s 0 ${WRKSRC}/README.rst # workaround for https://github.com/bjodah/symcxx/issues/19
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/symcxx/_symcxx.so
+
+.include <bsd.port.mk>
diff --git a/math/py-symcxx/distinfo b/math/py-symcxx/distinfo
new file mode 100644
index 000000000000..014fc906bf04
--- /dev/null
+++ b/math/py-symcxx/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522365597
+SHA256 (symcxx-0.1.9.tar.gz) = 5ac726823920f3b9880fa6e32845aa6fb3d6bd9baebfa0fea2181eb9ed8a27b8
+SIZE (symcxx-0.1.9.tar.gz) = 214680
diff --git a/math/py-symcxx/pkg-descr b/math/py-symcxx/pkg-descr
new file mode 100644
index 000000000000..9e657fb39bef
--- /dev/null
+++ b/math/py-symcxx/pkg-descr
@@ -0,0 +1,7 @@
+SymCXX is an experimental Python package (with its core implemented in C++)
+for symbolic manipulation with limited scope (as in minimal). It tries to stay
+compatible with the API of SymPy. Its main goal is to explore designs related
+to automatic differentiation and numerical evaluation similar to SymEngine's
+Lambdify functionality.
+
+WWW: https://github.com/bjodah/symcxx