aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2018-03-26 23:10:49 +0800
committerMatthias Fechner <mfechner@FreeBSD.org>2018-03-26 23:10:49 +0800
commit3d94199ffdf867d5c0979b171716bccd5067beb4 (patch)
tree1d56fdbb27da3d34134ad70587a980b5bff806b8
parentba28afa06707e539a24ba87c7c113731558e8efa (diff)
downloadfreebsd-ports-3d94199ffdf867d5c0979b171716bccd5067beb4.tar.gz
freebsd-ports-3d94199ffdf867d5c0979b171716bccd5067beb4.tar.zst
freebsd-ports-3d94199ffdf867d5c0979b171716bccd5067beb4.zip
New ports required for gitlab update to 10.5.x.
Reviewed by: tz (mentor) Approved by: tz (mentor) Differential Revision: https://reviews.freebsd.org/D14840
Notes
Notes: svn path=/head/; revision=465602
-rw-r--r--databases/Makefile1
-rw-r--r--databases/rubygem-pg018/Makefile25
-rw-r--r--databases/rubygem-pg018/distinfo2
-rw-r--r--databases/rubygem-pg018/pkg-descr5
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-google-protobuf351/Makefile19
-rw-r--r--devel/rubygem-google-protobuf351/distinfo3
-rw-r--r--devel/rubygem-google-protobuf351/pkg-descr9
-rw-r--r--net/Makefile2
-rw-r--r--net/rubygem-gitaly-proto083/Makefile23
-rw-r--r--net/rubygem-gitaly-proto083/distinfo3
-rw-r--r--net/rubygem-gitaly-proto083/pkg-descr12
-rw-r--r--net/rubygem-gitaly-proto084/Makefile25
-rw-r--r--net/rubygem-gitaly-proto084/distinfo3
-rw-r--r--net/rubygem-gitaly-proto084/pkg-descr12
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-doorkeeper-openid_connect12/Makefile22
-rw-r--r--security/rubygem-doorkeeper-openid_connect12/distinfo3
-rw-r--r--security/rubygem-doorkeeper-openid_connect12/pkg-descr8
19 files changed, 179 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index ffc6aeb3c2d8..3ab9338553df 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -974,6 +974,7 @@
SUBDIR += rubygem-pg
SUBDIR += rubygem-pg_array_parser
SUBDIR += rubygem-pg0
+ SUBDIR += rubygem-pg018
SUBDIR += rubygem-pghero
SUBDIR += rubygem-pghero-rails5
SUBDIR += rubygem-pghero-rails50
diff --git a/databases/rubygem-pg018/Makefile b/databases/rubygem-pg018/Makefile
new file mode 100644
index 000000000000..bb3507a5e102
--- /dev/null
+++ b/databases/rubygem-pg018/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= pg
+PORTVERSION= 0.18.4
+CATEGORIES= databases rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 018
+
+MAINTAINER= idefix@fechner.net
+COMMENT= Ruby interface to PostgreSQL library
+
+LICENSE= BSD2CLAUSE RUBY
+LICENSE_COMB= dual
+LICENSE_FILE_BSD2CLAUSE =${WRKSRC}/BSDL
+LICENSE_FILE_RUBY =${WRKSRC}/LICENSE
+
+PORTSCOUT= limit:^0\.18\.
+
+CONFIGURE_ARGS= --with-pgsql-include-dir=`${PG_CONFIG} --includedir` \
+ --with-pgsql-lib-dir=`${PG_CONFIG} --libdir`
+PG_CONFIG= ${LOCALBASE}/bin/pg_config
+USES= gem pgsql
+USE_RUBY= yes
+
+.include <bsd.port.mk>
diff --git a/databases/rubygem-pg018/distinfo b/databases/rubygem-pg018/distinfo
new file mode 100644
index 000000000000..b2a88f17b12c
--- /dev/null
+++ b/databases/rubygem-pg018/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/pg-0.18.4.gem) = 62f0dce2fd0b3b0f684b2d60e09b3f515e7eb30f8f736bf5ede5b49e5425bb1d
+SIZE (rubygem/pg-0.18.4.gem) = 219648
diff --git a/databases/rubygem-pg018/pkg-descr b/databases/rubygem-pg018/pkg-descr
new file mode 100644
index 000000000000..d0484d1b2370
--- /dev/null
+++ b/databases/rubygem-pg018/pkg-descr
@@ -0,0 +1,5 @@
+rubygem-pg provides the module "pg", a Ruby interface to the
+PostgreSQL Relational Database Management System, which
+supersedes the old "postgres" module.
+
+WWW: https://bitbucket.org/ged/ruby-pg/wiki/Home
diff --git a/devel/Makefile b/devel/Makefile
index 528b1914583f..e41ab28bd9e4 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5499,6 +5499,7 @@
SUBDIR += rubygem-gobject-introspection
SUBDIR += rubygem-google-api-client
SUBDIR += rubygem-google-protobuf
+ SUBDIR += rubygem-google-protobuf351
SUBDIR += rubygem-googleapis-common-protos-types
SUBDIR += rubygem-graf
SUBDIR += rubygem-grape
diff --git a/devel/rubygem-google-protobuf351/Makefile b/devel/rubygem-google-protobuf351/Makefile
new file mode 100644
index 000000000000..6805befd141a
--- /dev/null
+++ b/devel/rubygem-google-protobuf351/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= google-protobuf
+PORTVERSION= 3.5.1
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 351
+
+MAINTAINER= idefix@fechner.net
+COMMENT= Ruby extension to Google Protocol Buffers
+
+LICENSE= BSD3CLAUSE
+
+PORTSCOUT= limit:^3\.5\.1
+
+USES= gem
+USE_RUBY= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-google-protobuf351/distinfo b/devel/rubygem-google-protobuf351/distinfo
new file mode 100644
index 000000000000..e6bb267dcdce
--- /dev/null
+++ b/devel/rubygem-google-protobuf351/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1515088389
+SHA256 (rubygem/google-protobuf-3.5.1.gem) = 11a3442d823bf9b2a83cee74e5ada8b1c4e4ced6592b6b96e678e6c653931169
+SIZE (rubygem/google-protobuf-3.5.1.gem) = 239616
diff --git a/devel/rubygem-google-protobuf351/pkg-descr b/devel/rubygem-google-protobuf351/pkg-descr
new file mode 100644
index 000000000000..4b7e007200a3
--- /dev/null
+++ b/devel/rubygem-google-protobuf351/pkg-descr
@@ -0,0 +1,9 @@
+rubygem-google-protobuf is a Ruby extension that implements Protocol Buffers
+functionality. It makes use of generated Ruby code that defines message and enum
+types in a Ruby DSL. You may write definitions in this DSL directly, but we
+recommend using protoc's Ruby generation support with .proto files. The build
+process in this directory only installs the extension; you need to install
+protoc as well to have Ruby code generation functionality.
+
+WWW: https://developers.google.com/protocol-buffers/
+WWW: https://github.com/google/protobuf/tree/master/ruby
diff --git a/net/Makefile b/net/Makefile
index acdbb0867173..0b38669cfed5 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1215,6 +1215,8 @@
SUBDIR += rubygem-geoip
SUBDIR += rubygem-gitaly
SUBDIR += rubygem-gitaly-proto
+ SUBDIR += rubygem-gitaly-proto083
+ SUBDIR += rubygem-gitaly-proto084
SUBDIR += rubygem-gitlab_omniauth-ldap
SUBDIR += rubygem-gitlab_omniauth-ldap1
SUBDIR += rubygem-grpc
diff --git a/net/rubygem-gitaly-proto083/Makefile b/net/rubygem-gitaly-proto083/Makefile
new file mode 100644
index 000000000000..2b4761e274e2
--- /dev/null
+++ b/net/rubygem-gitaly-proto083/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= gitaly-proto
+PORTVERSION= 0.83.0
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 083
+
+MAINTAINER= idefix@fechner.net
+COMMENT= Protobuf specifications and client libraries for Gitaly
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-google-protobuf>=3.1:devel/rubygem-google-protobuf \
+ rubygem-grpc>=1.0:net/rubygem-grpc
+
+PORTSCOUT= limit:^0\.83\.
+
+NO_ARCH= yes
+USES= gem
+USE_RUBY= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-gitaly-proto083/distinfo b/net/rubygem-gitaly-proto083/distinfo
new file mode 100644
index 000000000000..1b29b90d8f0e
--- /dev/null
+++ b/net/rubygem-gitaly-proto083/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1517316506
+SHA256 (rubygem/gitaly-proto-0.83.0.gem) = 1bf399f33d784e65538815f82d51c6e869312a7b15fe84a1d666600282d76a7c
+SIZE (rubygem/gitaly-proto-0.83.0.gem) = 15360
diff --git a/net/rubygem-gitaly-proto083/pkg-descr b/net/rubygem-gitaly-proto083/pkg-descr
new file mode 100644
index 000000000000..2886a66d5b68
--- /dev/null
+++ b/net/rubygem-gitaly-proto083/pkg-descr
@@ -0,0 +1,12 @@
+Gitaly is part of GitLab. It is a server application that uses its own gRPC
+protocol to communicate with its clients. This repository contains the protocol
+definition and automatically generated wrapper code for Go and Ruby.
+
+The .proto files define the remote procedure calls for interacting with Gitaly.
+We keep auto-generated client libraries for Ruby and Go in their respective
+subdirectories.
+
+Use the make generate script from the root of the repository to regenerate the
+client libraries after updating .proto files.
+
+WWW: https://gitlab.com/gitlab-org/gitaly-proto
diff --git a/net/rubygem-gitaly-proto084/Makefile b/net/rubygem-gitaly-proto084/Makefile
new file mode 100644
index 000000000000..233e5641a368
--- /dev/null
+++ b/net/rubygem-gitaly-proto084/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= gitaly-proto
+PORTVERSION= 0.84.0
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 084
+
+MAINTAINER= idefix@fechner.net
+COMMENT= Protobuf specifications and client libraries for Gitaly
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-google-protobuf>=3.1:devel/rubygem-google-protobuf \
+ rubygem-grpc>=1.0:net/rubygem-grpc
+
+CONFLICTS_INSTALL= rubygem-gitaly-proto
+
+PORTSCOUT= limit:^0\.84\.
+
+NO_ARCH= yes
+USES= gem
+USE_RUBY= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-gitaly-proto084/distinfo b/net/rubygem-gitaly-proto084/distinfo
new file mode 100644
index 000000000000..4baadbd2b2f9
--- /dev/null
+++ b/net/rubygem-gitaly-proto084/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1517673283
+SHA256 (rubygem/gitaly-proto-0.84.0.gem) = 885372a594214be5f4a8c49d739081551ce19d5d5b5ee207e81771b65e391417
+SIZE (rubygem/gitaly-proto-0.84.0.gem) = 15360
diff --git a/net/rubygem-gitaly-proto084/pkg-descr b/net/rubygem-gitaly-proto084/pkg-descr
new file mode 100644
index 000000000000..2886a66d5b68
--- /dev/null
+++ b/net/rubygem-gitaly-proto084/pkg-descr
@@ -0,0 +1,12 @@
+Gitaly is part of GitLab. It is a server application that uses its own gRPC
+protocol to communicate with its clients. This repository contains the protocol
+definition and automatically generated wrapper code for Go and Ruby.
+
+The .proto files define the remote procedure calls for interacting with Gitaly.
+We keep auto-generated client libraries for Ruby and Go in their respective
+subdirectories.
+
+Use the make generate script from the root of the repository to regenerate the
+client libraries after updating .proto files.
+
+WWW: https://gitlab.com/gitlab-org/gitaly-proto
diff --git a/security/Makefile b/security/Makefile
index 6a4533d0bc42..4f5fa4cd6660 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1076,6 +1076,7 @@
SUBDIR += rubygem-digest-crc
SUBDIR += rubygem-doorkeeper
SUBDIR += rubygem-doorkeeper-openid_connect
+ SUBDIR += rubygem-doorkeeper-openid_connect12
SUBDIR += rubygem-doorkeeper-rails5
SUBDIR += rubygem-doorkeeper-rails50
SUBDIR += rubygem-encryptor
diff --git a/security/rubygem-doorkeeper-openid_connect12/Makefile b/security/rubygem-doorkeeper-openid_connect12/Makefile
new file mode 100644
index 000000000000..7a0390573199
--- /dev/null
+++ b/security/rubygem-doorkeeper-openid_connect12/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= doorkeeper-openid_connect
+PORTVERSION= 1.2.0
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 12
+
+MAINTAINER= idefix@fechner.net
+COMMENT= OpenID Connect extension for Doorkeeper
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-doorkeeper>=4.3:security/rubygem-doorkeeper \
+ rubygem-json-jwt>=1.6:www/rubygem-json-jwt
+
+NO_ARCH= yes
+USES= gem
+USE_RUBY= yes
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-doorkeeper-openid_connect12/distinfo b/security/rubygem-doorkeeper-openid_connect12/distinfo
new file mode 100644
index 000000000000..6081bcabab79
--- /dev/null
+++ b/security/rubygem-doorkeeper-openid_connect12/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1509091724
+SHA256 (rubygem/doorkeeper-openid_connect-1.2.0.gem) = 47a0d2ad6738456fd728f079bb6decd88df816ffc26323624652e61732ed608e
+SIZE (rubygem/doorkeeper-openid_connect-1.2.0.gem) = 20480
diff --git a/security/rubygem-doorkeeper-openid_connect12/pkg-descr b/security/rubygem-doorkeeper-openid_connect12/pkg-descr
new file mode 100644
index 000000000000..08e1bdfa4f11
--- /dev/null
+++ b/security/rubygem-doorkeeper-openid_connect12/pkg-descr
@@ -0,0 +1,8 @@
+Implements an OpenID Connect authentication provider for Rails applications on
+top of the Doorkeeper OAuth 2.0 framework.
+
+OpenID Connect is a single-sign-on and identity layer with a growing list of
+server and client implementations. If you're looking for a client in Ruby check
+out omniauth-openid-connect.
+
+WWW: https://github.com/doorkeeper-gem/doorkeeper-openid_connect