aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-27 03:49:46 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-27 03:49:46 +0800
commit40e6a5b9dfc4cef66c3631d7b4e29602f7ddc752 (patch)
tree64a7ff866e312f26ee5f125159c8437d425a3897
parent372ca09a433cadc62c50da619bb387cfb1016187 (diff)
downloadfreebsd-ports-40e6a5b9dfc4cef66c3631d7b4e29602f7ddc752.tar.gz
freebsd-ports-40e6a5b9dfc4cef66c3631d7b4e29602f7ddc752.tar.zst
freebsd-ports-40e6a5b9dfc4cef66c3631d7b4e29602f7ddc752.zip
New port: devel/py-coreapi: Python client library for Core API
PR: 226943 Submitted by: Kai <freebsd_ports@k-worx.org>
Notes
Notes: svn path=/head/; revision=465633
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-coreapi/Makefile24
-rw-r--r--devel/py-coreapi/distinfo3
-rw-r--r--devel/py-coreapi/pkg-descr4
4 files changed, 32 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0f774bcce618..205a4bb74ecb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4362,6 +4362,7 @@
SUBDIR += py-construct
SUBDIR += py-construct28
SUBDIR += py-contextlib2
+ SUBDIR += py-coreapi
SUBDIR += py-coreschema
SUBDIR += py-country
SUBDIR += py-cov-core
diff --git a/devel/py-coreapi/Makefile b/devel/py-coreapi/Makefile
new file mode 100644
index 000000000000..8c85753e5a82
--- /dev/null
+++ b/devel/py-coreapi/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= coreapi
+DISTVERSION= 2.3.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= Python client library for Core API
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}coreschema>0:devel/py-coreschema@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}itypes>0:devel/py-itypes@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}uritemplate>0:net/py-uritemplate@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-coreapi/distinfo b/devel/py-coreapi/distinfo
new file mode 100644
index 000000000000..99a6b2c2a30f
--- /dev/null
+++ b/devel/py-coreapi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522053773
+SHA256 (coreapi-2.3.3.tar.gz) = 46145fcc1f7017c076a2ef684969b641d18a2991051fddec9458ad3f78ffc1cb
+SIZE (coreapi-2.3.3.tar.gz) = 18788
diff --git a/devel/py-coreapi/pkg-descr b/devel/py-coreapi/pkg-descr
new file mode 100644
index 000000000000..b4650f00c92e
--- /dev/null
+++ b/devel/py-coreapi/pkg-descr
@@ -0,0 +1,4 @@
+Python client library for the Core API, a format-independent Document Object
+Model for representing Web APIs.
+
+WWW: https://github.com/core-api/python-client