aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-03-26 02:05:18 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-03-26 02:05:18 +0800
commit44ff203801393d213b4fe0400ad14ead923bf3cc (patch)
tree9187f37d3020ebc0a7381ee3946702d106811fd0
parent52f067291781c701e29cb0a5399588bf73de4289 (diff)
downloadfreebsd-ports-44ff203801393d213b4fe0400ad14ead923bf3cc.tar.gz
freebsd-ports-44ff203801393d213b4fe0400ad14ead923bf3cc.tar.zst
freebsd-ports-44ff203801393d213b4fe0400ad14ead923bf3cc.zip
Add py-pip-tools 1.11.0
pip-tools = pip-compile + pip-sync It is a set of command line tools to help you keep your pip-based packages fresh, even when you've pinned them. WWW: https://pypi.python.org/pypi/pip-tools WWW: https://github.com/jazzband/pip-tools
Notes
Notes: svn path=/head/; revision=465536
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pip-tools/Makefile26
-rw-r--r--devel/py-pip-tools/distinfo3
-rw-r--r--devel/py-pip-tools/pkg-descr7
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index dac71f8fd82c..aa3d493705cc 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4715,6 +4715,7 @@
SUBDIR += py-pika-pool
SUBDIR += py-pinocchio
SUBDIR += py-pip
+ SUBDIR += py-pip-tools
SUBDIR += py-pipenv
SUBDIR += py-pkgconfig
SUBDIR += py-plan
diff --git a/devel/py-pip-tools/Makefile b/devel/py-pip-tools/Makefile
new file mode 100644
index 000000000000..9916aaacb838
--- /dev/null
+++ b/devel/py-pip-tools/Makefile
@@ -0,0 +1,26 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pip-tools
+PORTVERSION= 1.11.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Keep your pinned dependencies fresh
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=6:devel/py-click@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}first>=0:devel/py-first@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${FLAVOR}
+
+NO_ARCH= yes
+USE_LOCALE= en_US.UTF-8
+USE_PYTHON= autoplist concurrent distutils
+USES= python
+
+.include <bsd.port.mk>
diff --git a/devel/py-pip-tools/distinfo b/devel/py-pip-tools/distinfo
new file mode 100644
index 000000000000..0809ad6c9c88
--- /dev/null
+++ b/devel/py-pip-tools/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1521943579
+SHA256 (pip-tools-1.11.0.tar.gz) = ba427b68443466c389e3b0b0ef55f537ab39344190ea980dfebb333d0e6a50a3
+SIZE (pip-tools-1.11.0.tar.gz) = 83201
diff --git a/devel/py-pip-tools/pkg-descr b/devel/py-pip-tools/pkg-descr
new file mode 100644
index 000000000000..cf5565a4fe2e
--- /dev/null
+++ b/devel/py-pip-tools/pkg-descr
@@ -0,0 +1,7 @@
+pip-tools = pip-compile + pip-sync
+
+It is a set of command line tools to help you keep your pip-based packages
+fresh, even when you've pinned them.
+
+WWW: https://pypi.python.org/pypi/pip-tools
+WWW: https://github.com/jazzband/pip-tools