aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-03-26 02:04:09 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-03-26 02:04:09 +0800
commit479dc75220183ec3045c293fa13ab40bc12d5d50 (patch)
treec2840a682524bdbc5b23a8623ec788006605e3cf
parent0c065e2745707343a5adc2a1292183b060ef3406 (diff)
downloadfreebsd-ports-479dc75220183ec3045c293fa13ab40bc12d5d50.tar.gz
freebsd-ports-479dc75220183ec3045c293fa13ab40bc12d5d50.tar.zst
freebsd-ports-479dc75220183ec3045c293fa13ab40bc12d5d50.zip
Add py-first 2.0.1
first is an MIT licensed Python package with a simple function that returns the first true value from an iterable, or None if there is none. If you need more power, you can also supply a key function that is used to judge the truth value of the element or a default value if None doesn’t fit your use case. WWW: https://pypi.python.org/pypi/first WWW: https://github.com/hynek/first
Notes
Notes: svn path=/head/; revision=465533
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-first/Makefile20
-rw-r--r--devel/py-first/distinfo3
-rw-r--r--devel/py-first/pkg-descr7
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 231ccdffb7ec..26707dc7e115 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4438,6 +4438,7 @@
SUBDIR += py-fastnumbers
SUBDIR += py-filemagic
SUBDIR += py-fileutils
+ SUBDIR += py-first
SUBDIR += py-five.customerize
SUBDIR += py-five.formlib
SUBDIR += py-five.globalrequest
diff --git a/devel/py-first/Makefile b/devel/py-first/Makefile
new file mode 100644
index 000000000000..5a04035347a9
--- /dev/null
+++ b/devel/py-first/Makefile
@@ -0,0 +1,20 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= first
+PORTVERSION= 2.0.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Return the first true value of an iterable
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+NO_ARCH= yes
+USE_PYTHON= autoplist concurrent distutils
+USES= python
+
+.include <bsd.port.mk>
diff --git a/devel/py-first/distinfo b/devel/py-first/distinfo
new file mode 100644
index 000000000000..d92ba14f1fd3
--- /dev/null
+++ b/devel/py-first/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1521943705
+SHA256 (first-2.0.1.tar.gz) = 3bb3de3582cb27071cfb514f00ed784dc444b7f96dc21e140de65fe00585c95e
+SIZE (first-2.0.1.tar.gz) = 5325
diff --git a/devel/py-first/pkg-descr b/devel/py-first/pkg-descr
new file mode 100644
index 000000000000..95df989b8989
--- /dev/null
+++ b/devel/py-first/pkg-descr
@@ -0,0 +1,7 @@
+first is an MIT licensed Python package with a simple function that returns the
+first true value from an iterable, or None if there is none. If you need more
+power, you can also supply a key function that is used to judge the truth value
+of the element or a default value if None doesn’t fit your use case.
+
+WWW: https://pypi.python.org/pypi/first
+WWW: https://github.com/hynek/first