aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-30 05:16:56 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-30 05:16:56 +0800
commit557cda5882fae360c29ff14a39b12ab7f1895cda (patch)
tree18b24e9787c91050defb81520721d978e4337c7f
parentf8e32f885c33769e37f18082efdbdd28e7f58c93 (diff)
downloadfreebsd-ports-557cda5882fae360c29ff14a39b12ab7f1895cda.tar.gz
freebsd-ports-557cda5882fae360c29ff14a39b12ab7f1895cda.tar.zst
freebsd-ports-557cda5882fae360c29ff14a39b12ab7f1895cda.zip
New port: devel/py-strategies: Programmatic control flow
Notes
Notes: svn path=/head/; revision=465930
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-strategies/Makefile22
-rw-r--r--devel/py-strategies/distinfo3
-rw-r--r--devel/py-strategies/pkg-descr4
4 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 73d42db55647..041d373719b1 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4945,6 +4945,7 @@
SUBDIR += py-stdnum
SUBDIR += py-stevedore
SUBDIR += py-stopit
+ SUBDIR += py-strategies
SUBDIR += py-streamparse
SUBDIR += py-structlog
SUBDIR += py-stsci.distutils
diff --git a/devel/py-strategies/Makefile b/devel/py-strategies/Makefile
new file mode 100644
index 000000000000..3ba65adf23a4
--- /dev/null
+++ b/devel/py-strategies/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= strategies
+DISTVERSION= 0.2.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Programmatic control flow
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}multipledispatch>0:devel/py-multipledispatch@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}toolz>0:devel/py-toolz@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-strategies/distinfo b/devel/py-strategies/distinfo
new file mode 100644
index 000000000000..0df729dc054a
--- /dev/null
+++ b/devel/py-strategies/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522357603
+SHA256 (strategies-0.2.3.tar.gz) = 488c55a5d7f887c5290f03209e11622f5da4e754826eb123bac1cca473f3240a
+SIZE (strategies-0.2.3.tar.gz) = 6373
diff --git a/devel/py-strategies/pkg-descr b/devel/py-strategies/pkg-descr
new file mode 100644
index 000000000000..8625b2301aec
--- /dev/null
+++ b/devel/py-strategies/pkg-descr
@@ -0,0 +1,4 @@
+This project contains a set of complementary higher order functions that
+loosely resembles the Stratego language.
+
+WWW: http://github.com/logpy/strategies