aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-28 06:13:15 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-28 06:13:15 +0800
commit591c20ec75145fa5944afee2a94e1c03ac9d3151 (patch)
treec167aecd2250d8c41eb87ac2b1c862e196fdeb80
parent19cc258e4456e392520f5a21c353b635ff1e0f72 (diff)
downloadfreebsd-ports-591c20ec75145fa5944afee2a94e1c03ac9d3151.tar.gz
freebsd-ports-591c20ec75145fa5944afee2a94e1c03ac9d3151.tar.zst
freebsd-ports-591c20ec75145fa5944afee2a94e1c03ac9d3151.zip
New port: www/py-django-js-asset: Insert script tags with additional attributes for django.forms.Media
While here, fixed minor sorting probems in www/Makefile. PR: 227015 Submitted by: Kai <freebsd_ports@k-worx.org>
Notes
Notes: svn path=/head/; revision=465768
-rw-r--r--www/Makefile5
-rw-r--r--www/py-django-js-asset/Makefile21
-rw-r--r--www/py-django-js-asset/distinfo3
-rw-r--r--www/py-django-js-asset/pkg-descr4
4 files changed, 31 insertions, 2 deletions
diff --git a/www/Makefile b/www/Makefile
index addb788ba77e..03db03ed6aad 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1582,6 +1582,7 @@
SUBDIR += py-django-haystack
SUBDIR += py-django-hijack
SUBDIR += py-django-htmlmin
+ SUBDIR += py-django-js-asset
SUBDIR += py-django-json-rpc
SUBDIR += py-django-jsonfield
SUBDIR += py-django-keyedcache
@@ -2028,10 +2029,10 @@
SUBDIR += rubygem-haml-rails-rails4
SUBDIR += rubygem-haml4
SUBDIR += rubygem-hamlit
- SUBDIR += rubygem-hamlit26
SUBDIR += rubygem-hamlit-rails
SUBDIR += rubygem-hamlit-rails-rails5
SUBDIR += rubygem-hamlit-rails-rails50
+ SUBDIR += rubygem-hamlit26
SUBDIR += rubygem-hashicorp-checkpoint
SUBDIR += rubygem-heroku
SUBDIR += rubygem-heroku-api
@@ -2204,9 +2205,9 @@
SUBDIR += rubygem-uglifier27
SUBDIR += rubygem-underscore-rails
SUBDIR += rubygem-unicorn
- SUBDIR += rubygem-unicorn51
SUBDIR += rubygem-unicorn-worker-killer
SUBDIR += rubygem-unicorn-worker-killer044
+ SUBDIR += rubygem-unicorn51
SUBDIR += rubygem-url_escape
SUBDIR += rubygem-url_mount
SUBDIR += rubygem-vegas
diff --git a/www/py-django-js-asset/Makefile b/www/py-django-js-asset/Makefile
new file mode 100644
index 000000000000..2c31a32dd678
--- /dev/null
+++ b/www/py-django-js-asset/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= django-js-asset
+DISTVERSION= 1.0.0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= Insert script tags with additional attributes for django.forms.Media
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django>0:www/py-django@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-django-js-asset/distinfo b/www/py-django-js-asset/distinfo
new file mode 100644
index 000000000000..ef34c645b238
--- /dev/null
+++ b/www/py-django-js-asset/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522167059
+SHA256 (django-js-asset-1.0.0.tar.gz) = 38fc1de7a93a2f667fe7ee34acc53d682bac5ce6c73ac6f0ecb4ff77d0f61f1b
+SIZE (django-js-asset-1.0.0.tar.gz) = 4104
diff --git a/www/py-django-js-asset/pkg-descr b/www/py-django-js-asset/pkg-descr
new file mode 100644
index 000000000000..1b3c52191784
--- /dev/null
+++ b/www/py-django-js-asset/pkg-descr
@@ -0,0 +1,4 @@
+Insert script tags with additional attributes (such as "id" and "data" for
+CSP-compatible data injection) for the django.forms.Media package.
+
+WWW: https://github.com/matthiask/django-js-asset