aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-24 04:01:36 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-24 04:01:36 +0800
commit60cfc6b9fabb073a7b5623f9b6fd8075adcaac77 (patch)
tree7e387d26bf83a2c8c1c0f695cb96d078c42052ed
parent8d5bc3ff008144b8a2131e1967be6f2d809108c1 (diff)
downloadfreebsd-ports-60cfc6b9fabb073a7b5623f9b6fd8075adcaac77.tar.gz
freebsd-ports-60cfc6b9fabb073a7b5623f9b6fd8075adcaac77.tar.zst
freebsd-ports-60cfc6b9fabb073a7b5623f9b6fd8075adcaac77.zip
New port: devel/py-minio: Minio library for Amazon S3 compatible cloud storage
PR: 226877 Submitted by: jhixson@gmail.com
Notes
Notes: svn path=/head/; revision=465401
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-minio/Makefile23
-rw-r--r--devel/py-minio/distinfo3
-rw-r--r--devel/py-minio/files/patch-setup.py11
-rw-r--r--devel/py-minio/pkg-descr4
5 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0515d6eb6b1a..d399ccf7e6ca 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4615,6 +4615,7 @@
SUBDIR += py-microversion-parse
SUBDIR += py-mimeparse
SUBDIR += py-minimongo
+ SUBDIR += py-minio
SUBDIR += py-mock
SUBDIR += py-mongoengine
SUBDIR += py-mongokit
diff --git a/devel/py-minio/Makefile b/devel/py-minio/Makefile
new file mode 100644
index 000000000000..46b77663af2e
--- /dev/null
+++ b/devel/py-minio/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= minio
+DISTVERSION= 3.0.4
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jhixson@gmail.com
+COMMENT= Minio library for Amazon S3 compatible cloud storage
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}certifi>=0:security/py-certifi@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}urllib3>0:net/py-urllib3@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-minio/distinfo b/devel/py-minio/distinfo
new file mode 100644
index 000000000000..728a796b7b86
--- /dev/null
+++ b/devel/py-minio/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1521833363
+SHA256 (minio-3.0.4.tar.gz) = 5d4d086726bb7800570a86a040c607793235e190299f0d18aa0d2277492f393b
+SIZE (minio-3.0.4.tar.gz) = 42720
diff --git a/devel/py-minio/files/patch-setup.py b/devel/py-minio/files/patch-setup.py
new file mode 100644
index 000000000000..7e63bbb5ea3b
--- /dev/null
+++ b/devel/py-minio/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2018-03-23 19:57:54 UTC
++++ setup.py
+@@ -64,7 +64,7 @@ setup(
+ packages=packages,
+ install_requires=requires,
+ tests_require=tests_requires,
+- setup_requires=['nose>=1.0'],
++ #setup_requires=['nose>=1.0'],
+ license='Apache License 2.0',
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
diff --git a/devel/py-minio/pkg-descr b/devel/py-minio/pkg-descr
new file mode 100644
index 000000000000..eb93a8bdddda
--- /dev/null
+++ b/devel/py-minio/pkg-descr
@@ -0,0 +1,4 @@
+The Minio Python Client SDK provides simple APIs to access any Amazon
+S3 compatible object storage server.
+
+WWW: https://github.com/minio/minio-py