aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlivier Cochard <olivier@FreeBSD.org>2018-03-29 05:22:58 +0800
committerOlivier Cochard <olivier@FreeBSD.org>2018-03-29 05:22:58 +0800
commit612e5c005c2c51ab1aea6b389aa2d851805cbf91 (patch)
tree0d1cad8a06b7d8eed97533c76c026473b2b59cac
parentaacbf40bfc96744a4df567ff1dd7eff05cda7691 (diff)
downloadfreebsd-ports-612e5c005c2c51ab1aea6b389aa2d851805cbf91.tar.gz
freebsd-ports-612e5c005c2c51ab1aea6b389aa2d851805cbf91.tar.zst
freebsd-ports-612e5c005c2c51ab1aea6b389aa2d851805cbf91.zip
Forgot to port BGP MD5 patch into -devel branch
Notes
Notes: svn path=/head/; revision=465848
-rw-r--r--net/bird-devel/Makefile1
-rw-r--r--net/bird-devel/files/patch-sysdep_bsd_setkey.h19
2 files changed, 20 insertions, 0 deletions
diff --git a/net/bird-devel/Makefile b/net/bird-devel/Makefile
index b9405c297c8e..82512475cbaf 100644
--- a/net/bird-devel/Makefile
+++ b/net/bird-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= bird
DISTVERSION= 2.0.2
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://bird.network.cz/pub/bird/
PKGNAMESUFFIX= -devel
diff --git a/net/bird-devel/files/patch-sysdep_bsd_setkey.h b/net/bird-devel/files/patch-sysdep_bsd_setkey.h
new file mode 100644
index 000000000000..cbd4b5e2f733
--- /dev/null
+++ b/net/bird-devel/files/patch-sysdep_bsd_setkey.h
@@ -0,0 +1,19 @@
+--- sysdep/bsd/setkey.h.orig 2018-01-16 09:46:07 UTC
++++ sysdep/bsd/setkey.h
+@@ -160,12 +160,14 @@ sk_set_md5_in_sasp_db(sock *s, ip_addr local, ip_addr
+ if (len > TCP_KEYLEN_MAX)
+ ERR_MSG("The password for TCP MD5 Signature is too long");
+
+- if (setkey_md5(&src, &dst, pxlen, passwd, SADB_ADD) < 0)
++ if (setkey_md5(&src, &dst, pxlen, passwd, SADB_ADD) < 0 ||
++ setkey_md5(&dst, &src, pxlen, passwd, SADB_ADD) < 0)
+ ERR_MSG("Cannot add TCP-MD5 password into the IPsec SA/SP database");
+ }
+ else
+ {
+- if (setkey_md5(&src, &dst, pxlen, NULL, SADB_DELETE) < 0)
++ if (setkey_md5(&src, &dst, pxlen, NULL, SADB_DELETE) < 0 ||
++ setkey_md5(&dst, &src, pxlen, NULL, SADB_DELETE) < 0)
+ ERR_MSG("Cannot delete TCP-MD5 password from the IPsec SA/SP database");
+ }
+ return 0;