aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-24 07:19:53 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-24 07:19:53 +0800
commit6cdf7766c9123694d979fb46e794245deed9330f (patch)
treedcbc3f473ca24ad88ab783833298e23023348917
parent32455fd010511302be9cfa0fa4d463308b969249 (diff)
downloadfreebsd-ports-6cdf7766c9123694d979fb46e794245deed9330f.tar.gz
freebsd-ports-6cdf7766c9123694d979fb46e794245deed9330f.tar.zst
freebsd-ports-6cdf7766c9123694d979fb46e794245deed9330f.zip
sysutils/exfat-utils sysutils/fusefs-exfat: Update 1.2.7 -> 1.2.8
Also grouped USExx. PR: 226699 Submitted by: samm@os2.kiev.ua (maintainer)
Notes
Notes: svn path=/head/; revision=465414
-rw-r--r--sysutils/exfat-utils/Makefile5
-rw-r--r--sysutils/exfat-utils/distinfo6
-rw-r--r--sysutils/exfat-utils/files/patch-ublio26
-rw-r--r--sysutils/fusefs-exfat/Makefile5
-rw-r--r--sysutils/fusefs-exfat/distinfo6
-rw-r--r--sysutils/fusefs-exfat/files/patch-ublio26
6 files changed, 36 insertions, 38 deletions
diff --git a/sysutils/exfat-utils/Makefile b/sysutils/exfat-utils/Makefile
index dda4a140d42d..475ab80caff7 100644
--- a/sysutils/exfat-utils/Makefile
+++ b/sysutils/exfat-utils/Makefile
@@ -3,7 +3,7 @@
PORTNAME= exfat
DISTVERSIONPREFIX= v
-DISTVERSION= 1.2.7
+DISTVERSION= 1.2.8
CATEGORIES= sysutils
PKGNAMESUFFIX= -utils
@@ -23,10 +23,9 @@ LICENSE_PERMS_MSPAT= no-dist-mirror no-dist-sell no-pkg-mirror no-pkg-sell
LIB_DEPENDS= libublio.so:devel/libublio
+USES= autoreconf localbase pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= relan
-
-USES= autoreconf localbase pkgconfig
GNU_CONFIGURE= yes
PLIST_FILES= sbin/exfatlabel sbin/dumpexfat sbin/exfatfsck sbin/mkexfatfs \
diff --git a/sysutils/exfat-utils/distinfo b/sysutils/exfat-utils/distinfo
index 366ff46dafd3..81e96cf87926 100644
--- a/sysutils/exfat-utils/distinfo
+++ b/sysutils/exfat-utils/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1514448316
-SHA256 (relan-exfat-v1.2.7_GH0.tar.gz) = bf9b26ed5002a45da75a9fba3bc5aafa67031addad205016c35141beb3c7f6b5
-SIZE (relan-exfat-v1.2.7_GH0.tar.gz) = 55796
+TIMESTAMP = 1521383513
+SHA256 (relan-exfat-v1.2.8_GH0.tar.gz) = 778474bfbcd92e35bba5b88bd7ad3f6400328256636abb9031bfcc1ce15ed887
+SIZE (relan-exfat-v1.2.8_GH0.tar.gz) = 55911
diff --git a/sysutils/exfat-utils/files/patch-ublio b/sysutils/exfat-utils/files/patch-ublio
index afa1410e16e2..65d36a69bf5c 100644
--- a/sysutils/exfat-utils/files/patch-ublio
+++ b/sysutils/exfat-utils/files/patch-ublio
@@ -31,12 +31,12 @@ index b45db3f..2bcda4b 100644
AC_CONFIG_FILES([
diff --git libexfat/io.c libexfat/io.c
index 60f28e2..14c0151 100644
---- libexfat/io.c
-+++ libexfat/io.c
-@@ -37,12 +37,20 @@
- #include <sys/ioctl.h>
- #endif
+--- libexfat/io.c 2018-02-03 09:01:42.000000000 +0100
++++ libexfat/io.c 2018-03-18 15:45:43.573290677 +0100
+@@ -38,12 +38,20 @@
+ #elif __linux__
#include <sys/mount.h>
+ #endif
+#ifdef USE_UBLIO
+#include <sys/uio.h>
+#include <ublio.h>
@@ -53,8 +53,8 @@ index 60f28e2..14c0151 100644
+#endif
};
- static int open_ro(const char* spec)
-@@ -74,6 +82,9 @@ struct exfat_dev* exfat_open(const char* spec, enum exfat_mode mode)
+ static bool is_open(int fd)
+@@ -80,6 +88,9 @@
{
struct exfat_dev* dev;
struct stat stbuf;
@@ -62,9 +62,9 @@ index 60f28e2..14c0151 100644
+ struct ublio_param up;
+#endif
- dev = malloc(sizeof(struct exfat_dev));
- if (dev == NULL)
-@@ -211,6 +222,24 @@ struct exfat_dev* exfat_open(const char* spec, enum exfat_mode mode)
+ /* The system allocates file descriptors sequentially. If we have been
+ started with stdin (0), stdout (1) or stderr (2) closed, the system
+@@ -235,6 +246,24 @@
}
}
@@ -89,7 +89,7 @@ index 60f28e2..14c0151 100644
return dev;
}
-@@ -218,6 +247,13 @@ int exfat_close(struct exfat_dev* dev)
+@@ -242,6 +271,13 @@
{
int rc = 0;
@@ -103,7 +103,7 @@ index 60f28e2..14c0151 100644
if (close(dev->fd) != 0)
{
exfat_error("failed to close device: %s", strerror(errno));
-@@ -231,6 +267,13 @@ int exfat_fsync(struct exfat_dev* dev)
+@@ -255,6 +291,13 @@
{
int rc = 0;
@@ -117,7 +117,7 @@ index 60f28e2..14c0151 100644
if (fsync(dev->fd) != 0)
{
exfat_error("fsync failed: %s", strerror(errno));
-@@ -251,29 +294,56 @@ off_t exfat_get_size(const struct exfat_dev* dev)
+@@ -275,29 +318,56 @@
off_t exfat_seek(struct exfat_dev* dev, off_t offset, int whence)
{
diff --git a/sysutils/fusefs-exfat/Makefile b/sysutils/fusefs-exfat/Makefile
index 29f79af449d4..63519b7e09fc 100644
--- a/sysutils/fusefs-exfat/Makefile
+++ b/sysutils/fusefs-exfat/Makefile
@@ -3,7 +3,7 @@
PORTNAME= exfat
DISTVERSIONPREFIX= v
-DISTVERSION= 1.2.7
+DISTVERSION= 1.2.8
CATEGORIES= sysutils
PKGNAMEPREFIX= fusefs-
@@ -23,10 +23,9 @@ LICENSE_PERMS_MSPAT= no-dist-mirror no-dist-sell no-pkg-mirror no-pkg-sell
LIB_DEPENDS= libublio.so:devel/libublio
+USES= autoreconf fuse localbase pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= relan
-
-USES= autoreconf fuse localbase pkgconfig
GNU_CONFIGURE= yes
MAKE_ARGS= SUBDIRS="libexfat fuse"
diff --git a/sysutils/fusefs-exfat/distinfo b/sysutils/fusefs-exfat/distinfo
index a7feed379f66..f91a3e0b187d 100644
--- a/sysutils/fusefs-exfat/distinfo
+++ b/sysutils/fusefs-exfat/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1514453447
-SHA256 (relan-exfat-v1.2.7_GH0.tar.gz) = bf9b26ed5002a45da75a9fba3bc5aafa67031addad205016c35141beb3c7f6b5
-SIZE (relan-exfat-v1.2.7_GH0.tar.gz) = 55796
+TIMESTAMP = 1521383763
+SHA256 (relan-exfat-v1.2.8_GH0.tar.gz) = 778474bfbcd92e35bba5b88bd7ad3f6400328256636abb9031bfcc1ce15ed887
+SIZE (relan-exfat-v1.2.8_GH0.tar.gz) = 55911
diff --git a/sysutils/fusefs-exfat/files/patch-ublio b/sysutils/fusefs-exfat/files/patch-ublio
index afa1410e16e2..65d36a69bf5c 100644
--- a/sysutils/fusefs-exfat/files/patch-ublio
+++ b/sysutils/fusefs-exfat/files/patch-ublio
@@ -31,12 +31,12 @@ index b45db3f..2bcda4b 100644
AC_CONFIG_FILES([
diff --git libexfat/io.c libexfat/io.c
index 60f28e2..14c0151 100644
---- libexfat/io.c
-+++ libexfat/io.c
-@@ -37,12 +37,20 @@
- #include <sys/ioctl.h>
- #endif
+--- libexfat/io.c 2018-02-03 09:01:42.000000000 +0100
++++ libexfat/io.c 2018-03-18 15:45:43.573290677 +0100
+@@ -38,12 +38,20 @@
+ #elif __linux__
#include <sys/mount.h>
+ #endif
+#ifdef USE_UBLIO
+#include <sys/uio.h>
+#include <ublio.h>
@@ -53,8 +53,8 @@ index 60f28e2..14c0151 100644
+#endif
};
- static int open_ro(const char* spec)
-@@ -74,6 +82,9 @@ struct exfat_dev* exfat_open(const char* spec, enum exfat_mode mode)
+ static bool is_open(int fd)
+@@ -80,6 +88,9 @@
{
struct exfat_dev* dev;
struct stat stbuf;
@@ -62,9 +62,9 @@ index 60f28e2..14c0151 100644
+ struct ublio_param up;
+#endif
- dev = malloc(sizeof(struct exfat_dev));
- if (dev == NULL)
-@@ -211,6 +222,24 @@ struct exfat_dev* exfat_open(const char* spec, enum exfat_mode mode)
+ /* The system allocates file descriptors sequentially. If we have been
+ started with stdin (0), stdout (1) or stderr (2) closed, the system
+@@ -235,6 +246,24 @@
}
}
@@ -89,7 +89,7 @@ index 60f28e2..14c0151 100644
return dev;
}
-@@ -218,6 +247,13 @@ int exfat_close(struct exfat_dev* dev)
+@@ -242,6 +271,13 @@
{
int rc = 0;
@@ -103,7 +103,7 @@ index 60f28e2..14c0151 100644
if (close(dev->fd) != 0)
{
exfat_error("failed to close device: %s", strerror(errno));
-@@ -231,6 +267,13 @@ int exfat_fsync(struct exfat_dev* dev)
+@@ -255,6 +291,13 @@
{
int rc = 0;
@@ -117,7 +117,7 @@ index 60f28e2..14c0151 100644
if (fsync(dev->fd) != 0)
{
exfat_error("fsync failed: %s", strerror(errno));
-@@ -251,29 +294,56 @@ off_t exfat_get_size(const struct exfat_dev* dev)
+@@ -275,29 +318,56 @@
off_t exfat_seek(struct exfat_dev* dev, off_t offset, int whence)
{