aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuangyuan Yang <ygy@FreeBSD.org>2018-03-24 14:43:29 +0800
committerGuangyuan Yang <ygy@FreeBSD.org>2018-03-24 14:43:29 +0800
commit6e3314f231adf21e7ecb908ba645187d55b36500 (patch)
treea0232cd7e26176bd3e06ca532d89c835e14d9226
parent1a0cc25e3fe5d7008442fb48f888c7a3600f0200 (diff)
downloadfreebsd-ports-6e3314f231adf21e7ecb908ba645187d55b36500.tar.gz
freebsd-ports-6e3314f231adf21e7ecb908ba645187d55b36500.tar.zst
freebsd-ports-6e3314f231adf21e7ecb908ba645187d55b36500.zip
- Add websocketd 0.3.0
websocketd is the WebSocket daemon. It takes care of handling the WebSocket connections, launching your programs to handle the WebSockets, and passing messages between programs and web-browser. PR: 226867 Approved by: adamw
Notes
Notes: svn path=/head/; revision=465429
-rw-r--r--www/Makefile1
-rw-r--r--www/websocketd/Makefile26
-rw-r--r--www/websocketd/distinfo5
-rw-r--r--www/websocketd/pkg-descr8
4 files changed, 40 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 0781022776b4..a3d603b80585 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -2453,6 +2453,7 @@
SUBDIR += webreport
SUBDIR += webresolve
SUBDIR += websh
+ SUBDIR += websocketd
SUBDIR += webstats
SUBDIR += webstone
SUBDIR += webstone-ssl
diff --git a/www/websocketd/Makefile b/www/websocketd/Makefile
new file mode 100644
index 000000000000..c352d440a5c1
--- /dev/null
+++ b/www/websocketd/Makefile
@@ -0,0 +1,26 @@
+# Created by: Guangyuan Yang <ygy@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= websocketd
+DISTVERSION= 0.3.0
+CATEGORIES= www
+MASTER_SITES= https://github.com/joewalnes/${PORTNAME}/releases/download/v${DISTVERSION}/
+DISTNAME= ${PORTNAME}-${DISTVERSION}-freebsd_${ARCH:S/i386/386/:S/x86_64/amd64/}
+
+MAINTAINER= ygy@FreeBSD.org
+COMMENT= Access any command-line tool via a WebSocket
+
+LICENSE= BSD2CLAUSE
+
+ONLY_FOR_ARCHS= amd64 i386
+
+NO_WRKSUBDIR= yes
+PLIST_FILES= bin/${PORTNAME}
+
+NO_BUILD= yes
+USES= zip
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/www/websocketd/distinfo b/www/websocketd/distinfo
new file mode 100644
index 000000000000..29a6bf374d0a
--- /dev/null
+++ b/www/websocketd/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1521782495
+SHA256 (websocketd-0.3.0-freebsd_amd64.zip) = 89e3c0b007a643c870c6b59eecb611cb0757780fcabe402bbb6cbb190ab478be
+SIZE (websocketd-0.3.0-freebsd_amd64.zip) = 2555193
+SHA256 (websocketd-0.3.0-freebsd_386.zip) = b5de6e70273ba0be28b9ee3c76491f6502045def69c8acdf0db5142502439f1e
+SIZE (websocketd-0.3.0-freebsd_386.zip) = 2404543
diff --git a/www/websocketd/pkg-descr b/www/websocketd/pkg-descr
new file mode 100644
index 000000000000..5d61c3cb113a
--- /dev/null
+++ b/www/websocketd/pkg-descr
@@ -0,0 +1,8 @@
+websocketd is a small command-line tool that will wrap an existing command-line
+interface program, and allow it to be accessed via a WebSocket.
+
+WebSocket-capable applications can now be built very easily in any language. As
+long as you can write an executable program that reads `STDIN` and writes to
+`STDOUT`, you can build a WebSocket server.
+
+WWW: http://websocketd.com/