aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-03-26 02:05:45 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-03-26 02:05:45 +0800
commit6f164f4db7ded0de46e1c293a085aa2159185981 (patch)
treeba258222499c2babfa266267cfbf184ebd5b6197
parent44ff203801393d213b4fe0400ad14ead923bf3cc (diff)
downloadfreebsd-ports-6f164f4db7ded0de46e1c293a085aa2159185981.tar.gz
freebsd-ports-6f164f4db7ded0de46e1c293a085aa2159185981.tar.zst
freebsd-ports-6f164f4db7ded0de46e1c293a085aa2159185981.zip
Add py-whistle 1.0.1
Whistle is a simple tool that allow your application components to communicate with each other by dispatching events and listening to them. Whistle is an Event Dispatcher library for the Python 3.5+ language. It's largely inspired from Symfony's EventDispatcher component. Using an event dispatcher is a great way to write loosely coupled extensible code, having each part only communicate using light events. WWW: https://python-whistle.github.io/ WWW: https://github.com/python-whistle/whistle
Notes
Notes: svn path=/head/; revision=465537
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-whistle/Makefile19
-rw-r--r--devel/py-whistle/distinfo3
-rw-r--r--devel/py-whistle/pkg-descr11
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index aa3d493705cc..61f4849deea5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5027,6 +5027,7 @@
SUBDIR += py-weblib
SUBDIR += py-websockify
SUBDIR += py-wheel
+ SUBDIR += py-whistle
SUBDIR += py-widgetsnbextension
SUBDIR += py-wrapt
SUBDIR += py-wsgi_intercept
diff --git a/devel/py-whistle/Makefile b/devel/py-whistle/Makefile
new file mode 100644
index 000000000000..e246f8aaeb91
--- /dev/null
+++ b/devel/py-whistle/Makefile
@@ -0,0 +1,19 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= whistle
+PORTVERSION= 1.0.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Event dispatcher
+
+LICENSE= APACHE20
+
+NO_ARCH= yes
+USE_PYTHON= autoplist distutils
+USES= python:3.5+
+
+.include <bsd.port.mk>
diff --git a/devel/py-whistle/distinfo b/devel/py-whistle/distinfo
new file mode 100644
index 000000000000..1c333c94b00b
--- /dev/null
+++ b/devel/py-whistle/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1521957066
+SHA256 (whistle-1.0.1.tar.gz) = 960775d90bd26cab4b135df901593cee7ae9e99c489d4e2c8d6224355c5f2b90
+SIZE (whistle-1.0.1.tar.gz) = 4475
diff --git a/devel/py-whistle/pkg-descr b/devel/py-whistle/pkg-descr
new file mode 100644
index 000000000000..a0f7805d4689
--- /dev/null
+++ b/devel/py-whistle/pkg-descr
@@ -0,0 +1,11 @@
+Whistle is a simple tool that allow your application components to communicate
+with each other by dispatching events and listening to them.
+
+Whistle is an Event Dispatcher library for the Python 3.5+ language. It's
+largely inspired from Symfony's EventDispatcher component.
+
+Using an event dispatcher is a great way to write loosely coupled extensible
+code, having each part only communicate using light events.
+
+WWW: https://python-whistle.github.io/
+WWW: https://github.com/python-whistle/whistle