aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-28 05:58:26 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-28 05:58:26 +0800
commit6f50f986794f1b9a9eee36704a5704f3179aab7a (patch)
treeb05d8089c8bfa1109f14d2376c3436d539490430
parent7753f3c26a249d561851aea5447cda24e6b803a4 (diff)
downloadfreebsd-ports-6f50f986794f1b9a9eee36704a5704f3179aab7a.tar.gz
freebsd-ports-6f50f986794f1b9a9eee36704a5704f3179aab7a.tar.zst
freebsd-ports-6f50f986794f1b9a9eee36704a5704f3179aab7a.zip
New port: www/py-django-timezone-field: Provides database and form fields for pytz timezone objects for Django
PR: 226913 Submitted by: Kai <freebsd_ports@k-worx.org>
Notes
Notes: svn path=/head/; revision=465766
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-timezone-field/Makefile22
-rw-r--r--www/py-django-timezone-field/distinfo3
-rw-r--r--www/py-django-timezone-field/pkg-descr3
4 files changed, 29 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index afe8e94a7cbe..addb788ba77e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1630,6 +1630,7 @@
SUBDIR += py-django-tastypie
SUBDIR += py-django-templatetag-sugar
SUBDIR += py-django-threaded-multihost
+ SUBDIR += py-django-timezone-field
SUBDIR += py-django-tinymce
SUBDIR += py-django-voting
SUBDIR += py-django111
diff --git a/www/py-django-timezone-field/Makefile b/www/py-django-timezone-field/Makefile
new file mode 100644
index 000000000000..4f3cbeed971c
--- /dev/null
+++ b/www/py-django-timezone-field/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= django-timezone-field
+DISTVERSION= 2.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= Provides database and form fields for pytz timezone objects for Django
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django>=1.8:www/py-django@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-django-timezone-field/distinfo b/www/py-django-timezone-field/distinfo
new file mode 100644
index 000000000000..ae2020f81622
--- /dev/null
+++ b/www/py-django-timezone-field/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1521979237
+SHA256 (django-timezone-field-2.1.tar.gz) = 826c046758de29fd199657c113a1886f2bf951d8568554466f666b51e097e1c2
+SIZE (django-timezone-field-2.1.tar.gz) = 5986
diff --git a/www/py-django-timezone-field/pkg-descr b/www/py-django-timezone-field/pkg-descr
new file mode 100644
index 000000000000..83be226cc201
--- /dev/null
+++ b/www/py-django-timezone-field/pkg-descr
@@ -0,0 +1,3 @@
+Provides database and form fields for pytz timezone objects for Django.
+
+WWW: https://github.com/mfogel/django-timezone-field