aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2018-03-30 07:15:20 +0800
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2018-03-30 07:15:20 +0800
commit7043ccf5ceca8905a26e11b893535c69b2fd1f56 (patch)
tree178f36db2972f8bcbd86a5b178d28d1a6f682897
parent71059214130f276ffcf7671eba9a5c79986f95c6 (diff)
downloadfreebsd-ports-7043ccf5ceca8905a26e11b893535c69b2fd1f56.tar.gz
freebsd-ports-7043ccf5ceca8905a26e11b893535c69b2fd1f56.tar.zst
freebsd-ports-7043ccf5ceca8905a26e11b893535c69b2fd1f56.zip
Add new port mail/py-validate_email: Verifies if an email address is valid and really exists
Verifies and checks if an e-mail address is valid, properly formatted and really exists. It can optionally check the MX records of the e-mail domain. WWW: https://github.com/syrusakbary/validate_email PR: 227029 Submitted by: Kai <freebsd_ports@k-worx.org>
Notes
Notes: svn path=/head/; revision=465936
-rw-r--r--mail/Makefile1
-rw-r--r--mail/py-validate_email/Makefile32
-rw-r--r--mail/py-validate_email/distinfo3
-rw-r--r--mail/py-validate_email/pkg-descr4
4 files changed, 40 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 1799b9b7aaaa..048961053d07 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -549,6 +549,7 @@
SUBDIR += py-pyspf
SUBDIR += py-pyzmail
SUBDIR += py-spambayes
+ SUBDIR += py-validate_email
SUBDIR += py-zope.sendmail
SUBDIR += pymsgauth
SUBDIR += pysieved
diff --git a/mail/py-validate_email/Makefile b/mail/py-validate_email/Makefile
new file mode 100644
index 000000000000..923cb6620f60
--- /dev/null
+++ b/mail/py-validate_email/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= validate_email
+DISTVERSION= 1.3
+CATEGORIES= mail python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= Verifies if an email address is valid and really exists
+
+LICENSE= LGPL3+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+# If the default version (2.7) of Python is used, use package py-dns
+MY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dns>0:dns/py-dns@${PY_FLAVOR}
+
+RUN_DEPENDS= ${MY_DEPENDS}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.pre.mk>
+
+# If Python 3+ is used then use package py-py3dns instead
+.if ${PYTHON_MAJOR_VER} == "3"
+MY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}py3dns>0:dns/py-py3dns@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/py-validate_email/distinfo b/mail/py-validate_email/distinfo
new file mode 100644
index 000000000000..ad813abb8cf7
--- /dev/null
+++ b/mail/py-validate_email/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522218646
+SHA256 (validate_email-1.3.tar.gz) = 784719dc5f780be319cdd185dc85dd93afebdb6ebb943811bc4c7c5f9c72aeaf
+SIZE (validate_email-1.3.tar.gz) = 4694
diff --git a/mail/py-validate_email/pkg-descr b/mail/py-validate_email/pkg-descr
new file mode 100644
index 000000000000..55e393bd9e38
--- /dev/null
+++ b/mail/py-validate_email/pkg-descr
@@ -0,0 +1,4 @@
+Verifies and checks if an e-mail address is valid, properly formatted and really
+exists. It can optionally check the MX records of the e-mail domain.
+
+WWW: https://github.com/syrusakbary/validate_email