aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-22 17:41:10 +0800
committerMathieu Arnold <mat@FreeBSD.org>2018-03-22 17:41:10 +0800
commit73f4909edb17ab87267d91ac74fd1a622a05238d (patch)
tree30090a2be8f99a7869226422c21ea6ddd9e19a8f
parent093a32afc4e7ab4774695b4b72ea93160b903b00 (diff)
downloadfreebsd-ports-73f4909edb17ab87267d91ac74fd1a622a05238d.tar.gz
freebsd-ports-73f4909edb17ab87267d91ac74fd1a622a05238d.tar.zst
freebsd-ports-73f4909edb17ab87267d91ac74fd1a622a05238d.zip
Install vim syntax files.
PR: 226457 Submitted by: mat Approved by: maintainer timeout Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=465281
-rw-r--r--www/nginx/Makefile4
-rw-r--r--www/nginx/pkg-plist4
2 files changed, 7 insertions, 1 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 17db8da50199..d6605456ccdb 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.12.2
-PORTREVISION?= 10
+PORTREVISION?= 11
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
@@ -1330,6 +1330,8 @@ do-install:
.endif
post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/vim/vimfiles
+ cd ${WRKSRC}/contrib/vim && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/share/vim/vimfiles
.if ${PORT_OPTIONS:MHTTP} && ${PORT_OPTIONS:MHTTP_PERL}
${ECHO_CMD} ${SITE_ARCH_REL}/auto/nginx/nginx.so >> ${TMPPLIST}
${ECHO_CMD} ${SITE_ARCH_REL}/nginx.pm >> ${TMPPLIST}
diff --git a/www/nginx/pkg-plist b/www/nginx/pkg-plist
index f7e44688f120..7ffc236d9406 100644
--- a/www/nginx/pkg-plist
+++ b/www/nginx/pkg-plist
@@ -14,6 +14,10 @@
%%WWWDATA%%@exec chmod a-w %D/www/nginx-dist
%%WWWDATA%%@unexec if [ -L %D/www/nginx ]; then rm -f %D/www/nginx; fi
sbin/nginx
+share/vim/vimfiles/ftdetect/nginx.vim
+share/vim/vimfiles/ftplugin/nginx.vim
+share/vim/vimfiles/indent/nginx.vim
+share/vim/vimfiles/syntax/nginx.vim
@dir %%NGINX_TMPDIR%%
@dir %%NGINX_LOGDIR%%
man/man8/nginx.8.gz