aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-28 05:50:51 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-28 05:50:51 +0800
commit7753f3c26a249d561851aea5447cda24e6b803a4 (patch)
tree9524830e9eea2b2db323b395852691cbd4026e5e
parentb10a0b0207016604bc4ddfdbae2588f0733aad07 (diff)
downloadfreebsd-ports-7753f3c26a249d561851aea5447cda24e6b803a4.tar.gz
freebsd-ports-7753f3c26a249d561851aea5447cda24e6b803a4.tar.zst
freebsd-ports-7753f3c26a249d561851aea5447cda24e6b803a4.zip
New port: www/py-django-filter: Dynamic filtering for querysets with Django
PR: 227007 Submitted by: Kai <freebsd_ports@k-worx.org>
Notes
Notes: svn path=/head/; revision=465765
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-filter/Makefile24
-rw-r--r--www/py-django-filter/distinfo3
-rw-r--r--www/py-django-filter/pkg-descr3
4 files changed, 31 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index bc6be9b80157..afe8e94a7cbe 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1575,6 +1575,7 @@
SUBDIR += py-django-evolution
SUBDIR += py-django-extensions
SUBDIR += py-django-filer
+ SUBDIR += py-django-filter
SUBDIR += py-django-formtools
SUBDIR += py-django-guardian
SUBDIR += py-django-happenings
diff --git a/www/py-django-filter/Makefile b/www/py-django-filter/Makefile
new file mode 100644
index 000000000000..55958a930167
--- /dev/null
+++ b/www/py-django-filter/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= django-filter
+DISTVERSION= 1.1.0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= Dynamic filtering for querysets with Django
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django>0:www/py-django@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}djangorestframework>0:www/py-djangorestframework@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}coreapi>0:devel/py-coreapi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}coreschema>0:devel/py-coreschema@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-django-filter/distinfo b/www/py-django-filter/distinfo
new file mode 100644
index 000000000000..dfd9c43778b6
--- /dev/null
+++ b/www/py-django-filter/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522148113
+SHA256 (django-filter-1.1.0.tar.gz) = ec0ef1ba23ef95b1620f5d481334413700fb33f45cd76d56a63f4b0b1d76976a
+SIZE (django-filter-1.1.0.tar.gz) = 127831
diff --git a/www/py-django-filter/pkg-descr b/www/py-django-filter/pkg-descr
new file mode 100644
index 000000000000..6920bfba0ce0
--- /dev/null
+++ b/www/py-django-filter/pkg-descr
@@ -0,0 +1,3 @@
+A generic system for filtering Django QuerySets based on user selections.
+
+WWW: https://github.com/carltongibson/django-filter