aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-26 07:46:05 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-26 07:46:05 +0800
commit79810ca9368890d46b0a00c1d8acbfcaa7976bfd (patch)
tree47bd3e7fd3ddc7a0b828ef8ee557760a8170b7d2
parent77b062495721fd10311c9f983701bbe663e574aa (diff)
downloadfreebsd-ports-79810ca9368890d46b0a00c1d8acbfcaa7976bfd.tar.gz
freebsd-ports-79810ca9368890d46b0a00c1d8acbfcaa7976bfd.tar.zst
freebsd-ports-79810ca9368890d46b0a00c1d8acbfcaa7976bfd.zip
New port: textproc/py-gfm: Github-flavored Markdown for the py-markdown module
Submitted by: Kai <freebsd_ports@k-worx.org>
Notes
Notes: svn path=/head/; revision=465550
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-gfm/Makefile35
-rw-r--r--textproc/py-gfm/distinfo3
-rw-r--r--textproc/py-gfm/pkg-descr4
4 files changed, 43 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 98cdf627e57c..b9e0f12c3eee 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1304,6 +1304,7 @@
SUBDIR += py-feedparser
SUBDIR += py-gambit-elasticsearch
SUBDIR += py-genshi
+ SUBDIR += py-gfm
SUBDIR += py-guess-language
SUBDIR += py-hexdump
SUBDIR += py-html2text
diff --git a/textproc/py-gfm/Makefile b/textproc/py-gfm/Makefile
new file mode 100644
index 000000000000..2fcaa0aaeda8
--- /dev/null
+++ b/textproc/py-gfm/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= gfm
+DISTVERSION= 0.1.3
+CATEGORIES= textproc python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= Github-flavored Markdown for the py-markdown module
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}markdown>0:textproc/py-markdown@${PY_FLAVOR}
+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= Zopieux
+GH_PROJECT= py-${PORTNAME}
+USE_PYTHON= distutils concurrent autoplist
+NO_ARCH= yes
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${PY_FLAVOR}
+DOCS_VARS= PYDISTUTILS_BUILD_TARGET+=build_sphinx
+
+PORTDOCS= *
+
+post-install-DOCS-on:
+ cd ${WRKSRC}/build/sphinx/html && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} "! -name .buildinfo -and ! -path objects.inv"
+
+.include <bsd.port.mk>
diff --git a/textproc/py-gfm/distinfo b/textproc/py-gfm/distinfo
new file mode 100644
index 000000000000..3d5ce591ca52
--- /dev/null
+++ b/textproc/py-gfm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522021092
+SHA256 (py-gfm-0.1.3_GH0.tar.gz) = 5d8cf9d8fbdaf4c9d28a7f00dcfdaa6212cfb2f3f89b15f347ba6a9970902b39
+SIZE (py-gfm-0.1.3_GH0.tar.gz) = 20821
diff --git a/textproc/py-gfm/pkg-descr b/textproc/py-gfm/pkg-descr
new file mode 100644
index 000000000000..4757cd9c4b68
--- /dev/null
+++ b/textproc/py-gfm/pkg-descr
@@ -0,0 +1,4 @@
+Enables Github-flavored Markdown for the py-markdown module. It aims for
+maximal compatibility with GitHub's rendering.
+
+WWW: https://github.com/Zopieux/py-gfm