aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2018-03-22 17:53:05 +0800
committerAdriaan de Groot <adridg@FreeBSD.org>2018-03-22 17:53:05 +0800
commit83bbface6eac75342a94725bf3c24940539ce8f5 (patch)
treeb521274b39061d196d452e733fac7f106325356c
parent73f4909edb17ab87267d91ac74fd1a622a05238d (diff)
downloadfreebsd-ports-83bbface6eac75342a94725bf3c24940539ce8f5.tar.gz
freebsd-ports-83bbface6eac75342a94725bf3c24940539ce8f5.tar.zst
freebsd-ports-83bbface6eac75342a94725bf3c24940539ce8f5.zip
Fix cad/kicad{-devel} in advance of CMake 3.11. Remove old duplicate CMake
module. The old modules use CMake internals that are going away in 3.11; this particular module has been shipped with CMake since 3.0 at least, so it's just not necessary except on silly ancient platforms. Reviewed by: thierry (maintainer) Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D14772
Notes
Notes: svn path=/head/; revision=465282
-rw-r--r--cad/kicad-devel/Makefile8
-rw-r--r--cad/kicad/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/cad/kicad-devel/Makefile b/cad/kicad-devel/Makefile
index b414c9cbbd4c..fa7043050d82 100644
--- a/cad/kicad-devel/Makefile
+++ b/cad/kicad-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kicad
DISTVERSION= r${GIT_SRC_DATE}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= cad
PKGNAMESUFFIX= -devel
DIST_SUBDIR= ${PORTNAME}
@@ -84,6 +84,12 @@ showversions:
tmp:
echo "${DATADIR} ${DATADIR:H}"
+# The CheckCXXSymbolExists module has been shipped with CMake since 3.0 times.
+# The ancient implementation that this bundled module uses, no longer works
+# because it uses CMake internals that have gone away in 3.11.
+post-extract:
+ ${RM} ${WRKSRC}/CMakeModules/CheckCXXSymbolExists.cmake
+
post-configure:
${REINPLACE_CMD} -e 's|#define HAVE_ISO646_H|//#define HAVE_ISO646_H|' \
${WRKSRC}/config.h
diff --git a/cad/kicad/Makefile b/cad/kicad/Makefile
index 034254e5c974..287814ed60ad 100644
--- a/cad/kicad/Makefile
+++ b/cad/kicad/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kicad
PORTVERSION= 4.0.7
-PORTREVISION= 6
+PORTREVISION= 7
PORTEPOCH= 2
CATEGORIES= cad
@@ -59,6 +59,12 @@ DOXYGEN_IMPLIES= DOCS
DOXYGEN_ALL_TARGET= all doxygen-docs
DOXYGEN_PORTDOCS= doxygen
+# The CheckCXXSymbolExists module has been shipped with CMake since 3.0 times.
+# The ancient implementation that this bundled module uses, no longer works
+# because it uses CMake internals that have gone away in 3.11.
+post-extract:
+ ${RM} ${WRKSRC}/CMakeModules/CheckCXXSymbolExists.cmake
+
pre-configure:
${REINPLACE_CMD} -e 's|/usr/share/kicad|${DATADIR}|' \
-e 's|/usr/local|${PREFIX}|' \