aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-27 07:13:45 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-27 07:13:45 +0800
commit89e7355c19a974372c2ea5f806fba30a94a96b0c (patch)
tree5a07fe0217e015925cea45f9c42c8403f07a172e
parent43e7d7076477309c00398ce8d67c6c39596c3377 (diff)
downloadfreebsd-ports-89e7355c19a974372c2ea5f806fba30a94a96b0c.tar.gz
freebsd-ports-89e7355c19a974372c2ea5f806fba30a94a96b0c.tar.zst
freebsd-ports-89e7355c19a974372c2ea5f806fba30a94a96b0c.zip
New port: science/libcint: General GTO integrals for quantum chemistry
Notes
Notes: svn path=/head/; revision=465645
-rw-r--r--science/Makefile1
-rw-r--r--science/libcint/Makefile25
-rw-r--r--science/libcint/distinfo3
-rw-r--r--science/libcint/files/patch-CMakeLists.txt15
-rw-r--r--science/libcint/files/patch-src_c2f.h10
-rw-r--r--science/libcint/pkg-descr5
6 files changed, 59 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index b7d007efaa03..9205be291c22 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -82,6 +82,7 @@
SUBDIR += kst2
SUBDIR += lamprop
SUBDIR += libaec
+ SUBDIR += libcint
SUBDIR += libctl
SUBDIR += libefp
SUBDIR += libgeodecomp
diff --git a/science/libcint/Makefile b/science/libcint/Makefile
new file mode 100644
index 000000000000..d2962b7b51e1
--- /dev/null
+++ b/science/libcint/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= libcint
+DISTVERSIONPREFIX= v
+DISTVERSION= 3.0.10
+CATEGORIES= science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= General GTO integrals for quantum chemistry
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libopenblas.so:math/openblas
+
+USES= cmake:outsource blaslapack:openblas
+USE_GITHUB= yes
+GH_ACCOUNT= sunqm
+USE_LDCONFIG= yes
+
+PLIST_FILES= include/cint.h \
+ lib/libcint.so \
+ lib/libcint.so.3.0.6
+
+.include <bsd.port.mk>
diff --git a/science/libcint/distinfo b/science/libcint/distinfo
new file mode 100644
index 000000000000..12b0db73c271
--- /dev/null
+++ b/science/libcint/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522103933
+SHA256 (sunqm-libcint-v3.0.10_GH0.tar.gz) = aac6d9630dc4c62840f03262166e877d3aeaf27b6b33498fb490fa3428f12fe4
+SIZE (sunqm-libcint-v3.0.10_GH0.tar.gz) = 38801760
diff --git a/science/libcint/files/patch-CMakeLists.txt b/science/libcint/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..a568548498f6
--- /dev/null
+++ b/science/libcint/files/patch-CMakeLists.txt
@@ -0,0 +1,15 @@
+--- CMakeLists.txt.orig 2018-03-26 22:49:26 UTC
++++ CMakeLists.txt
+@@ -25,7 +25,11 @@ if(QUADMATH_FOUND)
+ set(HAVE_QUADMATH_H 1 CACHE INTERNAL "Have QUADMATH")
+ endif()
+
+-find_package(BLAS REQUIRED)
++# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=226959
++#find_package(BLAS REQUIRED)
++set(BLAS_FOUND ON)
++set(BLAS_LINKER_FLAGS -L${CMAKE_INSTALL_PREFIX}/lib -lopenblas -lopenblasp)
++set(BLAS_LIBRARIES ${CMAKE_INSTALL_PREFIX}/lib/libopenblas.so ${CMAKE_INSTALL_PREFIX}/lib/libopenblasp.so)
+
+ include(CheckFunctionExists)
+ set(CMAKE_REQUIRED_INCLUDES math.h)
diff --git a/science/libcint/files/patch-src_c2f.h b/science/libcint/files/patch-src_c2f.h
new file mode 100644
index 000000000000..b7d3deccc865
--- /dev/null
+++ b/science/libcint/files/patch-src_c2f.h
@@ -0,0 +1,10 @@
+--- src/c2f.h.orig 2018-03-21 00:24:56 UTC
++++ src/c2f.h
+@@ -4,6 +4,7 @@
+ */
+
+ #include "config.h"
++#include <sys/types.h>
+
+ #define ALL_CINT_FORTRAN_(NAME) \
+ int c##NAME##_sph_(double *out, int *shls, int *atm, int *natm, \
diff --git a/science/libcint/pkg-descr b/science/libcint/pkg-descr
new file mode 100644
index 000000000000..98648736df2f
--- /dev/null
+++ b/science/libcint/pkg-descr
@@ -0,0 +1,5 @@
+libcint is an open source library for analytical Gaussian integrals.
+It provides C/Fortran API to evaluate one-electron/two-electron
+integrals for Cartesian/real-spheric/spinor Gaussian type functions.
+
+WWW: https://github.com/sunqm/libcint