aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2018-03-28 00:29:07 +0800
committerMax Brazhnikov <makc@FreeBSD.org>2018-03-28 00:29:07 +0800
commit98867ec8368abcf53f8c8d7832f716ffc9d62f4e (patch)
tree035f3c5661067f2f6c2a552d538ae9d3f5a7fbf1
parentc2b52ba444372b2ff1cdbc223fe7ab7262d05466 (diff)
downloadfreebsd-ports-98867ec8368abcf53f8c8d7832f716ffc9d62f4e.tar.gz
freebsd-ports-98867ec8368abcf53f8c8d7832f716ffc9d62f4e.tar.zst
freebsd-ports-98867ec8368abcf53f8c8d7832f716ffc9d62f4e.zip
Add new port misc/py-python-utils:
Collection of small Python functions and classes WWW: https://pypi.python.org/pypi/python-utils
Notes
Notes: svn path=/head/; revision=465721
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-python-utils/Makefile22
-rw-r--r--misc/py-python-utils/distinfo3
-rw-r--r--misc/py-python-utils/pkg-descr5
4 files changed, 31 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 9376bb2846b3..232323ad6080 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -401,6 +401,7 @@
SUBDIR += py-pyfiglet
SUBDIR += py-pyprind
SUBDIR += py-python-geohash
+ SUBDIR += py-python-utils
SUBDIR += py-qt4-demo
SUBDIR += py-qt4-doc
SUBDIR += py-qt5-demo
diff --git a/misc/py-python-utils/Makefile b/misc/py-python-utils/Makefile
new file mode 100644
index 000000000000..5bc8324a1714
--- /dev/null
+++ b/misc/py-python-utils/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= python-utils
+PORTVERSION= 2.3.0
+CATEGORIES= misc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= Collection of small functions and classes
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-runner>=0:devel/py-pytest-runner@${FLAVOR}
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+.include <bsd.port.mk>
diff --git a/misc/py-python-utils/distinfo b/misc/py-python-utils/distinfo
new file mode 100644
index 000000000000..aed4db88b4b0
--- /dev/null
+++ b/misc/py-python-utils/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1521804690
+SHA256 (python-utils-2.3.0.tar.gz) = 34aaf26b39b0b86628008f2ae0ac001b30e7986a8d303b61e1357dfcdad4f6d3
+SIZE (python-utils-2.3.0.tar.gz) = 19384
diff --git a/misc/py-python-utils/pkg-descr b/misc/py-python-utils/pkg-descr
new file mode 100644
index 000000000000..c2d90d9e6c9f
--- /dev/null
+++ b/misc/py-python-utils/pkg-descr
@@ -0,0 +1,5 @@
+Python Utils is a collection of small Python functions and classes
+which make common patterns shorter and easier.
+
+WWW: https://pypi.python.org/pypi/python-utils
+WWW: https://github.com/WoLpH/python-utils