aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-24 13:57:43 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-24 13:57:43 +0800
commita73be82acc7039f916ecd693de991e6f298c9c45 (patch)
treed4f15c8ade0634b39a6353869361bcf6cc71de31
parent300c9d0ac24fc1ea904d2b6b14aea2b345a3508d (diff)
downloadfreebsd-ports-a73be82acc7039f916ecd693de991e6f298c9c45.tar.gz
freebsd-ports-a73be82acc7039f916ecd693de991e6f298c9c45.tar.zst
freebsd-ports-a73be82acc7039f916ecd693de991e6f298c9c45.zip
New port: devel/py-json_tricks: Extra features for Python's JSON: comments, order, datetimes, etc
While here, fixed a minor prdering problem in devel/Makefile
Notes
Notes: svn path=/head/; revision=465426
-rw-r--r--devel/Makefile3
-rw-r--r--devel/py-json_tricks/Makefile19
-rw-r--r--devel/py-json_tricks/distinfo3
-rw-r--r--devel/py-json_tricks/pkg-descr12
4 files changed, 36 insertions, 1 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d399ccf7e6ca..231ccdffb7ec 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4550,6 +4550,7 @@
SUBDIR += py-jsmin
SUBDIR += py-json-py
SUBDIR += py-json-sempai
+ SUBDIR += py-json_tricks
SUBDIR += py-jsonlib
SUBDIR += py-jsonlib2
SUBDIR += py-jsonlines
@@ -5285,6 +5286,7 @@
SUBDIR += rubygem-activesupport4
SUBDIR += rubygem-activesupport5
SUBDIR += rubygem-activesupport50
+ SUBDIR += rubygem-airborne
SUBDIR += rubygem-akismet
SUBDIR += rubygem-algebrick
SUBDIR += rubygem-algorithms
@@ -5292,7 +5294,6 @@
SUBDIR += rubygem-analogger
SUBDIR += rubygem-annoy
SUBDIR += rubygem-ansi
- SUBDIR += rubygem-airborne
SUBDIR += rubygem-apipie-bindings
SUBDIR += rubygem-apipie-params
SUBDIR += rubygem-app_config
diff --git a/devel/py-json_tricks/Makefile b/devel/py-json_tricks/Makefile
new file mode 100644
index 000000000000..244841d03532
--- /dev/null
+++ b/devel/py-json_tricks/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= json_tricks
+DISTVERSION= 3.11.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Extra features for Python's JSON: comments, order, datetimes, etc
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-json_tricks/distinfo b/devel/py-json_tricks/distinfo
new file mode 100644
index 000000000000..d9768703be4c
--- /dev/null
+++ b/devel/py-json_tricks/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1521870225
+SHA256 (json_tricks-3.11.3.tar.gz) = dda43dcc3c683972922bbb2d5a79861c8f1a8cee5f28f94d3eb96f28bdd9d4a6
+SIZE (json_tricks-3.11.3.tar.gz) = 33380
diff --git a/devel/py-json_tricks/pkg-descr b/devel/py-json_tricks/pkg-descr
new file mode 100644
index 000000000000..fb6d717bc4cd
--- /dev/null
+++ b/devel/py-json_tricks/pkg-descr
@@ -0,0 +1,12 @@
+The pyjson-tricks package brings several pieces of functionality to python
+handling of json files:
+
+* Store and load numpy arrays in human-readable format.
+* Store and load class instances both generic and customized.
+* Store and load date/times as a dictionary (including timezone).
+* Preserve map order {} using OrderedDict.
+* Allow for comments in json files by starting lines with #.
+* Sets, complex numbers, Decimal, Fraction, enums, compression,
+ duplicate keys, etc.
+
+WWW: https://github.com/mverleg/pyjson_tricks