aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2018-03-28 00:38:38 +0800
committerMax Brazhnikov <makc@FreeBSD.org>2018-03-28 00:38:38 +0800
commitb65fd5a100124a2aa175d70865d6e152d358550b (patch)
treeb556f0d78f9e77f4d8403b79b5e44b9a16957c18
parent98867ec8368abcf53f8c8d7832f716ffc9d62f4e (diff)
downloadfreebsd-ports-b65fd5a100124a2aa175d70865d6e152d358550b.tar.gz
freebsd-ports-b65fd5a100124a2aa175d70865d6e152d358550b.tar.zst
freebsd-ports-b65fd5a100124a2aa175d70865d6e152d358550b.zip
Add new port misc/py-progressbar2:
Text mode progressbar library for Python WWW: https://pypi.python.org/pypi/progressbar2
Notes
Notes: svn path=/head/; revision=465722
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-progressbar2/Makefile26
-rw-r--r--misc/py-progressbar2/distinfo3
-rw-r--r--misc/py-progressbar2/pkg-descr6
4 files changed, 36 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 232323ad6080..f91781c48b52 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -397,6 +397,7 @@
SUBDIR += py-pexpect
SUBDIR += py-powerline-status
SUBDIR += py-progressbar
+ SUBDIR += py-progressbar2
SUBDIR += py-progressbar231
SUBDIR += py-pyfiglet
SUBDIR += py-pyprind
diff --git a/misc/py-progressbar2/Makefile b/misc/py-progressbar2/Makefile
new file mode 100644
index 000000000000..3d0586cc611e
--- /dev/null
+++ b/misc/py-progressbar2/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= progressbar2
+PORTVERSION= 3.36.0
+CATEGORIES= misc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= Text mode progressbar library for Python
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-runner>=0:devel/py-pytest-runner@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-utils>=2.3.0:misc/py-python-utils@${FLAVOR}
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}progressbar \
+ ${PYTHON_PKGNAMEPREFIX}progressbar231
+
+.include <bsd.port.mk>
diff --git a/misc/py-progressbar2/distinfo b/misc/py-progressbar2/distinfo
new file mode 100644
index 000000000000..6cd034c52dc6
--- /dev/null
+++ b/misc/py-progressbar2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1521332690
+SHA256 (progressbar2-3.36.0.tar.gz) = 8600401956fc07852b309483590b424529ada8566447b2900a565218c66ee32c
+SIZE (progressbar2-3.36.0.tar.gz) = 113869
diff --git a/misc/py-progressbar2/pkg-descr b/misc/py-progressbar2/pkg-descr
new file mode 100644
index 000000000000..a034181ce99c
--- /dev/null
+++ b/misc/py-progressbar2/pkg-descr
@@ -0,0 +1,6 @@
+This library provides a text mode progressbar. This is typically
+used to display the progress of a long running operation, providing
+a visual clue that processing is underway.
+
+WWW: https://pypi.python.org/pypi/progressbar2
+WWW: https://github.com/WoLpH/python-progressbar