aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2018-03-27 04:58:14 +0800
committerAntoine Brodin <antoine@FreeBSD.org>2018-03-27 04:58:14 +0800
commitb702c5ec1e5f6f595f956da83a06790c54b6d952 (patch)
treed0e5bede28259b744bc9692c1b61b0629da970aa
parentca70c04605f4b003427c6a34188077f004017507 (diff)
downloadfreebsd-ports-b702c5ec1e5f6f595f956da83a06790c54b6d952.tar.gz
freebsd-ports-b702c5ec1e5f6f595f956da83a06790c54b6d952.tar.zst
freebsd-ports-b702c5ec1e5f6f595f956da83a06790c54b6d952.zip
Revert r465619 and r465623, the use of PORT_OPTIONS and option helpers is
incorrect With hat: portmgr
Notes
Notes: svn path=/head/; revision=465636
-rw-r--r--net-p2p/bitcoin-daemon/Makefile4
-rw-r--r--net-p2p/bitcoin-utils/Makefile4
-rw-r--r--net-p2p/bitcoin/Makefile17
-rw-r--r--net-p2p/bitcoin/pkg-help18
4 files changed, 5 insertions, 38 deletions
diff --git a/net-p2p/bitcoin-daemon/Makefile b/net-p2p/bitcoin-daemon/Makefile
index c79dc1d09a56..15fc32728a79 100644
--- a/net-p2p/bitcoin-daemon/Makefile
+++ b/net-p2p/bitcoin-daemon/Makefile
@@ -11,9 +11,7 @@ NOT_FOR_ARCHS= powerpc powerpc64 sparc64
NOT_FOR_ARCHS_REASON= does not support big-endian architectures
OPTIONS_DEFINE= DEBUG HARDENING TESTS UPNP WALLET ZMQ
-# BDBMODERN is a choice for BDBVER, introduced via OPTIONS_SINGLE=BDBVER
-# from ${MASTERDIR}/Makefile
-OPTIONS_DEFAULT= BDBMODERN HARDENING UPNP WALLET
+OPTIONS_DEFAULT= HARDENING UPNP WALLET
USERS= bitcoin
GROUPS= bitcoin
diff --git a/net-p2p/bitcoin-utils/Makefile b/net-p2p/bitcoin-utils/Makefile
index 0738be8a44d4..3830afccd4fe 100644
--- a/net-p2p/bitcoin-utils/Makefile
+++ b/net-p2p/bitcoin-utils/Makefile
@@ -10,9 +10,7 @@ NOT_FOR_ARCHS= powerpc powerpc64 sparc64
NOT_FOR_ARCHS_REASON= does not support big-endian architectures
OPTIONS_DEFINE= DEBUG HARDENING TESTS
-# BDBMODERN is a choice for BDBVER, introduced via OPTIONS_SINGLE=BDBVER
-# from ${MASTERDIR}/Makefile
-OPTIONS_DEFAULT= BDBMODERN HARDENING TESTS
+OPTIONS_DEFAULT= HARDENING TESTS
CONFIGURE_ARGS= --without-daemon \
--without-gui \
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index 350976e77221..af38d71a3823 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -4,7 +4,7 @@
PORTNAME= bitcoin
PORTVERSION= 0.16.0
DISTVERSIONPREFIX= v
-PORTREVISION?= 1
+PORTREVISION?= 0
CATEGORIES= net-p2p finance
MAINTAINER= kbowling@FreeBSD.org
@@ -37,14 +37,9 @@ TESTS_PLIST_FILES= bin/test_bitcoin-qt \
.endif
OPTIONS_DEFINE?= DBUS DEBUG HARDENING QRCODES TESTS UPNP WALLET ZMQ
-OPTIONS_SINGLE= BDBVER
-OPTIONS_SINGLE_BDBVER= BDB48 BDBMODERN
-OPTIONS_DEFAULT?= BDBMODERN DBUS HARDENING QRCODES UPNP WALLET
+OPTIONS_DEFAULT?= DBUS HARDENING QRCODES UPNP WALLET
OPTIONS_SUB= yes
-BDBVER_DESC= Berkeley DB version to use for wallet
-BDB48_DESC= Use BDB 4.8 (compatible with 5.x and 6.x)
-BDBMODERN_DESC= Use BDB 5.x or 6.x (not compatible with 4.8)
HARDENING_DESC= Attempt to harden binaries (PIE for ASLR, NX Stack)
QRCODES_DESC= Display QR Codes
TESTS_DESC= Build test binary and unit tests
@@ -76,6 +71,7 @@ QRCODES_LIB_DEPENDS= libqrencode.so:graphics/libqrencode
WALLET_CONFIGURE_ENABLE= wallet
WALLET_CXXFLAGS= -I${BDB_INCLUDE_DIR}
WALLET_LIBS= -L${BDB_LIB_DIR}
+WALLET_USES= bdb:48
ZMQ_CONFIGURE_ENABLE= zmq
ZMQ_BUILD_DEPENDS= libzmq4>0:net/libzmq4
@@ -98,13 +94,6 @@ PLIST_FILES?= bin/bitcoin-qt man/man1/bitcoin-qt.1.gz \
.include <bsd.port.pre.mk>
-.if empty(PORT_OPTIONS:MBDB48)
-WALLET_CONFIGURE_ON= --with-incompatible-bdb
-WALLET_USES= bdb:5+
-.else
-WALLET_USES= bdb:48
-.endif
-
.if ${OSVERSION} < 1100000
CONFIGURE_ARGS+=--disable-asm
.endif
diff --git a/net-p2p/bitcoin/pkg-help b/net-p2p/bitcoin/pkg-help
deleted file mode 100644
index e73a63038c07..000000000000
--- a/net-p2p/bitcoin/pkg-help
+++ /dev/null
@@ -1,18 +0,0 @@
-The wallet is stored in a Berkeley database file (BDB) (usually
-~/.bitcoin/wallets/wallet.dat).
-
-Bitcoin Core can use either BDB 4.8, 5.x or 6.x to create and access the
-wallet file.
-
-Wallets created using BDB 4.8 are also accessible by BDB 5.x and 6.x.
-
-Wallets created using BDB 5.x or 6.x are not accessible by BDB 4.8.
-
-Opening and using a wallet created by 4.8 with a higher major version (5.x
-or 6.x) does not change its format, so it will still be accessible to 4.8
-afterwards. But encrypting an unencrypted wallet recreates it, so encrypting
-a 4.8 wallet with Bitcoin Core linked against BDB 5.x or 6.x will render it
-unreadable for Bitcoin Core linked against BDB 4.8.
-
-If you do not plan on copying the wallet file to another machine that uses
-BDB 4.8 then it is recommended to use the modern versions of BDB 5.x or 6.x.