aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEd Maste <emaste@FreeBSD.org>2018-03-28 05:24:51 +0800
committerEd Maste <emaste@FreeBSD.org>2018-03-28 05:24:51 +0800
commitb87910ca563443db7bc2f820212431c8aa97d74d (patch)
tree8530f03657c5a50c8ca466e354af8df5386d2ae1
parentc73788ff8948c37819f3c38fd16f15cb4ed36cd2 (diff)
downloadfreebsd-ports-b87910ca563443db7bc2f820212431c8aa97d74d.tar.gz
freebsd-ports-b87910ca563443db7bc2f820212431c8aa97d74d.tar.zst
freebsd-ports-b87910ca563443db7bc2f820212431c8aa97d74d.zip
devel/libds: use BINARY_ALIAS to ensure linker is ld.bfd
lld has no built-in search paths (/lib, /usr/lib). Normally the linker is invoked from the compiler driver, and the search paths are added by the compiler. If lld is invoked directly library search paths must be specified explicitly, with -L/lib -L/usr/lib. This port does not honour LD or -fuse-ld in CFLAGS via LLD_UNSAFE, but BINARY_ALIAS can be used to ensure we use the BFD linker. PR: 226972 Approved by: portmgr (LLD_UNSAFE blanket) Sponsored by: The FreeBSD Foundation
Notes
Notes: svn path=/head/; revision=465760
-rw-r--r--devel/libds/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/devel/libds/Makefile b/devel/libds/Makefile
index 294f7f492250..9fdff4ea5773 100644
--- a/devel/libds/Makefile
+++ b/devel/libds/Makefile
@@ -14,6 +14,8 @@ COMMENT= ANSI Generic Data Structures Library
LICENSE= BSD4CLAUSE
USE_LDCONFIG= yes
+# LLD_UNSAFE - requires directly-invoked linker to provide library search paths
+BINARY_ALIAS= ld=ld.bfd
ALL_TARGET= gcc
HTML= avltree.html heap.html parray.html set.html \