aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2018-03-27 17:32:04 +0800
committerBernhard Froehlich <decke@FreeBSD.org>2018-03-27 17:32:04 +0800
commitb92e7fe2d412a53dd7f4e0423e67809b371c9e72 (patch)
treead247061e88200fa3b8d86471f3ed8f3d7f27dc2
parent2e40e7e2da5aeab549c7ac85dfaacc4f22d2b8f1 (diff)
downloadfreebsd-ports-b92e7fe2d412a53dd7f4e0423e67809b371c9e72.tar.gz
freebsd-ports-b92e7fe2d412a53dd7f4e0423e67809b371c9e72.tar.zst
freebsd-ports-b92e7fe2d412a53dd7f4e0423e67809b371c9e72.zip
- Update to 4.2.6
- Add a patch for a build failure when kerberos is installed Reported by: Frank Razenberg <frank@zzattack.org>
Notes
Notes: svn path=/head/; revision=465680
-rw-r--r--multimedia/tvheadend/Makefile2
-rw-r--r--multimedia/tvheadend/distinfo6
-rw-r--r--multimedia/tvheadend/files/patch-Makefile29
3 files changed, 33 insertions, 4 deletions
diff --git a/multimedia/tvheadend/Makefile b/multimedia/tvheadend/Makefile
index eb668f9198c0..ce10d446a9a1 100644
--- a/multimedia/tvheadend/Makefile
+++ b/multimedia/tvheadend/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tvheadend
-PORTVERSION= 4.2.5
+PORTVERSION= 4.2.6
DISTVERSIONPREFIX= v
CATEGORIES= multimedia
diff --git a/multimedia/tvheadend/distinfo b/multimedia/tvheadend/distinfo
index 28cbb5784e9c..21686fb99f0d 100644
--- a/multimedia/tvheadend/distinfo
+++ b/multimedia/tvheadend/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1515264849
-SHA256 (tvheadend-tvheadend-v4.2.5_GH0.tar.gz) = 36816c8b506af6b0f5df442bd96aa301223dc7c44d8b88eec53262e92956d740
-SIZE (tvheadend-tvheadend-v4.2.5_GH0.tar.gz) = 21528718
+TIMESTAMP = 1522131748
+SHA256 (tvheadend-tvheadend-v4.2.6_GH0.tar.gz) = 09b4d4ff436a2006001ef3c3f38553dc4db3ea31bf9871b046a33180a0e8a8b9
+SIZE (tvheadend-tvheadend-v4.2.6_GH0.tar.gz) = 21528720
diff --git a/multimedia/tvheadend/files/patch-Makefile b/multimedia/tvheadend/files/patch-Makefile
new file mode 100644
index 000000000000..cb7da85f939d
--- /dev/null
+++ b/multimedia/tvheadend/files/patch-Makefile
@@ -0,0 +1,29 @@
+Prepend local include paths in CFLAGS to avoid conflict with system wide includes
+
+CFLAGS could contain system wide include paths which might conflict
+with our filenames. So make sure that our local directories are first
+in the search order.
+
+Example with conflicting profile.h from kerberos:
+
+tvheadend-4.2.5/src/dvr/dvr.h:27:
+/usr/local/include/profile.h:24:28: error: typedef redefinition with
+different types ('struct _profile_t *' vs 'struct profile')
+typedef struct _profile_t *profile_t;
+ ^
+tvheadend-4.2.5/src/profile.h:147:3:
+note: previous definition is here
+} profile_t;
+
+Reported by: Frank Razenberg <frank@zzattack.org>
+--- Makefile.bak 2018-02-22 16:07:14.367738000 +0000
++++ Makefile 2018-02-22 16:08:14.628857000 +0000
+@@ -52,7 +52,7 @@
+ CFLAGS += -Wmissing-prototypes
+ CFLAGS += -fms-extensions -funsigned-char -fno-strict-aliasing
+ CFLAGS += -D_FILE_OFFSET_BITS=64
+-CFLAGS += -I${BUILDDIR} -I${ROOTDIR}/src -I${ROOTDIR}
++CFLAGS := -I${BUILDDIR} -I${ROOTDIR}/src -I${ROOTDIR} ${CFLAGS}
+ ifeq ($(CONFIG_ANDROID),yes)
+ LDFLAGS += -lm
+ else