aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-05-27 08:20:19 +0800
committerMark Linimon <linimon@FreeBSD.org>2017-05-27 08:20:19 +0800
commitc52a715800ff83f6a958709fb689f16631b4ef8a (patch)
tree6ebe315b8b10cbc2ec7619f8a666f8cab5b7b90c
parent13751f7ab8e0664df6343f3b041a3aeaca0d8712 (diff)
downloadfreebsd-ports-c52a715800ff83f6a958709fb689f16631b4ef8a.tar.gz
freebsd-ports-c52a715800ff83f6a958709fb689f16631b4ef8a.tar.zst
freebsd-ports-c52a715800ff83f6a958709fb689f16631b4ef8a.zip
Mark some ports failing on armv6, for errors classified as "???",
part 2. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=441819
-rw-r--r--mail/cyrus-imapd25/Makefile2
-rw-r--r--mail/tkrat2/Makefile3
-rw-r--r--math/coq/Makefile5
-rw-r--r--math/jakarta-commons-math3/Makefile2
-rw-r--r--misc/freeguide/Makefile2
-rw-r--r--multimedia/gstreamer-plugins-mpeg2enc/Makefile2
-rw-r--r--multimedia/gstreamer1-plugins-mpeg2enc/Makefile2
-rw-r--r--multimedia/libav/Makefile2
-rw-r--r--multimedia/mpeg_play/Makefile4
-rw-r--r--net/hsflowd/Makefile6
-rw-r--r--net/ipsvd/Makefile3
-rw-r--r--net/openmpi2/Makefile5
-rw-r--r--net/pacemaker/Makefile7
-rw-r--r--print/pdf-renderer/Makefile2
-rw-r--r--science/openkim/Makefile2
-rw-r--r--security/hpenc/Makefile3
-rw-r--r--security/p5-Digest-GOST/Makefile4
-rw-r--r--security/poly1305aes/Makefile3
-rw-r--r--shells/bash-completion/Makefile2
-rw-r--r--sysutils/acpica-tools/Makefile7
-rw-r--r--sysutils/dc3dd/Makefile8
-rw-r--r--sysutils/e2fsprogs/Makefile3
-rw-r--r--sysutils/geomWatch/Makefile7
-rw-r--r--sysutils/passwordsafe/Makefile3
-rw-r--r--www/apache-forrest/Makefile2
-rw-r--r--www/ctemplate/Makefile4
-rw-r--r--www/domoticz/Makefile2
-rw-r--r--www/libhpack/Makefile2
-rw-r--r--x11-toolkits/gnustep-gui/Makefile18
29 files changed, 83 insertions, 34 deletions
diff --git a/mail/cyrus-imapd25/Makefile b/mail/cyrus-imapd25/Makefile
index b458d2f327b2..86554d57d282 100644
--- a/mail/cyrus-imapd25/Makefile
+++ b/mail/cyrus-imapd25/Makefile
@@ -17,6 +17,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2 \
libpcre.so:devel/pcre
+BROKEN_armv6= fails to build: ./tools/config2header: Error code 1
+
CONFLICTS_INSTALL= cyrus-imapd-2.[^5].* cyrus-imapd2[^5]-2.[^5].* \
cyrus-imapd3*
diff --git a/mail/tkrat2/Makefile b/mail/tkrat2/Makefile
index fd21dda05627..19d21976eb7d 100644
--- a/mail/tkrat2/Makefile
+++ b/mail/tkrat2/Makefile
@@ -17,7 +17,8 @@ LIB_DEPENDS= libtcl84.so:lang/tcl84 \
libtk84.so:x11-toolkits/tk84 \
libc-client4.so:mail/cclient
-BROKEN_sparc64= fails to build
+BROKEN_armv6= fails to link: ./ratatosk2.1.so: Undefined symbol "__aeabi_uidivmod"
+BROKEN_sparc64= fails to build
USES= ssl
USE_XORG= x11 xt
diff --git a/math/coq/Makefile b/math/coq/Makefile
index 6303a1752909..58260aa16ec3 100644
--- a/math/coq/Makefile
+++ b/math/coq/Makefile
@@ -18,6 +18,9 @@ BUILD_DEPENDS= camlp5:devel/ocaml-camlp5 \
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
+BROKEN_armv6= fails to compile: Fatal error: exception Invalid_argument("index out of bounds")
+BROKEN_powerpc= fails to link
+
USES= gmake gettext-runtime
USE_EMACS= yes
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk20 gtksourceview2 pango
@@ -32,8 +35,6 @@ CONFIGURE_ARGS= -prefix ${PREFIX} \
MAKE_ENV= VERBOSE=1
ALL_TARGET= world
-BROKEN_powerpc= does not link
-
OPTIONS_DEFINE= DOCS IDE
OPTIONS_DEFAULT= IDE
OPTIONS_SUB= yes
diff --git a/math/jakarta-commons-math3/Makefile b/math/jakarta-commons-math3/Makefile
index 7f449daf7442..49d4819e9611 100644
--- a/math/jakarta-commons-math3/Makefile
+++ b/math/jakarta-commons-math3/Makefile
@@ -17,6 +17,8 @@ COMMENT= Java library of self-contained mathematics and statistics components
LICENSE= APACHE20
+BROKEN_armv6= fails to compile: build.xml: Compile failed; see the compiler error output for details
+
USE_ANT= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
diff --git a/misc/freeguide/Makefile b/misc/freeguide/Makefile
index 45a5ab24932d..d8f42cdb42f9 100644
--- a/misc/freeguide/Makefile
+++ b/misc/freeguide/Makefile
@@ -14,6 +14,8 @@ LICENSE_FILE= ${WRKSRC}/doc/COPYING
RUN_DEPENDS= tv_cat:textproc/p5-xmltv
+BROKEN_armv6= fails to package: freeguide.1.gz: No such file or directory
+
USE_JAVA= yes
JAVA_VERSION= 1.6+
USE_ANT= yes
diff --git a/multimedia/gstreamer-plugins-mpeg2enc/Makefile b/multimedia/gstreamer-plugins-mpeg2enc/Makefile
index 341e61611c80..5ae0faac0bc3 100644
--- a/multimedia/gstreamer-plugins-mpeg2enc/Makefile
+++ b/multimedia/gstreamer-plugins-mpeg2enc/Makefile
@@ -7,6 +7,8 @@ CATEGORIES= multimedia
COMMENT= Gstreamer mpeg encoder plugin
+BROKEN_armv6= fails to compile: 'format_codes.h' file not found
+
GST_PLUGIN= mpeg2enc
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
diff --git a/multimedia/gstreamer1-plugins-mpeg2enc/Makefile b/multimedia/gstreamer1-plugins-mpeg2enc/Makefile
index ba0f7e2a1ab6..ca1877ddb4bc 100644
--- a/multimedia/gstreamer1-plugins-mpeg2enc/Makefile
+++ b/multimedia/gstreamer1-plugins-mpeg2enc/Makefile
@@ -5,6 +5,8 @@ CATEGORIES= multimedia
COMMENT= GStreamer mpeg encoder plugin
+BROKEN_armv6= fails to compile: 'format_codes.h' file not found
+
GST_PLUGIN= mpeg2enc
DIST= bad
diff --git a/multimedia/libav/Makefile b/multimedia/libav/Makefile
index 9c3171cd03fe..07ebe632fed5 100644
--- a/multimedia/libav/Makefile
+++ b/multimedia/libav/Makefile
@@ -17,6 +17,8 @@ LIB_DEPENDS= libopencv_core.so:graphics/opencv-core \
libvdpau.so:multimedia/libvdpau \
libhogweed.so:security/nettle
+BROKEN_armv6= fails to compile: cc: warning: joined argument expects additional value: -mcpu=
+
USES= cpe gmake perl5 pkgconfig tar:xz
USE_XORG= x11
HAS_CONFIGURE= yes
diff --git a/multimedia/mpeg_play/Makefile b/multimedia/mpeg_play/Makefile
index 798453268d11..1b078ebe8a03 100644
--- a/multimedia/mpeg_play/Makefile
+++ b/multimedia/mpeg_play/Makefile
@@ -12,8 +12,8 @@ EXTRACT_SUFX= -patched-src.tar.gz
MAINTAINER= lme@FreeBSD.org
COMMENT= Program to play mpeg movies on X displays
-BROKEN_aarch64= fails to build: Unknown endianness of architecture
-BROKEN_mips64= fails to build: Unknown endianness of architecture
+NOT_FOR_ARCHS= aarch64 armv6 mips mips64
+NOT_FOR_ARCHS_REASON= fails to build: Unknown endianness of architecture
WRKSRC= ${WRKDIR}/mpeg_play
USES= imake
diff --git a/net/hsflowd/Makefile b/net/hsflowd/Makefile
index 233b875365c3..204a82d4bae7 100644
--- a/net/hsflowd/Makefile
+++ b/net/hsflowd/Makefile
@@ -4,11 +4,15 @@
PORTNAME= hsflowd
PORTVERSION= 1.24.1
CATEGORIES= net
-MASTER_SITES= http://mirrors.rit.edu/zi/
+MASTER_SITES= http://mirrors.rit.edu/zi/
MAINTAINER= zi@FreeBSD.org
COMMENT= Agent that exports metrics using the sFlow protocol
+BROKEN_armv6= fails to compile: src/FreeBSD/Makefile: Malformed conditional (empty $(BINDIR))
+BROKEN_mips= fails to compile: src/FreeBSD/Makefile: Malformed conditional (empty $(BINDIR))
+BROKEN_mips64= fails to compile: src/FreeBSD/Makefile: Malformed conditional (empty $(BINDIR))
+
SUB_FILES= pkg-message
USE_RC_SUBR= ${PORTNAME}
MAKE_ENV= BINDIR=${PREFIX}/sbin INITDIR=${PREFIX}/etc/rc.d \
diff --git a/net/ipsvd/Makefile b/net/ipsvd/Makefile
index c4c93b257802..c849c31afef2 100644
--- a/net/ipsvd/Makefile
+++ b/net/ipsvd/Makefile
@@ -12,6 +12,9 @@ COMMENT= Internet protocol service daemons
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/package/COPYING
+BROKEN_armv6= fails to install: Checking udpsvd... drop: unable to read from socket: bad address
+BROKEN_mips64= fails to install: tcpsvd failed
+
WRKSRC= ${WRKDIR}/net/${DISTNAME}
ALL_TARGET= default
diff --git a/net/openmpi2/Makefile b/net/openmpi2/Makefile
index 6c212cd49b13..12e14f3818ca 100644
--- a/net/openmpi2/Makefile
+++ b/net/openmpi2/Makefile
@@ -18,6 +18,9 @@ LIB_DEPENDS= libhwloc.so:devel/hwloc \
libevent.so:devel/libevent \
libmunge.so:security/munge
+BROKEN_armv6= fails to package: pkg-static: mca_patcher_overwrite.la: No such file or directory
+BROKEN_sparc64= fails to compile on sparc64
+
HAS_CONFIGURE= yes
INSTALL_TARGET= install-strip
# :keepla because port uses lt_dlopen
@@ -81,8 +84,6 @@ SLURM_PLIST_FILES= ${MPIDIR}/lib/openmpi/mca_ess_slurm.la \
${MPIDIR}/share/openmpi/help-plm-slurm.txt \
${MPIDIR}/share/openmpi/help-ras-slurm.txt
-BROKEN_sparc64= Does not compile on sparc64
-
post-patch:
@${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/${MPIDIR}/libdata/pkgconfig|g' \
${WRKSRC}/ompi/tools/wrappers/Makefile.am \
diff --git a/net/pacemaker/Makefile b/net/pacemaker/Makefile
index ead92f0ef6b3..ac4d0e5ec1cf 100644
--- a/net/pacemaker/Makefile
+++ b/net/pacemaker/Makefile
@@ -3,8 +3,8 @@
PORTNAME= pacemaker
PORTVERSION= 1.1.14
-PORTREVISION= 2
DISTVERSIONPREFIX= Pacemaker-
+PORTREVISION= 2
CATEGORIES= net
MAINTAINER= dpejesh@yahoo.com
@@ -12,8 +12,6 @@ COMMENT= Scalable High-Availability cluster resource manager
LICENSE= GPLv2
-BROKEN_powerpc64= Does not build
-
BUILD_DEPENDS= bash:shells/bash \
corosync:net/corosync
LIB_DEPENDS= libgnutls.so:security/gnutls \
@@ -25,6 +23,9 @@ LIB_DEPENDS= libgnutls.so:security/gnutls \
RUN_DEPENDS= bash:shells/bash \
corosync:net/corosync
+BROKEN_armv6= fails to install: help2man: can't get '--help' info from pacemakerd
+BROKEN_powerpc64= fails to build
+
CONFLICTS= heartbeat-[0-9]*
USERS= hacluster
diff --git a/print/pdf-renderer/Makefile b/print/pdf-renderer/Makefile
index eb5e43fa1d4a..c731b32aad6d 100644
--- a/print/pdf-renderer/Makefile
+++ b/print/pdf-renderer/Makefile
@@ -13,6 +13,8 @@ COMMENT= 100% Java PDF renderer and viewer
LICENSE= LGPL21
+BROKEN_armv6= fails to install: swinglabs-build-impl.xml: Javadoc returned 1
+
USES= dos2unix zip
NO_WRKSUBDIR= yes
USE_JAVA= yes
diff --git a/science/openkim/Makefile b/science/openkim/Makefile
index 7fdaa632ad09..2535a011abc6 100644
--- a/science/openkim/Makefile
+++ b/science/openkim/Makefile
@@ -22,7 +22,7 @@ MAKE_JOBS_UNSAFE=yes
.include <bsd.port.options.mk>
# Is there a better way to detect 32-bit systems?
-.if ${ARCH} == "i386" || ${ARCH} == "powerpc"
+.if ${ARCH} == "armv6" || ${ARCH} == "i386" || ${ARCH} == "mips" || ${ARCH} == "powerpc"
MAKE_ENV+= KIM_SYSTEM32="yes"
.endif
diff --git a/security/hpenc/Makefile b/security/hpenc/Makefile
index 85231c138503..f2dca3ef8447 100644
--- a/security/hpenc/Makefile
+++ b/security/hpenc/Makefile
@@ -11,7 +11,8 @@ COMMENT= Fast authenticated encryption CLI tool
LICENSE= BSD2CLAUSE
-BROKEN_powerpc64= Does not build: fatal error: cpuid_flags.inc: No such file or directory
+BROKEN_armv6= fails to build: fatal error: cpuid_flags.inc: No such file or directory
+BROKEN_powerpc64= fails to build: fatal error: cpuid_flags.inc: No such file or directory
NOT_FOR_ARCHS= aarch64 sparc64
NOT_FOR_ARCHS_REASON= not yet ported to this architecture
diff --git a/security/p5-Digest-GOST/Makefile b/security/p5-Digest-GOST/Makefile
index 223226bedb10..0d9dc57f2d41 100644
--- a/security/p5-Digest-GOST/Makefile
+++ b/security/p5-Digest-GOST/Makefile
@@ -12,8 +12,8 @@ COMMENT= Perl interface to the GOST R 34.11-94 digest algorithm
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-BROKEN_aarch64= fails to build: Cannot detect CPU architechture
-BROKEN_mips64= fails to build: Cannot detect CPU architechture
+NOT_FOR_ARCHS= aarch64 armv6 mips64
+NOT_FOR_ARCHS_REASON= fails to build: Cannot detect CPU architechture
USES= perl5
USE_PERL5= configure
diff --git a/security/poly1305aes/Makefile b/security/poly1305aes/Makefile
index 24ce7bc5bf34..a94ca04f153a 100644
--- a/security/poly1305aes/Makefile
+++ b/security/poly1305aes/Makefile
@@ -15,7 +15,8 @@ ALL_TARGET= default
CC+= ${CPPFLAGS} ${CFLAGS} ${LDFLAGS}
-BROKEN_aarch64= Fails to build: poly1305aes.impl.do: fatal: all tests failed
+BROKEN_armv6= fails to build: poly1305aes.impl.do: fatal: all tests failed
+BROKEN_aarch64= fails to build: poly1305aes.impl.do: fatal: all tests failed
NOT_FOR_ARCHS= amd64
.include <bsd.port.pre.mk>
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index f5e6958acd0d..d9219a83a919 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -14,6 +14,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= bash:shells/bash
+BROKEN_armv6= fails to build: gmake: install-recursive: Error 1
+
USE_GITHUB= yes
GH_ACCOUNT= scop
diff --git a/sysutils/acpica-tools/Makefile b/sysutils/acpica-tools/Makefile
index f7080182812a..27ead3700cfe 100644
--- a/sysutils/acpica-tools/Makefile
+++ b/sysutils/acpica-tools/Makefile
@@ -14,6 +14,10 @@ COMMENT= Tools from the ACPI Component Architecture (ACPICA) project
LICENSE= BSD3CLAUSE GPLv2
LICENSE_COMB= dual
+BROKEN_armv6= fails to compile: comparison of constant -1 with expression of type char is always true
+BROKEN_aarch64= fails to compile: comparison of constant -1 with expression of type char is always true
+BROKEN_powerpc64= fails to compile: comparison is always true due to limited range of data type
+
USES= gmake
BUILD_WRKSRC= ${WRKSRC}/generate/unix
@@ -26,9 +30,6 @@ PLIST_FILES= ${ACPICA_TOOLS:S,^,bin/,}
MAKE_ARGS= HOST=_FreeBSD NOOPT=TRUE PROGS="${ACPICA_TOOLS}"
MAKE_ARGS+= CC="${CC}" LEX="${FLEX}" YACC="${YACC}"
-BROKEN_aarch64= Fails to compile: error: comparison of constant -1 with expression of type char is always true
-BROKEN_powerpc64= Fails to compile: warning: comparison is always true due to limited range of data type
-
do-install:
${INSTALL_PROGRAM} ${ACPICA_TOOLS:S,^,${BUILD_WRKSRC}/bin/,} \
${STAGEDIR}${PREFIX}/bin
diff --git a/sysutils/dc3dd/Makefile b/sysutils/dc3dd/Makefile
index d06b727d1cc7..621659417628 100644
--- a/sysutils/dc3dd/Makefile
+++ b/sysutils/dc3dd/Makefile
@@ -10,14 +10,16 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/7.2
MAINTAINER= nobutaka@FreeBSD.org
COMMENT= dd program useful for computer forensics
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BROKEN_armv6= fails to compile: bit-field 'verify_error_if_negative_size__' has negative width
+
USES= gettext iconv gmake tar:bzip2
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
-LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/COPYING
-
OPTIONS_DEFINE= NLS
.include <bsd.port.options.mk>
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index f60d6d99092b..0a773973f280 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -15,6 +15,9 @@ LICENSE= GPLv2
PORTSCOUT= ignore # cannot handle the version in the directory
BROKEN_aarch64= fails to link: missing sbrk
+BROKEN_armv6= fails self-tests: Running e2fsprogs test suite...failed: f_pre_1970_date_encoding
+BROKEN_mips= fails self-tests: Running e2fsprogs test suite...failed: f_pre_1970_date_encoding
+BROKEN_mips64= fails self-tests: Running e2fsprogs test suite...failed: f_pre_1970_date_encoding
BROKEN_powerpc64= fails self-tests: Running e2fsprogs test suite...Signal (11) SIGSEGV
USES= cpe gmake pkgconfig tar:xz
diff --git a/sysutils/geomWatch/Makefile b/sysutils/geomWatch/Makefile
index 16d7e4b7d653..3e1d83dd416b 100644
--- a/sysutils/geomWatch/Makefile
+++ b/sysutils/geomWatch/Makefile
@@ -17,6 +17,10 @@ COMMENT= Watches for and e-mails admins about GEOM/ZFS state changes
LIB_DEPENDS= libesmtp.so:mail/libesmtp
+BROKEN_aarch64= fails to compile: ISA not supported
+BROKEN_armv6= fails to compile: call to 'atomic_add_64' is ambiguous
+IGNORE_DragonFly= requires geom(4) support
+
USES= tar:tbz
SUB_FILES= pkg-message
@@ -25,7 +29,4 @@ USE_RC_SUBR= ${PORTNAME}
MAKE_ARGS= WITH_ZFS=28
-BROKEN_aarch64= fails to compile: error: ISA not supported
-IGNORE_DragonFly= requires geom(4) support
-
.include <bsd.port.mk>
diff --git a/sysutils/passwordsafe/Makefile b/sysutils/passwordsafe/Makefile
index 45e5d4cda78d..8296df60ec5c 100644
--- a/sysutils/passwordsafe/Makefile
+++ b/sysutils/passwordsafe/Makefile
@@ -13,6 +13,9 @@ LIB_DEPENDS= libuuid.so:misc/e2fsprogs-libuuid \
libxerces-c-3.1.so:textproc/xerces-c3
BUILD_DEPENDS= zip:archivers/zip
+NOT_FOR_ARCHS= armv6
+NOT_FOR_ARCHS_REASON= Cannot determine whether the target CPU is big or little endian - please fix PwsPlatform.h
+
CONFLICTS= pwsafe-[0-9]*
USES= gmake
diff --git a/www/apache-forrest/Makefile b/www/apache-forrest/Makefile
index 6859df346e0b..605ff9778596 100644
--- a/www/apache-forrest/Makefile
+++ b/www/apache-forrest/Makefile
@@ -12,6 +12,8 @@ DISTFILES= ${DISTNAME}-sources.tar.gz \
MAINTAINER= nivit@FreeBSD.org
COMMENT= Tool for rapid development of small sites
+BROKEN_armv6= fails to compile: build.xml: tools/ant/lib not found
+
ANT= ${STAGEDIR}${DATADIR}/tools/ant/bin/ant
ANT_TARGET= local-deploy
diff --git a/www/ctemplate/Makefile b/www/ctemplate/Makefile
index 966e9739cfad..a8c631f5a275 100644
--- a/www/ctemplate/Makefile
+++ b/www/ctemplate/Makefile
@@ -9,7 +9,9 @@ MASTER_SITES= SF
MAINTAINER= ap@page2rss.com
COMMENT= Template system for C
-USES= gmake
+BROKEN_armv6= fails to compile: assigning to char * from incompatible type const char *
+
+USES= gmake
GNU_CONFIGURE= yes
PLIST_FILES+= bin/h2ap
diff --git a/www/domoticz/Makefile b/www/domoticz/Makefile
index 0c89e3c5e365..dedc04ca5dce 100644
--- a/www/domoticz/Makefile
+++ b/www/domoticz/Makefile
@@ -15,6 +15,8 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libexpat.so:textproc/expat2 \
libtelldus-core.so:comms/telldus-core
+BROKEN_armv6= fails to compile: HarmonyHub.cpp: ordered comparison between pointer and zero
+
CONFLICTS_INSTALL?= domoticz-[23]*
OPTIONS_SUB= YES
diff --git a/www/libhpack/Makefile b/www/libhpack/Makefile
index 0c31ffbe9411..cd95d906fe69 100644
--- a/www/libhpack/Makefile
+++ b/www/libhpack/Makefile
@@ -17,6 +17,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libcheck.so:devel/check
+BROKEN_armv6= fails to compile: Can't define TIME_MAX
+
CMAKE_ARGS= -DBUILD_DOCS=OFF \
-DBUILD_TESTS=OFF \
-DENABLE_GCOV=OFF \
diff --git a/x11-toolkits/gnustep-gui/Makefile b/x11-toolkits/gnustep-gui/Makefile
index b64ba2c27e97..612583915215 100644
--- a/x11-toolkits/gnustep-gui/Makefile
+++ b/x11-toolkits/gnustep-gui/Makefile
@@ -10,15 +10,8 @@ MASTER_SITES= GNUSTEP/core
MAINTAINER= theraven@FreeBSD.org
COMMENT= GNUstep GUI library
-LICENSE_COMB= multi
LICENSE= GPLv3 LGPL3
-
-OPTIONS_DEFINE= DOCS CUPS ASPELL
-OPTIONS_DEFAULT= CUPS
-OPTIONS_SUB= yes
-
-DOCS_BUILD_DEPENDS= texi2html:textproc/texi2html \
- texi2pdf:print/texinfo
+LICENSE_COMB= multi
LIB_DEPENDS+= libtiff.so:graphics/tiff
LIB_DEPENDS+= libpng.so:graphics/png
@@ -28,6 +21,15 @@ LIB_DEPENDS+= libsndfile.so:audio/libsndfile
LIB_DEPENDS+= libao.so:audio/libao
BUILD_DEPENDS+= ${LOCALBASE}/lib/libflite.a:audio/flite
+BROKEN_armv6= fails to package: chmod: GSSpeechServer.desktop: No such file or directory
+
+OPTIONS_DEFINE= DOCS CUPS ASPELL
+OPTIONS_DEFAULT= CUPS
+OPTIONS_SUB= yes
+
+DOCS_BUILD_DEPENDS= texi2html:textproc/texi2html \
+ texi2pdf:print/texinfo
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-tiff-library=${LOCALBASE}/lib
CONFIGURE_ARGS+= --with-tiff-include=${LOCALBASE}/include