aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-29 00:59:42 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-29 00:59:42 +0800
commitcb47907e1a40ea672c8068b4a08dea0e9a2a9bc5 (patch)
tree06f782c8e7ce808783915c0378a1ac8adaf6ebd9
parente3cfe61ef4da37dbc13ae66729859f7ada5cc27c (diff)
downloadfreebsd-ports-cb47907e1a40ea672c8068b4a08dea0e9a2a9bc5.tar.gz
freebsd-ports-cb47907e1a40ea672c8068b4a08dea0e9a2a9bc5.tar.zst
freebsd-ports-cb47907e1a40ea672c8068b4a08dea0e9a2a9bc5.zip
New port: devel/py-swagger-spec-validator: Validation of Swagger specifications
PR: 227038 Submitted by: Kai <freebsd_ports@k-worx.org>
Notes
Notes: svn path=/head/; revision=465821
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-swagger-spec-validator/Makefile22
-rw-r--r--devel/py-swagger-spec-validator/distinfo3
-rw-r--r--devel/py-swagger-spec-validator/pkg-descr5
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ad3d912e79ab..b5e97dedd3fb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4954,6 +4954,7 @@
SUBDIR += py-sure
SUBDIR += py-sysctl
SUBDIR += py-sysv_ipc
+ SUBDIR += py-swagger-spec-validator
SUBDIR += py-tables
SUBDIR += py-tabulate
SUBDIR += py-tapi
diff --git a/devel/py-swagger-spec-validator/Makefile b/devel/py-swagger-spec-validator/Makefile
new file mode 100644
index 000000000000..888ae3b7b19e
--- /dev/null
+++ b/devel/py-swagger-spec-validator/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= swagger-spec-validator
+DISTVERSION= 2.1.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= Validation of Swagger specifications
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsonschema>0:devel/py-jsonschema@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}simplejson>0:devel/py-simplejson@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-swagger-spec-validator/distinfo b/devel/py-swagger-spec-validator/distinfo
new file mode 100644
index 000000000000..90c717d889ea
--- /dev/null
+++ b/devel/py-swagger-spec-validator/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522248350
+SHA256 (swagger-spec-validator-2.1.0.tar.gz) = dc9219c6572ce0def6e1c160ca253c0e7fcde75812628f0c0199334f85bd138e
+SIZE (swagger-spec-validator-2.1.0.tar.gz) = 15729
diff --git a/devel/py-swagger-spec-validator/pkg-descr b/devel/py-swagger-spec-validator/pkg-descr
new file mode 100644
index 000000000000..ca7548069439
--- /dev/null
+++ b/devel/py-swagger-spec-validator/pkg-descr
@@ -0,0 +1,5 @@
+Swagger Spec Validator is a Python library that validates Swagger Specs against
+the Swagger 1.2 or Swagger 2.0 specification. The validator aims to check for
+full compliance with the specification.
+
+WWW: https://github.com/Yelp/swagger_spec_validator