aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-03-22 04:14:11 +0800
committerKurt Jaeger <pi@FreeBSD.org>2018-03-22 04:14:11 +0800
commitcc3c2817feada6d538a49253544539e21d93baa9 (patch)
tree7052f48d9378d7a4404a32f8c1bf733e5a819ccf
parent522c80dd1ab6ab25180c3f093f3d4aff4e20591c (diff)
downloadfreebsd-ports-cc3c2817feada6d538a49253544539e21d93baa9.tar.gz
freebsd-ports-cc3c2817feada6d538a49253544539e21d93baa9.tar.zst
freebsd-ports-cc3c2817feada6d538a49253544539e21d93baa9.zip
New port: dns/dsc
DSC (originally developed by The Measurement Factory and now developed by DNS-OARC) is a system for collecting and exploring statistics from busy DNS servers. It uses a distributed architecture with collectors running on or near nameservers sending their data to one or more central presenters for display and archiving. Collectors use pcap to sniff network traffic. They transmit aggregated data to the presenter as XML data. dsc is configurable to allow the administrator to capture any kind of data that he or she chooses. WWW: https://www.dns-oarc.net/dsc/ PR: 226631 Submitted by: Leo Vandewoestijne <freebsd@dns.company>
Notes
Notes: svn path=/head/; revision=465237
-rw-r--r--dns/Makefile1
-rw-r--r--dns/dsc/Makefile28
-rw-r--r--dns/dsc/distinfo3
-rw-r--r--dns/dsc/files/patch-cron_upload-prep.pl8
-rw-r--r--dns/dsc/files/pkg-message.in7
-rw-r--r--dns/dsc/pkg-descr10
-rw-r--r--dns/dsc/pkg-plist12
7 files changed, 69 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 320338d74998..fce194f16234 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -63,6 +63,7 @@
SUBDIR += doc
SUBDIR += dq
SUBDIR += drool
+ SUBDIR += dsc
SUBDIR += dsp
SUBDIR += dynip
SUBDIR += erlang-idna
diff --git a/dns/dsc/Makefile b/dns/dsc/Makefile
new file mode 100644
index 000000000000..f6e5ae8561f5
--- /dev/null
+++ b/dns/dsc/Makefile
@@ -0,0 +1,28 @@
+# Created by: Leo Vandewoestijne <freebsd@dns.company>
+# $FreeBSD$
+
+PORTNAME= dsc
+PORTVERSION= 2.6.1
+CATEGORIES= dns
+MASTER_SITES= https://www.dns-oarc.net/files/dsc/ \
+ https://dns.company/files/dsc/
+
+MAINTAINER= freebsd@dns.company
+COMMENT= Tool used for collecting and exploring statistics from DNS servers
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= libpcap>=1.8.1:net/libpcap \
+ GeoIP>=1.6.12:net/GeoIP \
+ p5-Proc-PID-File>=1.28:devel/p5-Proc-PID-File \
+ p5-XML-Simple>=2.24:textproc/p5-XML-Simple \
+ dsp>=2.0.0:dns/dsp
+
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+GNU_CONFIGURE= yes
+USES= gmake perl5 shebangfix
+
+SUB_FILES= pkg-message
+
+.include <bsd.port.mk>
diff --git a/dns/dsc/distinfo b/dns/dsc/distinfo
new file mode 100644
index 000000000000..f778b1bb5f13
--- /dev/null
+++ b/dns/dsc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520903828
+SHA256 (dsc-2.6.1.tar.gz) = e11019dc8cebd971bec420bb28dc97acc851dfd328c5d40bbf6b41df467db285
+SIZE (dsc-2.6.1.tar.gz) = 320065
diff --git a/dns/dsc/files/patch-cron_upload-prep.pl b/dns/dsc/files/patch-cron_upload-prep.pl
new file mode 100644
index 000000000000..f5896443e7e6
--- /dev/null
+++ b/dns/dsc/files/patch-cron_upload-prep.pl
@@ -0,0 +1,8 @@
+--- cron/upload-prep.pl.orig 2018-03-13 22:05:23 UTC
++++ cron/upload-prep.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/local/bin/perl
+ #
+ # Copyright (c) 2016-2017, OARC, Inc.
+ # Copyright (c) 2007, The Measurement Factory, Inc.
diff --git a/dns/dsc/files/pkg-message.in b/dns/dsc/files/pkg-message.in
new file mode 100644
index 000000000000..242ed921dfdd
--- /dev/null
+++ b/dns/dsc/files/pkg-message.in
@@ -0,0 +1,7 @@
+###########################################
+
+Before you configure:
+To obtain MaxMind's GeoIP tables,
+run %%LOCALBASE%%/bin/geoipupdate.sh manually.
+
+###########################################
diff --git a/dns/dsc/pkg-descr b/dns/dsc/pkg-descr
new file mode 100644
index 000000000000..bcc491078321
--- /dev/null
+++ b/dns/dsc/pkg-descr
@@ -0,0 +1,10 @@
+DSC (originally developed by The Measurement Factory and now developed
+by DNS-OARC) is a system for collecting and exploring statistics from
+busy DNS servers. It uses a distributed architecture with collectors
+running on or near nameservers sending their data to one or more
+central presenters for display and archiving. Collectors use pcap to
+sniff network traffic. They transmit aggregated data to the presenter
+as XML data. dsc is configurable to allow the administrator to capture
+any kind of data that he or she chooses.
+
+WWW: https://www.dns-oarc.net/dsc/
diff --git a/dns/dsc/pkg-plist b/dns/dsc/pkg-plist
new file mode 100644
index 000000000000..f160dc9dd964
--- /dev/null
+++ b/dns/dsc/pkg-plist
@@ -0,0 +1,12 @@
+bin/dsc
+%%ETCDIR%%/dsc.conf.sample
+libexec/dsc/upload-prep.pl
+libexec/dsc/upload-rsync.sh
+libexec/dsc/upload-ssh.sh
+libexec/dsc/upload-x509.sh
+man/man1/dsc.1.gz
+man/man5/dsc.conf.5.gz
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%PORTDOCS%%%%DOCSDIR%%/UPGRADE.md