aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-26 04:48:20 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-26 04:48:20 +0800
commitd17e47575bd1a05fbb78708af5fa784765b4b8f0 (patch)
tree206bc8ce5823f109418b9bfcea6c9a73cbca59ff
parent70356e0ca4cd8c13d73e06e2f68d1235e0ead13b (diff)
downloadfreebsd-ports-d17e47575bd1a05fbb78708af5fa784765b4b8f0.tar.gz
freebsd-ports-d17e47575bd1a05fbb78708af5fa784765b4b8f0.tar.zst
freebsd-ports-d17e47575bd1a05fbb78708af5fa784765b4b8f0.zip
New port: devel/ga: Partitioned Global Address Space (PGAS) library for distributed arrays
Notes
Notes: svn path=/head/; revision=465545
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ga/Makefile28
-rw-r--r--devel/ga/distinfo3
-rw-r--r--devel/ga/pkg-descr11
-rw-r--r--devel/ga/pkg-plist49
5 files changed, 92 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index fc0e71922211..449fb6db1846 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -662,6 +662,7 @@
SUBDIR += fujaba
SUBDIR += funnelweb
SUBDIR += fuzzylite
+ SUBDIR += ga
SUBDIR += gaa
SUBDIR += gamin
SUBDIR += gauche-readline
diff --git a/devel/ga/Makefile b/devel/ga/Makefile
new file mode 100644
index 000000000000..80362ccb7e1a
--- /dev/null
+++ b/devel/ga/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= ga
+DISTVERSIONPREFIX= v
+DISTVERSION= 5.6.4
+CATEGORIES= devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Partitioned Global Address Space (PGAS) library for distributed arrays
+
+LICENSE= BMIL
+LICENSE_NAME= Battelle Memorial Institute License
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+LIB_DEPENDS= libblas.so:math/blas \
+ liblapack.so:math/lapack \
+ libmpich.so:net/mpich2
+
+USES= autoreconf fortran gmake libtool localbase
+USE_GITHUB= yes
+GH_ACCOUNT= GlobalArrays
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-peigs --enable-shared --disable-static
+INSTALL_TARGET= install-strip
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/devel/ga/distinfo b/devel/ga/distinfo
new file mode 100644
index 000000000000..4155f3c138d3
--- /dev/null
+++ b/devel/ga/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522000478
+SHA256 (GlobalArrays-ga-v5.6.4_GH0.tar.gz) = f1e2e92e0ab76f58d7f8afde633b7614dc120f35a99b6880e7320b1dd7e8e652
+SIZE (GlobalArrays-ga-v5.6.4_GH0.tar.gz) = 4958446
diff --git a/devel/ga/pkg-descr b/devel/ga/pkg-descr
new file mode 100644
index 000000000000..118ca6188049
--- /dev/null
+++ b/devel/ga/pkg-descr
@@ -0,0 +1,11 @@
+The Global Arrays (GA) toolkit provides a shared memory style programming
+environment in the context of distributed array data structures (called
+"global arrays"). From the user perspective, a global array can be used
+as if it was stored in shared memory. All details of the data distribution,
+addressing, and data access are encapsulated in the global array objects.
+Information about the actual data distribution and locality can be easily
+obtained and taken advantage of whenever data locality is important. The
+primary target architectures for which GA was developed are massively-parallel
+distributed-memory and scalable shared-memory systems.
+
+WWW: https://github.com/GlobalArrays/ga
diff --git a/devel/ga/pkg-plist b/devel/ga/pkg-plist
new file mode 100644
index 000000000000..0badf852e84f
--- /dev/null
+++ b/devel/ga/pkg-plist
@@ -0,0 +1,49 @@
+bin/adjust.x
+bin/armci-config
+bin/collisions.x
+bin/comex-config
+bin/ga-config
+include/armci.h
+include/chemio.h
+include/comex.h
+include/coms.h
+include/dra.fh
+include/dra.h
+include/eaf.fh
+include/eaf.h
+include/elio.h
+include/error.h
+include/farg.h
+include/ga-mpi.fh
+include/ga-mpi.h
+include/ga-papi.h
+include/ga-wapi.h
+include/ga.h
+include/gacommon.h
+include/global.fh
+include/macdecls.h
+include/macommon.h
+include/maf2c.fh
+include/mafdecls.fh
+include/matypes.h
+include/message.h
+include/msgtypesc.h
+include/msgtypesf.h
+include/parmci.h
+include/scope.h
+include/sf.fh
+include/sf.h
+include/string-util.h
+include/table.h
+include/tcgmsg.fh
+include/tcgmsg.h
+include/typesf2c.h
+lib/libarmci.so
+lib/libarmci.so.0
+lib/libarmci.so.0.0.0
+lib/libcomex.so
+lib/libcomex.so.0
+lib/libcomex.so.0.0.0
+lib/libga.so
+lib/libga.so.1
+lib/libga.so.1.0.4