aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2018-03-30 12:06:05 +0800
committerXin LI <delphij@FreeBSD.org>2018-03-30 12:06:05 +0800
commitd5d70b47add8fe25e61eda31756eea7ae8349bdd (patch)
tree8a159c897c816a0af73c25d3e11c6ef5327a8206
parent1b93e5c49ae20beb347d7c2566bba76ff4528bfd (diff)
downloadfreebsd-ports-d5d70b47add8fe25e61eda31756eea7ae8349bdd.tar.gz
freebsd-ports-d5d70b47add8fe25e61eda31756eea7ae8349bdd.tar.zst
freebsd-ports-d5d70b47add8fe25e61eda31756eea7ae8349bdd.zip
Update to 2.4.46.
Notes
Notes: svn path=/head/; revision=465945
-rw-r--r--net/openldap24-server/Makefile6
-rw-r--r--net/openldap24-server/distinfo6
-rw-r--r--net/openldap24-server/files/patch-libressl64
3 files changed, 56 insertions, 20 deletions
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 851c14f9f16d..b8652484c35a 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openldap
-DISTVERSION= 2.4.45
+DISTVERSION= 2.4.46
PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
@@ -65,9 +65,9 @@ BROKEN= incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}
.endif
PORTREVISION_CLIENT= 0
-PORTREVISION_SERVER= 4
+PORTREVISION_SERVER= 0
OPENLDAP_SHLIB_MAJOR= 2
-OPENLDAP_SHLIB_MINOR= 10.8
+OPENLDAP_SHLIB_MINOR= 10.9
OPENLDAP_MAJOR= ${DISTVERSION:R}
OPTIONS_DEFINE= DEBUG FETCH GSSAPI
diff --git a/net/openldap24-server/distinfo b/net/openldap24-server/distinfo
index 84d9825ede35..468466414016 100644
--- a/net/openldap24-server/distinfo
+++ b/net/openldap24-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1496558623
-SHA256 (openldap-2.4.45.tgz) = cdd6cffdebcd95161a73305ec13fc7a78e9707b46ca9f84fb897cd5626df3824
-SIZE (openldap-2.4.45.tgz) = 5672845
+TIMESTAMP = 1522043372
+SHA256 (openldap-2.4.46.tgz) = 9a90dcb86b99ae790ccab93b7585a31fbcbeec8c94bf0f7ab0ca0a87ea0c4b2d
+SIZE (openldap-2.4.46.tgz) = 5700204
diff --git a/net/openldap24-server/files/patch-libressl b/net/openldap24-server/files/patch-libressl
index 20a65a4e0fd1..74f8eebb56ad 100644
--- a/net/openldap24-server/files/patch-libressl
+++ b/net/openldap24-server/files/patch-libressl
@@ -1,5 +1,5 @@
---- libraries/libldap/tls_o.c.orig 2017-06-04 16:31:28 UTC
-+++ libraries/libldap/tls_o.c
+--- libraries/libldap/tls_o.c.orig 2018-03-22 08:44:27.000000000 -0700
++++ libraries/libldap/tls_o.c 2018-03-29 20:41:39.574182742 -0700
@@ -47,7 +47,7 @@
#include <ssl.h>
#endif
@@ -9,7 +9,25 @@
#define ASN1_STRING_data(x) ASN1_STRING_get0_data(x)
#endif
-@@ -157,7 +157,7 @@ tlso_init( void )
+@@ -65,7 +65,7 @@
+ static int tlso_verify_cb( int ok, X509_STORE_CTX *ctx );
+ static int tlso_verify_ok( int ok, X509_STORE_CTX *ctx );
+ static int tlso_seed_PRNG( const char *randfile );
+-#if OPENSSL_VERSION_NUMBER < 0x10100000
++#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined(LIBRESSL_VERSION_NUMBER)
+ /*
+ * OpenSSL 1.1 API and later has new locking code
+ */
+@@ -116,7 +116,7 @@
+ #endif
+ #endif /* OpenSSL 1.1 */
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000
++#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined(LIBRESSL_VERSION_NUMBER)
+ /*
+ * OpenSSL 1.1 API and later makes the BIO method concrete types internal.
+ */
+@@ -197,7 +197,7 @@
(void) tlso_seed_PRNG( lo->ldo_tls_randfile );
#endif
@@ -18,7 +36,16 @@
SSL_load_error_strings();
SSL_library_init();
OpenSSL_add_all_digests();
-@@ -205,7 +205,7 @@ static void
+@@ -223,7 +223,7 @@
+
+ BIO_meth_free( tlso_bio_method );
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000
++#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined(LIBRESSL_VERSION_NUMBER)
+ EVP_cleanup();
+ #if OPENSSL_VERSION_NUMBER < 0x10000000
+ ERR_remove_state(0);
+@@ -249,7 +249,7 @@
tlso_ctx_ref( tls_ctx *ctx )
{
tlso_ctx *c = (tlso_ctx *)ctx;
@@ -27,7 +54,16 @@
#define SSL_CTX_up_ref(ctx) CRYPTO_add( &(ctx->references), 1, CRYPTO_LOCK_SSL_CTX )
#endif
SSL_CTX_up_ref( c );
-@@ -464,7 +464,7 @@ tlso_session_my_dn( tls_session *sess, struct berval *
+@@ -411,7 +411,7 @@
+ SSL_CTX_set_verify( ctx, i,
+ lo->ldo_tls_require_cert == LDAP_OPT_X_TLS_ALLOW ?
+ tlso_verify_ok : tlso_verify_cb );
+-#if OPENSSL_VERSION_NUMBER < 0x10100000
++#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined(LIBRESSL_VERSION_NUMBER)
+ SSL_CTX_set_tmp_rsa_callback( ctx, tlso_tmp_rsa_cb );
+ #endif
+ #ifdef HAVE_OPENSSL_CRL
+@@ -508,7 +508,7 @@
if (!x) return LDAP_INVALID_CREDENTIALS;
xn = X509_get_subject_name(x);
@@ -36,7 +72,7 @@
der_dn->bv_len = i2d_X509_NAME( xn, NULL );
der_dn->bv_val = xn->bytes->data;
#else
-@@ -500,7 +500,7 @@ tlso_session_peer_dn( tls_session *sess, struct berval
+@@ -544,7 +544,7 @@
return LDAP_INVALID_CREDENTIALS;
xn = X509_get_subject_name(x);
@@ -45,7 +81,7 @@
der_dn->bv_len = i2d_X509_NAME( xn, NULL );
der_dn->bv_val = xn->bytes->data;
#else
-@@ -721,7 +721,7 @@ struct tls_data {
+@@ -765,7 +765,7 @@
Sockbuf_IO_Desc *sbiod;
};
@@ -54,12 +90,12 @@
#define BIO_set_init(b, x) b->init = x
#define BIO_set_data(b, x) b->ptr = x
#define BIO_clear_flags(b, x) b->flags &= ~(x)
-@@ -822,7 +822,7 @@ tlso_bio_puts( BIO *b, const char *str )
- return tlso_bio_write( b, str, strlen( str ) );
+@@ -1170,7 +1170,7 @@
+ }
}
--#if OPENSSL_VERSION_NUMBER >= 0x10100000
-+#if OPENSSL_VERSION_NUMBER >= 0x10100000 && !defined(LIBRESSL_VERSION_NUMBER)
- struct bio_method_st {
- int type;
- const char *name;
+-#if OPENSSL_VERSION_NUMBER < 0x10100000
++#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined(LIBRESSL_VERSION_NUMBER)
+ static RSA *
+ tlso_tmp_rsa_cb( SSL *ssl, int is_export, int key_length )
+ {