aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Grosbein <eugen@FreeBSD.org>2018-03-28 19:37:37 +0800
committerEugene Grosbein <eugen@FreeBSD.org>2018-03-28 19:37:37 +0800
commitdd44d08de18438b8687ef4c46f0f97ea0065ad6c (patch)
treef0e18502d1251aed7b5e889be79a2c2036c17760
parenta66d1fd4a1d62ff225e00621c34cc8eea96df040 (diff)
downloadfreebsd-ports-dd44d08de18438b8687ef4c46f0f97ea0065ad6c.tar.gz
freebsd-ports-dd44d08de18438b8687ef4c46f0f97ea0065ad6c.tar.zst
freebsd-ports-dd44d08de18438b8687ef4c46f0f97ea0065ad6c.zip
New port: net-mgmt/p5-RDR-Collector
This is the Perl5 module designed to capture and process raw RDRv1 packets from a Cisco SCE series device. The port includes modules RDR::Collector, RDR::Processor and several sample scripts.
Notes
Notes: svn path=/head/; revision=465798
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/p5-RDR-Collector/Makefile24
-rw-r--r--net-mgmt/p5-RDR-Collector/distinfo3
-rw-r--r--net-mgmt/p5-RDR-Collector/pkg-descr4
-rw-r--r--net-mgmt/p5-RDR-Collector/pkg-plist8
5 files changed, 40 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 727e1421f957..0b9d00bd093c 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -267,6 +267,7 @@
SUBDIR += p5-SNMP-Simple
SUBDIR += p5-SNMP-Trapinfo
SUBDIR += p5-SNMP-Util
+ SUBDIR += p5-RDR-Collector
SUBDIR += p5-SNMP_Session
SUBDIR += p5-Telnet-Cisco
SUBDIR += p5-Tie-NetAddr-IP
diff --git a/net-mgmt/p5-RDR-Collector/Makefile b/net-mgmt/p5-RDR-Collector/Makefile
new file mode 100644
index 000000000000..111f59e34be5
--- /dev/null
+++ b/net-mgmt/p5-RDR-Collector/Makefile
@@ -0,0 +1,24 @@
+# Created by: Eugene Grosbein <eugen@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= RDR-Collector
+PORTVERSION= 1.0000
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= CPAN/RDR
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= eugen@FreeBSD.org
+COMMENT= Perl5 module to capture and process raw Cisco SCE RDRv1 packets
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+USES= perl5 shebangfix
+USE_PERL5= configure
+SHEBANG_FILES= examples/*.pl
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/p5-RDR-Collector/distinfo b/net-mgmt/p5-RDR-Collector/distinfo
new file mode 100644
index 000000000000..5219f12d1379
--- /dev/null
+++ b/net-mgmt/p5-RDR-Collector/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522233574
+SHA256 (RDR-Collector-1.0000.tar.gz) = b2a7471705634762b92565de0438362fb38bed15c9f249421b9c2c0084f15c3c
+SIZE (RDR-Collector-1.0000.tar.gz) = 19601
diff --git a/net-mgmt/p5-RDR-Collector/pkg-descr b/net-mgmt/p5-RDR-Collector/pkg-descr
new file mode 100644
index 000000000000..8505aa7d923f
--- /dev/null
+++ b/net-mgmt/p5-RDR-Collector/pkg-descr
@@ -0,0 +1,4 @@
+This is the Perl5 module designed to capture and process raw RDRv1 packets
+from a Cisco SCE series device.
+
+WWW: http://search.cpan.org/dist/RDR-Collector/
diff --git a/net-mgmt/p5-RDR-Collector/pkg-plist b/net-mgmt/p5-RDR-Collector/pkg-plist
new file mode 100644
index 000000000000..f6a95bda0b15
--- /dev/null
+++ b/net-mgmt/p5-RDR-Collector/pkg-plist
@@ -0,0 +1,8 @@
+%%PERL5_MAN3%%/RDR::Collector.3.gz
+%%PERL5_MAN3%%/RDR::Processor.3.gz
+%%SITE_PERL%%/RDR/Collector.pm
+%%SITE_PERL%%/RDR/Processor.pm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_process_raw.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_rdr_collect_only.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_rdr_collect_only_realtime.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_rdr_collect_only_realtime_db.pl