aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-03-25 23:36:43 +0800
committerTobias Kortkamp <tobik@FreeBSD.org>2018-03-25 23:36:43 +0800
commite0eee5ee79ab1bc6b709c6aa40200fa887484093 (patch)
tree5d3a23e70beda395fe63378b86ea1a4107077b22
parent4cd4110a9a91d2574b4ad094d017aa7462d4d02a (diff)
downloadfreebsd-ports-e0eee5ee79ab1bc6b709c6aa40200fa887484093.tar.gz
freebsd-ports-e0eee5ee79ab1bc6b709c6aa40200fa887484093.tar.zst
freebsd-ports-e0eee5ee79ab1bc6b709c6aa40200fa887484093.zip
multimedia/kodi-devel: Unbreak WAYLAND option
Notes
Notes: svn path=/head/; revision=465525
-rw-r--r--multimedia/kodi-devel/Makefile8
-rw-r--r--multimedia/kodi-devel/files/patch-rbpi9
-rw-r--r--multimedia/kodi-devel/files/patch-wayland35
3 files changed, 31 insertions, 21 deletions
diff --git a/multimedia/kodi-devel/Makefile b/multimedia/kodi-devel/Makefile
index f74fedab6651..5e72bfec0ce6 100644
--- a/multimedia/kodi-devel/Makefile
+++ b/multimedia/kodi-devel/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kodi
DISTVERSION= 18.0.g201803211302
+PORTREVISION= 1
CATEGORIES= multimedia
PKGNAMESUFFIX?= -devel
@@ -73,14 +74,13 @@ CONFIGURE_ENV= OPENSSL_LIBS="-L${OPENSSLLIB}" OPENSSL_CFLAGS="-I${OPENSSLINC}"
KODIARCH_i386= x86
KODIARCH_amd64= x86_64
-PLIST_SUB= ARCH=${KODIARCH_${ARCH}:U${ARCH}} OPSYS=${OPSYS:tl} \
- WAYLAND="@comment "
+PLIST_SUB= ARCH=${KODIARCH_${ARCH}:U${ARCH}} OPSYS=${OPSYS:tl}
OPTIONS_DEFINE= AVAHI CEC DBUS LIBBLURAY MYSQL NFS SMB SSH UPNP VAAPI \
VDPAU WEBSERVER
OPTIONS_DEFAULT= LIBBLURAY SNDIO SSH UPNP VAAPI VDPAU WEBSERVER X11
OPTIONS_SINGLE= PLATFORM
-OPTIONS_SINGLE_PLATFORM= GBM RPI X11
+OPTIONS_SINGLE_PLATFORM= GBM RPI WAYLAND X11
OPTIONS_EXCLUDE_amd64= RPI
OPTIONS_EXCLUDE_i386= RPI
OPTIONS_SUB= yes
@@ -95,7 +95,6 @@ CEC_DESC= CEC adapter support
GBM_DESC= GBM support (requires a kernel with evdev support)
PLATFORM_DESC= Platform
RPI_DESC= Raspberry Pi support
-WAYLAND_DESC= Wayland support (broken)
AVAHI_LIB_DEPENDS= libavahi-client.so:net/avahi-app
AVAHI_CMAKE_BOOL= ENABLE_AVAHI
@@ -154,7 +153,6 @@ VAAPI_CMAKE_BOOL= ENABLE_VAAPI
VDPAU_LIB_DEPENDS= libvdpau.so:multimedia/libvdpau
VDPAU_CMAKE_BOOL= ENABLE_VDPAU
-# Not enabled: Requires default WAYLAND in graphics/mesa-libs and missing graphics/waylandpp port
WAYLAND_BUILD_DEPENDS= wayland-protocols>=0:graphics/wayland-protocols
WAYLAND_CMAKE_ON= -DCORE_PLATFORM_NAME:STRING="wayland" \
-DWAYLAND_RENDER_SYSTEM:STRING="gl"
diff --git a/multimedia/kodi-devel/files/patch-rbpi b/multimedia/kodi-devel/files/patch-rbpi
index 6ad5af8a27de..4033a5eb2284 100644
--- a/multimedia/kodi-devel/files/patch-rbpi
+++ b/multimedia/kodi-devel/files/patch-rbpi
@@ -24,15 +24,6 @@
else()
message(WARNING "unknown CPU: ${CPU}")
endif()
---- cmake/treedata/freebsd/subdirs.txt.orig 2018-01-05 00:21:32 UTC
-+++ cmake/treedata/freebsd/subdirs.txt
-@@ -9,4 +9,6 @@ xbmc/storage/linux storage/linux
- xbmc/filesystem/posix filesystem/posix
- xbmc/utils/posix utils_posix
- xbmc/platform/posix posix
-+xbmc/cores/RetroPlayer/process/rbpi cores/RetroPlayer/process/rbpi
-+xbmc/cores/VideoPlayer/Process/rbpi cores/VideoPlayer/Process/rbpi
- xbmc/freebsd freebsdsupport
--- xbmc/windowing/rpi/WinSystemRpi.cpp.orig 2018-02-09 09:50:14 UTC
+++ xbmc/windowing/rpi/WinSystemRpi.cpp
@@ -32,9 +32,16 @@
diff --git a/multimedia/kodi-devel/files/patch-wayland b/multimedia/kodi-devel/files/patch-wayland
index bfbd88a936a9..b93cec9056a7 100644
--- a/multimedia/kodi-devel/files/patch-wayland
+++ b/multimedia/kodi-devel/files/patch-wayland
@@ -1,13 +1,34 @@
+--- cmake/modules/FindWaylandpp.cmake.orig 2018-03-21 13:02:45 UTC
++++ cmake/modules/FindWaylandpp.cmake
+@@ -10,7 +10,7 @@
+ # WAYLANDPP_DEFINITIONS - the waylandpp definitions
+ # WAYLANDPP_SCANNER - path to wayland-scanner++
+
+-pkg_check_modules(WAYLANDPP wayland-client++ wayland-egl++ wayland-cursor++)
++pkg_check_modules(WAYLANDPP wayland-client++ wayland-client-extra++ wayland-egl++ wayland-cursor++)
+ pkg_check_modules(PC_WAYLANDPP_SCANNER wayland-scanner++)
+ if(WAYLANDPP_FOUND)
+ pkg_get_variable(PC_WAYLANDPP_PKGDATADIR wayland-client++ pkgdatadir)
+--- cmake/treedata/freebsd/subdirs.txt.orig 2018-03-21 13:02:45 UTC
++++ cmake/treedata/freebsd/subdirs.txt
+@@ -9,4 +9,7 @@ xbmc/storage/linux storage/linux
+ xbmc/filesystem/posix filesystem/posix
+ xbmc/utils/posix utils_posix
+ xbmc/platform/posix posix
++xbmc/cores/RetroPlayer/process/rbpi cores/RetroPlayer/process/rbpi
++xbmc/cores/VideoPlayer/Process/rbpi cores/VideoPlayer/Process/rbpi
+ xbmc/freebsd freebsdsupport
++xbmc/windowing/linux windowing/linux
--- xbmc/windowing/wayland/ShellSurfaceXdgShell.h.orig 2018-03-21 13:02:45 UTC
+++ xbmc/windowing/wayland/ShellSurfaceXdgShell.h
-@@ -22,6 +22,7 @@
- #include "Connection.h"
+@@ -23,6 +23,7 @@
#include "ShellSurface.h"
-+#include <wayland-client-protocol.hpp>
#include <wayland-extra-protocols.hpp>
++#include <wayland-client-protocol-extra.hpp>
namespace KODI
+ {
--- xbmc/windowing/wayland/WinSystemWayland.cpp.orig 2018-03-21 13:02:45 UTC
+++ xbmc/windowing/wayland/WinSystemWayland.cpp
@@ -1331,7 +1331,7 @@ void CWinSystemWayland::PrepareFramePresentation()
@@ -21,11 +42,11 @@
m_presentationFeedbackHandlers.Invoke(tv, refresh, m_syncOutputID, m_syncOutputRefreshRate, msc);
--- xbmc/windowing/wayland/WinSystemWayland.h.orig 2018-03-21 13:02:45 UTC
+++ xbmc/windowing/wayland/WinSystemWayland.h
-@@ -28,6 +28,7 @@
- #include <set>
-
+@@ -30,6 +30,7 @@
#include <wayland-client.hpp>
-+#include <wayland-client-protocol.hpp>
#include <wayland-cursor.hpp>
#include <wayland-extra-protocols.hpp>
++#include <wayland-client-protocol-extra.hpp>
+ #include "Connection.h"
+ #include "Output.h"