aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2018-03-26 19:13:13 +0800
committerGuido Falsi <madpilot@FreeBSD.org>2018-03-26 19:13:13 +0800
commite2bc11562a239e216c9979a5bc0617e1e218ffb9 (patch)
tree606180d4125d5ec18a3ff2ed2f945f79912b1980
parentcb86b48c4a35abcfff4f415973948650595e3ba5 (diff)
downloadfreebsd-ports-e2bc11562a239e216c9979a5bc0617e1e218ffb9.tar.gz
freebsd-ports-e2bc11562a239e216c9979a5bc0617e1e218ffb9.tar.zst
freebsd-ports-e2bc11562a239e216c9979a5bc0617e1e218ffb9.zip
Fix asterisk 15 command line parsing.
PR: 226909 Submitted by: O. Hartmann <ohartmann@walstatt.org>
Notes
Notes: svn path=/head/; revision=465580
-rw-r--r--net/asterisk15/Makefile1
-rw-r--r--net/asterisk15/files/patch-main_asterisk.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/net/asterisk15/Makefile b/net/asterisk15/Makefile
index 7222e93d304a..411d967d45f6 100644
--- a/net/asterisk15/Makefile
+++ b/net/asterisk15/Makefile
@@ -2,6 +2,7 @@
PORTNAME= asterisk
PORTVERSION= 15.3.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= https://downloads.asterisk.org/pub/telephony/%SUBDIR%/:DEFAULT,g729
MASTER_SITE_SUBDIR= asterisk/ \
diff --git a/net/asterisk15/files/patch-main_asterisk.c b/net/asterisk15/files/patch-main_asterisk.c
new file mode 100644
index 000000000000..50382c6b909f
--- /dev/null
+++ b/net/asterisk15/files/patch-main_asterisk.c
@@ -0,0 +1,11 @@
+--- main/asterisk.c.orig 2018-03-15 16:31:26 UTC
++++ main/asterisk.c
+@@ -3991,7 +3991,7 @@ int main(int argc, char *argv[])
+ *
+ * \todo Document these options
+ */
+- optind = 0;
++ optind = 1;
+ while ((c = getopt(argc, argv, getopt_settings)) != -1) {
+ /*!\note Please keep the ordering here to alphabetical, capital letters
+ * first. This will make it easier in the future to select unused