aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-03-28 16:33:26 +0800
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-03-28 16:33:26 +0800
commite87930cff586134bc589a900b011dcc32208f35b (patch)
treec2b0c2e9f812f0e4d2cc7237cd89d86f33d903e8
parentd26d3ce43a1acfc587ef0951c94c5557a3450e13 (diff)
downloadfreebsd-ports-e87930cff586134bc589a900b011dcc32208f35b.tar.gz
freebsd-ports-e87930cff586134bc589a900b011dcc32208f35b.tar.zst
freebsd-ports-e87930cff586134bc589a900b011dcc32208f35b.zip
- Switch to new test framework
- Switch to options helpers Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=465783
-rw-r--r--sysutils/samesame/Makefile21
1 files changed, 4 insertions, 17 deletions
diff --git a/sysutils/samesame/Makefile b/sysutils/samesame/Makefile
index ae5702c6aa8c..e079dbebd4fb 100644
--- a/sysutils/samesame/Makefile
+++ b/sysutils/samesame/Makefile
@@ -21,17 +21,18 @@ CONFIGURE_ARGS= --enable-samechflags --enable-samechmod \
--mandir="${MANPREFIX}/man" --prefix="${PREFIX}" \
--includedir="${LOCALBASE}/include" --libdir="${LOCALBASE}/lib"
USES= tar:bzip2
+TEST_TARGET= check
OPTIONS_DEFINE= DEBUG DISK_STORAGE LOW_MEMORY_PROFILE \
- EXPERIMENTAL PROFILER TEST
+ EXPERIMENTAL PROFILER
OPTIONS_SUB= yes
DISK_STORAGE_DESC= Allows temporarily storage on disk
LOW_MEMORY_PROFILE_DESC= Low memory profile reduces functionality
EXPERIMENTAL_DESC= Enables experimental functionality
PROFILER_DESC= Enables gprof support
-TEST_DESC= Run quality assurance test
DISK_STORAGE_CONFIGURE_ENABLE= disk-storage
+LOW_MEMORY_PROFILE_CONFIGURE_ON= --enable-low-memory-profile --disable-read-onces
EXPERIMENTAL_CONFIGURE_ENABLE= experimental fsort #checksums preread
PROFILE_CONFIGURE_ENABLE= profiler
DEBUG_CONFIGURE_ENABLE= debug
@@ -42,22 +43,8 @@ DEBUG_CONFIGURE_ENABLE= debug
INSTALL_TARGET= install
.endif
-.if ${PORT_OPTIONS:MLOW_MEMORY_PROFILE}
-CONFIGURE_ARGS+= --enable-low-memory-profile --disable-read-onces
-.endif
-
-regression-test: build
- @cd ${WRKSRC}; ${MAKE} check
-
-post-build:
-.if ${PORT_OPTIONS:MTEST}
- @cd ${WRKSRC}; ${MAKE} check
-.endif
-
-post-install:
-.if ${PORT_OPTIONS:MDISK_STORAGE}
+post-install-DISK_STORAGE-on:
${INSTALL_SCRIPT} ${FILESDIR}/samesame.sh \
${STAGEDIR}${PREFIX}/etc/rc.d/
-.endif
.include <bsd.port.mk>