aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-03-30 16:28:22 +0800
committerJan Beich <jbeich@FreeBSD.org>2018-03-30 16:28:22 +0800
commite9e2f78564b4ed5adad461eed88eb4cebc6e5d6b (patch)
treedb4d17ed95e10ab17418568f7b0d60c095509569
parent3a0c5c28f27feb58b51a29c5e202d4307065bf5e (diff)
downloadfreebsd-ports-e9e2f78564b4ed5adad461eed88eb4cebc6e5d6b.tar.gz
freebsd-ports-e9e2f78564b4ed5adad461eed88eb4cebc6e5d6b.tar.zst
freebsd-ports-e9e2f78564b4ed5adad461eed88eb4cebc6e5d6b.zip
x11/alacritty: update libc crate to 0.2.39
alacritty >= g20180312 works fine as is on FreeBSD >= 12.0 as libc >= 0.2.38 uses pre-ino64 syscalls (via COMPAT_FREEBSD11). To simplify maintenance, update libc and drop the patch, similar to what lang/rust-nightly did. https://github.com/rust-lang/libc/commit/969ad2b73cdc https://github.com/rust-lang/libc/commit/78f93220d70e PR: 222824
Notes
Notes: svn path=/head/; revision=465950
-rw-r--r--x11/alacritty/Makefile6
-rw-r--r--x11/alacritty/distinfo4
-rw-r--r--x11/alacritty/files/extra-patch-freebsd12204
3 files changed, 4 insertions, 210 deletions
diff --git a/x11/alacritty/Makefile b/x11/alacritty/Makefile
index 76872993ecfc..ffe7e4bd0b15 100644
--- a/x11/alacritty/Makefile
+++ b/x11/alacritty/Makefile
@@ -2,6 +2,7 @@
PORTNAME= alacritty
PORTVERSION= g20180126
+PORTREVISION= 1
CATEGORIES= x11
MAINTAINER= zeising@FreeBSD.org
@@ -21,9 +22,6 @@ GH_TAGNAME= b82622e9948d1c90fc628739c7f328816214fb33
GH_TUPLE= jwilm:rust-fontconfig:be2b94de833ec69cf767186262a5fb8360fa5b45:servofontconfig \
jwilm:libfontconfig:5c1845e1bffa11cf4d3e6fb27f456bf5c814ce1b:servofontconfigsys
-EXTRA_PATCHES+= ${EXTRA_PATCHES_${OPSYS}_${OSREL:R}}
-EXTRA_PATCHES_FreeBSD_12= ${PATCHDIR}/extra-patch-freebsd12
-
PLIST_FILES= bin/alacritty \
${DESKTOPDIR:S,^${PREFIX}/,,}/Alacritty.desktop
@@ -92,7 +90,7 @@ CARGO_CRATES= aho-corasick-0.6.4 \
lazy_static-1.0.0 \
lazycell-0.4.0 \
lazycell-0.6.0 \
- libc-0.2.36 \
+ libc-0.2.39 \
libloading-0.4.3 \
libz-sys-1.0.18 \
linked-hash-map-0.5.0 \
diff --git a/x11/alacritty/distinfo b/x11/alacritty/distinfo
index 90b6717c66cd..1912cb4d83ee 100644
--- a/x11/alacritty/distinfo
+++ b/x11/alacritty/distinfo
@@ -129,8 +129,8 @@ SHA256 (rust/crates/lazycell-0.4.0.tar.gz) = ce12306c4739d86ee97c23139f3a34ddf03
SIZE (rust/crates/lazycell-0.4.0.tar.gz) = 8456
SHA256 (rust/crates/lazycell-0.6.0.tar.gz) = a6f08839bc70ef4a3fe1d566d5350f519c5912ea86be0df1740a7d247c7fc0ef
SIZE (rust/crates/lazycell-0.6.0.tar.gz) = 10099
-SHA256 (rust/crates/libc-0.2.36.tar.gz) = 1e5d97d6708edaa407429faa671b942dc0f2727222fb6b6539bf1db936e4b121
-SIZE (rust/crates/libc-0.2.36.tar.gz) = 310575
+SHA256 (rust/crates/libc-0.2.39.tar.gz) = f54263ad99207254cf58b5f701ecb432c717445ea2ee8af387334bdd1a03fdff
+SIZE (rust/crates/libc-0.2.39.tar.gz) = 325829
SHA256 (rust/crates/libloading-0.4.3.tar.gz) = fd38073de8f7965d0c17d30546d4bb6da311ab428d1c7a3fc71dff7f9d4979b9
SIZE (rust/crates/libloading-0.4.3.tar.gz) = 15613
SHA256 (rust/crates/libz-sys-1.0.18.tar.gz) = 87f737ad6cc6fd6eefe3d9dc5412f1573865bded441300904d2f42269e140f16
diff --git a/x11/alacritty/files/extra-patch-freebsd12 b/x11/alacritty/files/extra-patch-freebsd12
deleted file mode 100644
index 0327e3bc2606..000000000000
--- a/x11/alacritty/files/extra-patch-freebsd12
+++ /dev/null
@@ -1,204 +0,0 @@
-https://github.com/jwilm/alacritty/issues/618
-
---- cargo-crates/libc-0.2.36/src/unix/bsd/freebsdlike/freebsd/aarch64.rs.orig 2017-08-27 15:32:17 UTC
-+++ cargo-crates/libc-0.2.36/src/unix/bsd/freebsdlike/freebsd/aarch64.rs
-@@ -7,10 +7,12 @@ s! {
- pub struct stat {
- pub st_dev: ::dev_t,
- pub st_ino: ::ino_t,
-- pub st_mode: ::mode_t,
- pub st_nlink: ::nlink_t,
-+ pub st_mode: ::mode_t,
-+ pub st_pad0: ::uint16_t,
- pub st_uid: ::uid_t,
- pub st_gid: ::gid_t,
-+ pub st_pad1: ::uint32_t,
- pub st_rdev: ::dev_t,
- pub st_atime: ::time_t,
- pub st_atime_nsec: ::c_long,
-@@ -18,14 +20,14 @@ s! {
- pub st_mtime_nsec: ::c_long,
- pub st_ctime: ::time_t,
- pub st_ctime_nsec: ::c_long,
-+ pub st_birthtime: ::time_t,
-+ pub st_birthtime_nsec: ::c_long,
- pub st_size: ::off_t,
- pub st_blocks: ::blkcnt_t,
- pub st_blksize: ::blksize_t,
- pub st_flags: ::fflags_t,
-- pub st_gen: ::uint32_t,
-- pub st_lspare: ::int32_t,
-- pub st_birthtime: ::time_t,
-- pub st_birthtime_nsec: ::c_long,
-+ pub st_gen: ::uint64_t,
-+ pub st_spare: [::uint64_t; 10],
- }
- }
-
---- cargo-crates/libc-0.2.36/src/unix/bsd/freebsdlike/freebsd/mod.rs.orig 2018-01-04 03:31:59 UTC
-+++ cargo-crates/libc-0.2.36/src/unix/bsd/freebsdlike/freebsd/mod.rs
-@@ -1,8 +1,8 @@
- pub type fflags_t = u32;
- pub type clock_t = i32;
--pub type ino_t = u32;
-+pub type ino_t = u64;
- pub type lwpid_t = i32;
--pub type nlink_t = u16;
-+pub type nlink_t = u64;
- pub type blksize_t = u32;
- pub type clockid_t = ::c_int;
- pub type sem_t = _sem;
-@@ -44,10 +44,13 @@ s! {
- }
-
- pub struct dirent {
-- pub d_fileno: u32,
-+ pub d_fileno: u64,
-+ pub d_off: u64,
- pub d_reclen: u16,
- pub d_type: u8,
-- pub d_namlen: u8,
-+ pub d_pad0: u8,
-+ pub d_namlen: u16,
-+ pub d_pad1: u16,
- pub d_name: [::c_char; 256],
- }
-
---- cargo-crates/libc-0.2.36/src/unix/bsd/freebsdlike/freebsd/x86.rs.orig 2017-08-27 05:14:57 UTC
-+++ cargo-crates/libc-0.2.36/src/unix/bsd/freebsdlike/freebsd/x86.rs
-@@ -7,25 +7,30 @@ s! {
- pub struct stat {
- pub st_dev: ::dev_t,
- pub st_ino: ::ino_t,
-- pub st_mode: ::mode_t,
- pub st_nlink: ::nlink_t,
-+ pub st_mode: ::mode_t,
-+ pub st_pad0: ::uint16_t,
- pub st_uid: ::uid_t,
- pub st_gid: ::gid_t,
-+ pub st_pad1: ::uint32_t,
- pub st_rdev: ::dev_t,
-+ pub st_atime_ext: ::int32_t,
- pub st_atime: ::time_t,
- pub st_atime_nsec: ::c_long,
-+ pub st_mtime_ext: ::int32_t,
- pub st_mtime: ::time_t,
- pub st_mtime_nsec: ::c_long,
-+ pub st_ctime_ext: ::int32_t,
- pub st_ctime: ::time_t,
- pub st_ctime_nsec: ::c_long,
-+ pub st_birthtime_ext: ::int32_t,
-+ pub st_birthtime: ::time_t,
-+ pub st_birthtime_nsec: ::c_long,
- pub st_size: ::off_t,
- pub st_blocks: ::blkcnt_t,
- pub st_blksize: ::blksize_t,
- pub st_flags: ::fflags_t,
-- pub st_gen: ::uint32_t,
-- pub st_lspare: ::int32_t,
-- pub st_birthtime: ::time_t,
-- pub st_birthtime_nsec: ::c_long,
-- __unused: [u8; 8],
-+ pub st_gen: ::uint64_t,
-+ pub st_spare: [::uint64_t; 10],
- }
- }
---- cargo-crates/libc-0.2.36/src/unix/bsd/freebsdlike/freebsd/x86_64.rs.orig 2017-08-27 15:32:17 UTC
-+++ cargo-crates/libc-0.2.36/src/unix/bsd/freebsdlike/freebsd/x86_64.rs
-@@ -7,10 +7,12 @@ s! {
- pub struct stat {
- pub st_dev: ::dev_t,
- pub st_ino: ::ino_t,
-- pub st_mode: ::mode_t,
- pub st_nlink: ::nlink_t,
-+ pub st_mode: ::mode_t,
-+ pub st_pad0: ::uint16_t,
- pub st_uid: ::uid_t,
- pub st_gid: ::gid_t,
-+ pub st_pad1: ::uint32_t,
- pub st_rdev: ::dev_t,
- pub st_atime: ::time_t,
- pub st_atime_nsec: ::c_long,
-@@ -18,14 +20,14 @@ s! {
- pub st_mtime_nsec: ::c_long,
- pub st_ctime: ::time_t,
- pub st_ctime_nsec: ::c_long,
-+ pub st_birthtime: ::time_t,
-+ pub st_birthtime_nsec: ::c_long,
- pub st_size: ::off_t,
- pub st_blocks: ::blkcnt_t,
- pub st_blksize: ::blksize_t,
- pub st_flags: ::fflags_t,
-- pub st_gen: ::uint32_t,
-- pub st_lspare: ::int32_t,
-- pub st_birthtime: ::time_t,
-- pub st_birthtime_nsec: ::c_long,
-+ pub st_gen: ::uint64_t,
-+ pub st_spare: [::uint64_t; 10],
- }
- }
-
---- cargo-crates/libc-0.2.36/src/unix/bsd/freebsdlike/mod.rs.orig 2018-01-04 03:31:59 UTC
-+++ cargo-crates/libc-0.2.36/src/unix/bsd/freebsdlike/mod.rs
-@@ -1,5 +1,5 @@
- pub type c_char = i8;
--pub type dev_t = u32;
-+pub type dev_t = u64;
- pub type mode_t = u16;
- pub type pthread_attr_t = *mut ::c_void;
- pub type rlim_t = i64;
-@@ -38,8 +38,9 @@ s! {
- pub filter: ::c_short,
- pub flags: ::c_ushort,
- pub fflags: ::c_uint,
-- pub data: ::intptr_t,
-+ pub data: i64,
- pub udata: *mut ::c_void,
-+ pub ext: [u64; 4],
- }
-
- pub struct sockaddr_storage {
---- cargo-crates/mio-0.5.1/src/sys/unix/kqueue.rs.orig 2016-04-27 20:28:22 UTC
-+++ cargo-crates/mio-0.5.1/src/sys/unix/kqueue.rs
-@@ -109,7 +109,8 @@ impl Selector {
- flags: flags,
- fflags: FilterFlag::empty(),
- data: 0,
-- udata: token
-+ udata: token,
-+ ext: [0, 0, 0, 0],
- });
- }
-
---- cargo-crates/mio-0.6.12/src/sys/unix/kqueue.rs.orig 2018-01-05 23:38:17 UTC
-+++ cargo-crates/mio-0.6.12/src/sys/unix/kqueue.rs
-@@ -44,6 +44,7 @@ macro_rules! kevent {
- fflags: 0,
- data: 0,
- udata: $data as UData,
-+ ext: [0, 0, 0, 0],
- }
- }
- }
---- cargo-crates/nix-0.5.1/src/sys/event.rs.orig 2016-03-16 20:17:51 UTC
-+++ cargo-crates/nix-0.5.1/src/sys/event.rs
-@@ -23,8 +23,9 @@ mod ffi {
- pub filter: EventFilter, // 2
- pub flags: EventFlag, // 2
- pub fflags: FilterFlag, // 4
-- pub data: intptr_t, // 8
-- pub udata: usize // 8
-+ pub data: i64, // 8
-+ pub udata: usize, // 8
-+ pub ext: [u64; 4], // 32
- }
-
- #[cfg(target_os = "netbsd")]
-@@ -346,6 +347,7 @@ pub fn ev_set(ev: &mut KEvent,
- ev.fflags = fflags;
- ev.data = 0;
- ev.udata = udata;
-+ ev.ext = [0, 0, 0, 0];
- }
-
- #[cfg(target_os = "netbsd")]