aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-26 17:39:42 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-26 17:39:42 +0800
commitf28f234b25e4d40bed338586e2d346c5e9447191 (patch)
tree6276ddd97348ddbb71047b9c98ed7181040f1b1d
parent0e4c5f2f12b90f8674d1b9fd01626c68391233fe (diff)
downloadfreebsd-ports-f28f234b25e4d40bed338586e2d346c5e9447191.tar.gz
freebsd-ports-f28f234b25e4d40bed338586e2d346c5e9447191.tar.zst
freebsd-ports-f28f234b25e4d40bed338586e2d346c5e9447191.zip
New port: science/py-OpenFermion: Electronic structure package for quantum computers
Notes
Notes: svn path=/head/; revision=465571
-rw-r--r--science/Makefile1
-rw-r--r--science/py-OpenFermion/Makefile32
-rw-r--r--science/py-OpenFermion/distinfo3
-rw-r--r--science/py-OpenFermion/pkg-descr7
4 files changed, 43 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 03d0d7bf410e..b7d007efaa03 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -158,6 +158,7 @@
SUBDIR += psychopy
SUBDIR += pulseview
SUBDIR += py-DendroPy
+ SUBDIR += py-OpenFermion
SUBDIR += py-cdo
SUBDIR += py-coards
SUBDIR += py-h5py
diff --git a/science/py-OpenFermion/Makefile b/science/py-OpenFermion/Makefile
new file mode 100644
index 000000000000..37ff931eef0f
--- /dev/null
+++ b/science/py-OpenFermion/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= OpenFermion
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.4
+CATEGORIES= science python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Electronic structure package for quantum computers
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cvxopt>0:math/py-cvxopt@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}future>0:devel/py-future@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}h5py>0:science/py-h5py@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}networkx>0:math/py-networkx@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.18.0:science/py-scipy@${FLAVOR} \
+ ${PYNUMPY}
+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= quantumlib
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+post-patch: # workaround for https://github.com/quantumlib/OpenFermion/issues/289 (non-ascii file)
+ @truncate -s 0 ${WRKSRC}/README.rst
+
+.include <bsd.port.mk>
diff --git a/science/py-OpenFermion/distinfo b/science/py-OpenFermion/distinfo
new file mode 100644
index 000000000000..a654826c9d86
--- /dev/null
+++ b/science/py-OpenFermion/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522033438
+SHA256 (quantumlib-OpenFermion-v0.4_GH0.tar.gz) = 1073c74d71bf81efa64c5956f24a68b88f2de4c8e9f0eaf83da5536ba2137510
+SIZE (quantumlib-OpenFermion-v0.4_GH0.tar.gz) = 354007
diff --git a/science/py-OpenFermion/pkg-descr b/science/py-OpenFermion/pkg-descr
new file mode 100644
index 000000000000..bdbfc576e258
--- /dev/null
+++ b/science/py-OpenFermion/pkg-descr
@@ -0,0 +1,7 @@
+OpenFermion is an open source effort for compiling and analyzing quantum
+algorithms to simulate fermionic systems, including quantum chemistry.
+Among other functionalities, the current version features data structures
+and tools for obtaining and manipulating representations of fermionic and
+qubit Hamiltonians.
+
+WWW: https://github.com/quantumlib/OpenFermion