aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Grosbein <eugen@FreeBSD.org>2018-03-23 20:19:09 +0800
committerEugene Grosbein <eugen@FreeBSD.org>2018-03-23 20:19:09 +0800
commitf2ea4910119616032a29f1ed36733ee678970b6c (patch)
treed82f2fac89eb5f5cb0131ea9909e54955c18ec5e
parent38add9b79ec2f9d704fe2661ac1af772a617da99 (diff)
downloadfreebsd-ports-f2ea4910119616032a29f1ed36733ee678970b6c.tar.gz
freebsd-ports-f2ea4910119616032a29f1ed36733ee678970b6c.tar.zst
freebsd-ports-f2ea4910119616032a29f1ed36733ee678970b6c.zip
sysutils/cpupdate: update to g20180323
In new version: - fix comment in the startup script on "cpupdate_flags" defaults for rc.conf; - catch up with recent changes of platomav/CPUMicrocodes: updated to MCE DB r62. - removed patch that was integrated (auto load cpuctl.ko, compiler warning); - fixed crash when no supported CPU found (*); Reported by: Eitan Adler (*)
Notes
Notes: svn path=/head/; revision=465350
-rw-r--r--sysutils/cpupdate/Makefile6
-rw-r--r--sysutils/cpupdate/distinfo10
-rw-r--r--sysutils/cpupdate/files/cpupdate.in2
-rw-r--r--sysutils/cpupdate/files/patch-cpupdate.c45
4 files changed, 9 insertions, 54 deletions
diff --git a/sysutils/cpupdate/Makefile b/sysutils/cpupdate/Makefile
index 1bc0a050662b..e0d27cff98e8 100644
--- a/sysutils/cpupdate/Makefile
+++ b/sysutils/cpupdate/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= cpupdate
-DISTVERSION= g20180320
+DISTVERSION= g20180323
CATEGORIES= sysutils
MAINTAINER= eugen@FreeBSD.org
@@ -22,13 +22,13 @@ SUB_LIST= CPM_DIR=${CPM_DIR} INTEL_DIR=${INTEL_DIR}
USE_GITHUB= yes
GH_ACCOUNT= kernschmelze
GH_PROJECT= ${PORTNAME}
-GH_TAGNAME= b0df539
+GH_TAGNAME= 7633a43
PLIST_FILES= sbin/${PORTNAME} man/man8/${PORTNAME}.8.gz
CPM_ACCOUNT= platomav
CPM_PROJECT= CPUMicrocodes
-CPM_TAGNAME= 2ece631
+CPM_TAGNAME= a0371d6
OPTIONS_DEFINE= CPM INTEL
CPM_DESC= Download platomav/CPUMicrocodes collection
diff --git a/sysutils/cpupdate/distinfo b/sysutils/cpupdate/distinfo
index 9df8072e62cd..7e66997e3e74 100644
--- a/sysutils/cpupdate/distinfo
+++ b/sysutils/cpupdate/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1521545124
+TIMESTAMP = 1521807121
SHA256 (microcode-20180312.tgz) = 0b381face2df1b0a829dc4fa8fa93f47f39e11b1c9c22ebd44f8614657c1e779
SIZE (microcode-20180312.tgz) = 3789662
-SHA256 (kernschmelze-cpupdate-g20180320-b0df539_GH0.tar.gz) = 5edb60b1ce5534f85c83676dc475e44800f4e5a2d4df7376ba0187e9b5cc17e9
-SIZE (kernschmelze-cpupdate-g20180320-b0df539_GH0.tar.gz) = 4566043
-SHA256 (platomav-CPUMicrocodes-2ece631_GH0.tar.gz) = bc45bad50b1c2bf86e0a4810d98d8e84328e84dd506d45774079bc87cfb01e15
-SIZE (platomav-CPUMicrocodes-2ece631_GH0.tar.gz) = 4577042
+SHA256 (kernschmelze-cpupdate-g20180323-7633a43_GH0.tar.gz) = b6a595223b7e70fbdf170b51d6aee4d907b36e080c18d076b6a17ae16bd63d28
+SIZE (kernschmelze-cpupdate-g20180323-7633a43_GH0.tar.gz) = 4566592
+SHA256 (platomav-CPUMicrocodes-a0371d6_GH0.tar.gz) = 9c0b37018e3a5abaae5d02a73bd83e70e889055ed2fdccac0353d221193ba915
+SIZE (platomav-CPUMicrocodes-a0371d6_GH0.tar.gz) = 4595189
diff --git a/sysutils/cpupdate/files/cpupdate.in b/sysutils/cpupdate/files/cpupdate.in
index 4eda7f453bd3..961fbd8f5997 100644
--- a/sysutils/cpupdate/files/cpupdate.in
+++ b/sysutils/cpupdate/files/cpupdate.in
@@ -13,7 +13,7 @@
# cpupdate_enable (bool): Set to NO by default.
# Set it to YES to enable cpupdate.
# cpupdate_flags (string): Command line flags for cpupdate.
-# Default is "".
+# Default is "-w -u".
. /etc/rc.subr
diff --git a/sysutils/cpupdate/files/patch-cpupdate.c b/sysutils/cpupdate/files/patch-cpupdate.c
deleted file mode 100644
index b498056e8974..000000000000
--- a/sysutils/cpupdate/files/patch-cpupdate.c
+++ /dev/null
@@ -1,45 +0,0 @@
---- cpupdate.c.orig 2018-03-20 04:24:53 UTC
-+++ cpupdate.c
-@@ -39,6 +39,8 @@ __FBSDID("$FreeBSD$");
-
- #include <sys/queue.h>
- #include <sys/param.h>
-+#include <sys/linker.h>
-+#include <sys/module.h>
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <sys/ioctl.h>
-@@ -99,6 +101,16 @@ usage( void)
- exit(EX_USAGE);
- }
-
-+static int
-+modload( const char *name)
-+{
-+ if (modfind(name) < 0)
-+ if (kldload(name) < 0 || modfind(name) < 0) {
-+ warn("%s: module not found", name);
-+ return 0;
-+ }
-+ return 1;
-+}
-
- static int
- cpu_getCoreNum( void)
-@@ -111,6 +123,7 @@ cpu_getCoreNum( void)
- if (dirp == NULL) {
- r = -1;
- } else {
-+ modload("cpuctl");
- while ((direntry = readdir(dirp)) != NULL) {
- if (direntry->d_namlen == 0)
- continue;
-@@ -466,7 +479,7 @@ main( int argc, char *argv[])
- #else
- if (!r) {
- INFO( 10, "No updating error.\n");
-- INFO( 10, "NOTICE: This FreeBSD version does not support registering new CPU features!\n", numCores);
-+ INFO( 10, "NOTICE: This FreeBSD version does not support registering new CPU features!\n");
- handler->freeucodeinfo( &cpupbuf);
- }
- #endif