aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-30 06:25:16 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-30 06:25:16 +0800
commitf5e1f2e0f526a025c7fb593ff5f3079e1fd8f089 (patch)
tree25b3bd7f5b588067ea488f6b474f28297754430a
parentfe9710e505e6fdb2f240dfc18946334261bd59ff (diff)
downloadfreebsd-ports-f5e1f2e0f526a025c7fb593ff5f3079e1fd8f089.tar.gz
freebsd-ports-f5e1f2e0f526a025c7fb593ff5f3079e1fd8f089.tar.zst
freebsd-ports-f5e1f2e0f526a025c7fb593ff5f3079e1fd8f089.zip
New port: math/py-Diofant: Python library for symbolic mathematics
Notes
Notes: svn path=/head/; revision=465934
-rw-r--r--math/Makefile1
-rw-r--r--math/py-Diofant/Makefile32
-rw-r--r--math/py-Diofant/distinfo3
-rw-r--r--math/py-Diofant/files/patch-setup.py11
-rw-r--r--math/py-Diofant/pkg-descr7
5 files changed, 54 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index b34246d6bdf5..e32a243dab5a 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -621,6 +621,7 @@
SUBDIR += pspp
SUBDIR += pure-mpfr
SUBDIR += pure-rational
+ SUBDIR += py-Diofant
SUBDIR += py-PyWavelets
SUBDIR += py-altgraph
SUBDIR += py-apgl
diff --git a/math/py-Diofant/Makefile b/math/py-Diofant/Makefile
new file mode 100644
index 000000000000..6e53582889c1
--- /dev/null
+++ b/math/py-Diofant/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= Diofant
+DISTVERSION= 0.9.0
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python library for symbolic mathematics
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}isort>0:devel/py-isort@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${FLAVOR}
+# RUN_DEPENDS includes extra_reqs for convenience
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cachetools>0:devel/py-cachetools@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gmpy2>=2.0.8:math/py-gmpy2@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>2.1.1:math/py-matplotlib@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mpmath>=0.19:math/py-mpmath@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyparsing>2.1.2:devel/py-pyparsing@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}strategies>=0.2.3:devel/py-strategies@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}theano>=0.9.0:math/py-theano@${FLAVOR} \
+ ${PYNUMPY}
+
+USES= python:3.5+
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-Diofant/distinfo b/math/py-Diofant/distinfo
new file mode 100644
index 000000000000..4d41077c1b84
--- /dev/null
+++ b/math/py-Diofant/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522358534
+SHA256 (Diofant-0.9.0.tar.gz) = 2ad017257c4ae3ccb2bc065863bf411602a67fc82af4d417dfb6e21c85e775a8
+SIZE (Diofant-0.9.0.tar.gz) = 2309393
diff --git a/math/py-Diofant/files/patch-setup.py b/math/py-Diofant/files/patch-setup.py
new file mode 100644
index 000000000000..014af031d847
--- /dev/null
+++ b/math/py-Diofant/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2018-03-29 22:06:10 UTC
++++ setup.py
+@@ -20,7 +20,7 @@ with open('diofant/__init__.py') as f:
+ if m:
+ __version__ = m.group(1)
+
+-setup_reqs = ['setuptools>=5.5.1', 'pip>=6.0', 'pytest-runner', 'isort']
++setup_reqs = ['setuptools>=5.5.1', 'pytest-runner', 'isort']
+ extra_reqs = {'exports': ['numpy>=1.12.1', 'scipy', 'Theano>=0.9.0'],
+ 'gmpy': ['gmpy2>=2.0.8'],
+ 'plot': ['pyparsing!=2.1.2', 'matplotlib!=2.1.1'],
diff --git a/math/py-Diofant/pkg-descr b/math/py-Diofant/pkg-descr
new file mode 100644
index 000000000000..1ba305ec7afd
--- /dev/null
+++ b/math/py-Diofant/pkg-descr
@@ -0,0 +1,7 @@
+Diofant is a Python library for symbolic mathematics.
+It is able to symbolically differentiate, integrate functions, solve
+algebraoc equations and a lot more.
+
+It can present results in a very cool pseudographics in your terminal.
+
+WWW: https://github.com/diofant/diofant