aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-03-25 22:36:28 +0800
committerMark Linimon <linimon@FreeBSD.org>2018-03-25 22:36:28 +0800
commitfb5279299dfea6d9fa52b59cbd4cb0e295dbfe21 (patch)
tree7d1a4906174bf10722839ecaad48d8385a5df3fc
parentb169d18212a90b6f9bab78e62e07aff7c435d106 (diff)
downloadfreebsd-ports-fb5279299dfea6d9fa52b59cbd4cb0e295dbfe21.tar.gz
freebsd-ports-fb5279299dfea6d9fa52b59cbd4cb0e295dbfe21.tar.zst
freebsd-ports-fb5279299dfea6d9fa52b59cbd4cb0e295dbfe21.zip
Disable dtrace usdt on armvX. It causes link failures.
Regression-tested on amd64. PR: 224271 Submitted by: mikael.urankar Approved by: kwm (maintainer timeout)
Notes
Notes: svn path=/head/; revision=465519
-rw-r--r--lang/spidermonkey170/Makefile5
-rw-r--r--lang/spidermonkey24/Makefile5
-rw-r--r--lang/spidermonkey38/Makefile5
3 files changed, 15 insertions, 0 deletions
diff --git a/lang/spidermonkey170/Makefile b/lang/spidermonkey170/Makefile
index 3deccbcd5939..6e188e2f5432 100644
--- a/lang/spidermonkey170/Makefile
+++ b/lang/spidermonkey170/Makefile
@@ -29,6 +29,11 @@ CONFIGURE_ARGS= --with-pthreads \
OPTIONS_DEFINE= DEBUG DTRACE GCZEAL JEMALLOC METHODJIT OPTIMIZE READLINE \
THREADSAFE TRACEJIT UTF8
OPTIONS_DEFAULT= METHODJIT OPTIMIZE READLINE THREADSAFE TRACEJIT
+# ld(1) fails to link probes: Relocations in generic ELF (EM: 0)
+OPTIONS_EXCLUDE_aarch64= DTRACE
+# dt_modtext:opensolaris/lib/libdtrace/common/dt_link.c: arm not implemented
+OPTIONS_EXCLUDE_armv6= DTRACE
+OPTIONS_EXCLUDE_armv7= DTRACE
OPTIONS_SUB= yes
DEBUG_CONFIGURE_ENABLE= debug debug-symbols
diff --git a/lang/spidermonkey24/Makefile b/lang/spidermonkey24/Makefile
index e144e1bb734a..9765b541a23a 100644
--- a/lang/spidermonkey24/Makefile
+++ b/lang/spidermonkey24/Makefile
@@ -31,6 +31,11 @@ CONFIGURE_ARGS= --with-pthreads \
OPTIONS_DEFINE= DEBUG GCZEAL JEMALLOC METHODJIT OPTIMIZE READLINE \
THREADSAFE TRACEJIT UTF8 DTRACE
OPTIONS_DEFAULT= METHODJIT OPTIMIZE READLINE THREADSAFE TRACEJIT
+# ld(1) fails to link probes: Relocations in generic ELF (EM: 0)
+OPTIONS_EXCLUDE_aarch64= DTRACE
+# dt_modtext:opensolaris/lib/libdtrace/common/dt_link.c: arm not implemented
+OPTIONS_EXCLUDE_armv6= DTRACE
+OPTIONS_EXCLUDE_armv7= DTRACE
OPTIONS_SUB= yes
DEBUG_CONFIGURE_ENABLE= debug debug-symbols
diff --git a/lang/spidermonkey38/Makefile b/lang/spidermonkey38/Makefile
index 4d070f6eaad7..da0057bd345a 100644
--- a/lang/spidermonkey38/Makefile
+++ b/lang/spidermonkey38/Makefile
@@ -33,6 +33,11 @@ CONFIGURE_ARGS= --with-pthreads \
OPTIONS_DEFINE= DEBUG GCZEAL JEMALLOC METHODJIT OPTIMIZE READLINE \
THREADSAFE TRACEJIT UTF8 DTRACE
OPTIONS_DEFAULT=METHODJIT OPTIMIZE READLINE THREADSAFE TRACEJIT
+# ld(1) fails to link probes: Relocations in generic ELF (EM: 0)
+OPTIONS_EXCLUDE_aarch64= DTRACE
+# dt_modtext:opensolaris/lib/libdtrace/common/dt_link.c: arm not implemented
+OPTIONS_EXCLUDE_armv6= DTRACE
+OPTIONS_EXCLUDE_armv7= DTRACE
OPTIONS_SUB= yes
DEBUG_CONFIGURE_ENABLE= debug debug-symbols