aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-03-24 18:13:33 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2018-03-24 18:13:33 +0800
commitfc292011ac615233051cadb1585f7e508c1eb4f8 (patch)
tree26dcb6dd0cf4755259f2c32a58e77b353bc1ac00
parent2693c10fc18fec12249a542f4d35f59f4444a5cc (diff)
downloadfreebsd-ports-fc292011ac615233051cadb1585f7e508c1eb4f8.tar.gz
freebsd-ports-fc292011ac615233051cadb1585f7e508c1eb4f8.tar.zst
freebsd-ports-fc292011ac615233051cadb1585f7e508c1eb4f8.zip
Sync kde.mk a bit with the development repo.
This should ease the import of the new ports for Applications and Plasma Desktop. - add some more component handling - bump KDE_APPLICATIONS_VERSION (no direct consumers exist in the ports tree atm) - fix some space/tab errors Differential Revision: https://reviews.freebsd.org/D14814
Notes
Notes: svn path=/head/; revision=465444
-rw-r--r--Mk/Uses/kde.mk158
-rw-r--r--games/kanagram-kde4/Makefile2
-rw-r--r--games/khangman-kde4/Makefile2
-rw-r--r--math/kalgebra-kde4/Makefile2
-rw-r--r--misc/artikulate-kde4/Makefile2
-rw-r--r--misc/kwordquiz-kde4/Makefile2
-rw-r--r--misc/parley-kde4/Makefile2
-rw-r--r--sysutils/kf5-baloo/Makefile2
8 files changed, 99 insertions, 73 deletions
diff --git a/Mk/Uses/kde.mk b/Mk/Uses/kde.mk
index 1eae2d2c1022..7bf9532b0ea4 100644
--- a/Mk/Uses/kde.mk
+++ b/Mk/Uses/kde.mk
@@ -69,8 +69,8 @@ KDE_FRAMEWORKS_VERSION?= 5.44.0
KDE_FRAMEWORKS_BRANCH?= stable
# Current KDE applications.
-KDE_APPLICATIONS_VERSION?= 16.12.3
-KDE_APPLICATIONS_BRANCH?= stable
+KDE_APPLICATIONS_VERSION?= 17.12.3
+KDE_APPLICATIONS_BRANCH?= stable
# Upstream moves old software to Attic/. Specify the newest applications release there.
# Only the major version is used for the comparison.
_KDE_APPLICATIONS_ATTIC_VERSION= 16.12.3
@@ -120,19 +120,20 @@ DIST_SUBDIR?= KDE/${KDE4_VERSION}
PKGNAMESUFFIX= -kde4
CONFLICTS_INSTALL= ${PORTNAME:C/-kde4//}-4.*
. elif ${_KDE_CATEGORY:Mkde-applications}
-PORTVERSION?= ${KDE_APPLICATIONS_VERSION}
+PORTVERSION?= ${KDE_APPLICATIONS_VERSION}
. if ${_KDE_VERSION:M4}
-CONFLICTS_INSTALL?= ${PORTNAME}-kf5-*
+CONFLICTS_INSTALL?= ${PORTNAME}-[0-9]*
+PKGNAMESUFFIX?= -kde4
. else
-CONFLICTS_INSTALL?= kde4-${PORTNAME}-* ${PORTNAME}-kde4-*
+CONFLICTS_INSTALL?= ${PORTNAME}-kde4-[0-9]*
. endif
-# Decide where the file lies on KDE's servers: Check whether the file lies in Attic
+# Decide where the file lies on KDE's servers: Check whether the file lies in Attic
. if ${KDE_APPLICATIONS_VERSION:R:R} <= ${_KDE_APPLICATIONS_ATTIC_VERSION:R:R}
-MASTER_SITES?= KDE/Attic/applications/${KDE_APPLICATIONS_VERSION}/src
+MASTER_SITES?= KDE/Attic/applications/${KDE_APPLICATIONS_VERSION}/src
. else
-MASTER_SITES?= KDE/${KDE_APPLICATIONS_BRANCH}/applications/${KDE_APPLICATIONS_VERSION}/src
+MASTER_SITES?= KDE/${KDE_APPLICATIONS_BRANCH}/applications/${KDE_APPLICATIONS_VERSION}/src
. endif
-DIST_SUBDIR?= KDE/applications/${KDE_APPLICATIONS_VERSION}
+DIST_SUBDIR?= KDE/applications/${KDE_APPLICATIONS_VERSION}
. elif ${_KDE_CATEGORY:Mkde-frameworks}
PORTVERSION?= ${KDE_FRAMEWORKS_VERSION}
PKGNAMEPREFIX?= kf5-
@@ -202,17 +203,23 @@ PLIST_SUB+= PYCACHE="" \
PYO_SUFFIX=pyo
. endif
# ==============================================================================
-_USE_KDE4_ALL= baloo baloo-widgets baseapps kactivities kate kdelibs \
- kfilemetadata korundum libkcddb libkcompactdisc \
- libkdcraw libkdeedu libkdegames libkexiv2 libkipi \
- libkonq libksane marble nepomuk-core nepomuk-widgets \
- okular oxygen-icons5 perlkde perlqt pimlibs pykde4 \
+
+_USE_KDE_BOTH= akonadi attica libkcddb libkcompactdisc libkdcraw libkdegames \
+ libkeduvocdocument libkexiv2 libkipi libksane okular \
+ baloo baloo-widgets kate marble
+
+_USE_KDE4_ALL= baloo baloo-widgets baseapps kactivities kdelibs \
+ kfilemetadata korundum \
+ libkonq nepomuk-core nepomuk-widgets \
+ oxygen-icons5 perlkde perlqt pimlibs pykde4 \
pykdeuic4 qtruby runtime smokegen smokekde smokeqt \
workspace
# These components are not part of the Software Compilation.
-_USE_KDE4_ALL+= akonadi attica automoc4 ontologies qimageblitz soprano \
+_USE_KDE4_ALL+= akonadi automoc4 ontologies qimageblitz soprano \
strigi
+_USE_KDE4_ALL+= ${_USE_KDE_BOTH}
+
# List of components of the KDE Frameworks distribution.
# The *_TIER<n> variables are internal, primarily for checking
# that our list of frameworks matches the structure offered upstream.
@@ -223,10 +230,9 @@ _USE_FRAMEWORKS_TIER1= apidox archive attica5 breeze-icons codecs config \
widgetsaddons windowsystem
# NOT LISTED TIER1: modemmanagerqt networkmanagerqt (not applicable)
-_USE_FRAMEWORKS_TIER2= auth completion crash doctools filemetadata5 \
- kimageformats jobwidgets notifications package \
- pty unitconversion
-# NOT LISTED TIER2: activities-stats (runtime requires x11/plasma5-kactivitymanagerd)
+_USE_FRAMEWORKS_TIER2= auth completion crash doctools \
+ filemetadata kimageformats jobwidgets notifications \
+ package pty unitconversion
_USE_FRAMEWORKS_TIER3= activities baloo5 bookmarks configwidgets \
designerplugin emoticons globalaccel guiaddons \
@@ -250,14 +256,11 @@ _USE_FRAMEWORKS_ALL= ecm \
${_USE_FRAMEWORKS_PORTING} \
${_USE_FRAMEWORKS_EXTRA}
-_USE_KDE5_ALL= ${_USE_FRAMEWORKS_ALL}
-# ====================== kde4 components =======================================
-baloo_PORT= sysutils/baloo-kde4
-baloo_LIB= libbaloocore.so
+_USE_KDE5_ALL= ${_USE_FRAMEWORKS_ALL} \
+ ${_USE_KDE_BOTH}
-baloo-widgets_PORT= sysutils/baloo-widgets-kde4
-baloo-widgets_LIB= libbaloowidgets.so
+# ====================== kde4 components =======================================
baseapps_PORT= x11/kde-baseapps-kde4
baseapps_PATH= ${KDE_PREFIX}/bin/kfmclient
@@ -266,9 +269,6 @@ baseapps_TYPE= run
kactivities_PORT= x11/kactivities
kactivities_LIB= libkactivities.so
-kate_PORT= editors/kate-kde4
-kate_LIB= libkateinterfaces.so
-
kdelibs_PORT= x11/kdelibs-kde4
kdelibs_LIB= libkdecore.so
@@ -279,45 +279,15 @@ korundum_PORT= devel/ruby-korundum-kde4
korundum_PATH= ${KDE_PREFIX}/lib/kde4/krubypluginfactory.so
korundum_TYPE= run
-libkcddb_PORT= audio/libkcddb-kde4
-libkcddb_LIB= libkcddb.so
-
-libkcompactdisc_PORT= audio/libkcompactdisc-kde4
-libkcompactdisc_LIB= libkcompactdisc.so
-
-libkdcraw_PORT= graphics/libkdcraw-kde4
-libkdcraw_LIB= libkdcraw.so
-
-libkdeedu_PORT= misc/libkdeedu-kde4
-libkdeedu_LIB= libkeduvocdocument.so
-
-libkdegames_PORT= games/libkdegames-kde4
-libkdegames_LIB= libkdegames.so
-
-libkexiv2_PORT= graphics/libkexiv2-kde4
-libkexiv2_LIB= libkexiv2.so
-
-libkipi_PORT= graphics/libkipi-kde4
-libkipi_LIB= libkipi.so
-
libkonq_PORT= x11/libkonq-kde4
libkonq_LIB= libkonq.so
-libksane_PORT= graphics/libksane-kde4
-libksane_LIB= libksane.so
-
-marble_PORT= astro/marble-kde4
-marble_LIB= libmarblewidget.so
-
nepomuk-core_PORT= sysutils/nepomuk-core-kde4
nepomuk-core_LIB= libnepomukcore.so
nepomuk-widgets_PORT= sysutils/nepomuk-widgets-kde4
nepomuk-widgets_LIB= libnepomukwidgets.so
-okular_PORT= graphics/okular-kde4
-okular_LIB= libokularcore.so
-
perlkde_PORT= devel/p5-perlkde-kde4
perlkde_PATH= ${KDE_PREFIX}/lib/kde4/kperlpluginfactory.so
perlkde_TYPE= run
@@ -356,12 +326,6 @@ workspace_PORT= x11/kde-workspace-kde4
workspace_LIB= libkworkspace.so
# Non-Software Compilation components
-akonadi_PORT= databases/akonadi-kde4
-akonadi_LIB= libakonadiprotocolinternals.so
-
-attica_PORT= x11-toolkits/attica
-attica_LIB= libattica.so
-
automoc4_PORT= devel/automoc4
automoc4_PATH= ${LOCALBASE}/bin/automoc4
automoc4_TYPE= build
@@ -443,8 +407,8 @@ ecm_PATH= ${LOCALBASE}/share/ECM/cmake/ECMConfig.cmake
emoticons_PORT= x11-themes/kf5-kemoticons
emoticons_LIB= libKF5Emoticons.so
-filemetadata5_PORT= devel/kf5-kfilemetadata
-filemetadata5_LIB= libKF5FileMetaData.so
+filemetadata_PORT= devel/kf5-kfilemetadata
+filemetadata_LIB= libKF5FileMetaData.so
frameworkintegration_PORT= x11/kf5-frameworkintegration
frameworkintegration_LIB= libKF5Style.so
@@ -607,6 +571,68 @@ xmlrpcclient_PORT= net/kf5-kxmlrpcclient
xmlrpcclient_LIB= libKF5XmlRpcClient.so
# ====================== end of frameworks components ==========================
+# ====================== multiversion component ================================
+akonadi4_PORT= databases/akonadi-kde4
+akonadi4_LIB= libakonadiprotocolinternals.so
+
+attica4_PORT= x11-toolkits/attica
+attica4_LIB= libattica.so
+
+baloo4_PORT= sysutils/baloo-kde4
+baloo4_LIB= libbaloocore.so
+
+baloo-widgets4_PORT= sysutils/baloo-widgets-kde4
+baloo-widgets4_LIB= libbaloowidgets.so
+
+
+kate4_PORT= editors/kate-kde4
+kate4_LIB= libkateinterfaces.so
+
+libkcddb4_PORT= audio/libkcddb-kde4
+libkcddb4_LIB= libkcddb.so
+
+libkcompactdisc4_PORT= audio/libkcompactdisc-kde4
+libkcompactdisc4_LIB= libkcompactdisc.so
+
+libkdcraw4_PORT= graphics/libkdcraw-kde4
+libkdcraw4_LIB= libkdcraw.so
+
+libkdegames4_PORT= games/libkdegames-kde4
+libkdegames4_LIB= libkdegames.so
+
+libkeduvocdocument4_PORT= misc/libkdeedu-kde4
+libkeduvocdocument4_LIB= libkeduvocdocument.so
+
+libkexiv24_PORT= graphics/libkexiv2-kde4
+libkexiv24_LIB= libkexiv2.so
+
+libkipi4_PORT= graphics/libkipi-kde4
+libkipi4_LIB= libkipi.so
+
+libksane4_PORT= graphics/libksane-kde4
+libksane4_LIB= libksane.so
+
+marble4_PORT= astro/marble-kde4
+marble4_LIB= libmarblewidget.so
+
+okular4_PORT= graphics/okular-kde4
+okular4_LIB= libokularcore.so
+# ====================== end of multiversion components ========================
+
+# ====================== select the proper multiversion component ==============
+. for comp in ${_USE_KDE_BOTH}
+${comp}_PORT= ${${comp}${_KDE_VERSION}_PORT}
+. if defined(${comp}${_KDE_VERSION}_LIB)
+${comp}_LIB= ${${comp}${_KDE_VERSION}_LIB}
+. else
+. if defined(${comp}${_KDE_VERSION}_PATH})
+${comp}_PATH= ${${comp}${_KDE_VERSION}_LIB}
+. endif
+# If neither is defined, this gets caught below when checking components
+. endif
+. endfor
+#===============================================================================
+
# end of component list ########################################################
_USE_KDE_ALL= ${_USE_${_KDE_RELNAME}_ALL}
diff --git a/games/kanagram-kde4/Makefile b/games/kanagram-kde4/Makefile
index 7b1466b558cc..12fa8a6edb5d 100644
--- a/games/kanagram-kde4/Makefile
+++ b/games/kanagram-kde4/Makefile
@@ -9,7 +9,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Letter order game for KDE 4
USES= cmake:outsource kde:4 tar:xz
-USE_KDE= kdelibs libkdeedu automoc4
+USE_KDE= kdelibs libkeduvocdocument automoc4
USE_QT4= xml corelib declarative gui opengl script xml \
moc_build qmake_build rcc_build uic_build
diff --git a/games/khangman-kde4/Makefile b/games/khangman-kde4/Makefile
index d09f51bfa433..5e6e9089863c 100644
--- a/games/khangman-kde4/Makefile
+++ b/games/khangman-kde4/Makefile
@@ -9,7 +9,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Hangman game for KDE 4
USES= cmake:outsource kde:4 tar:xz
-USE_KDE= kdelibs libkdeedu automoc4
+USE_KDE= kdelibs libkeduvocdocument automoc4
USE_QT4= corelib declarative gui opengl script xml \
moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/math/kalgebra-kde4/Makefile b/math/kalgebra-kde4/Makefile
index f41b601ce281..b13c52f896c3 100644
--- a/math/kalgebra-kde4/Makefile
+++ b/math/kalgebra-kde4/Makefile
@@ -14,7 +14,7 @@ CMAKE_ARGS= -DBUILD_mobile:BOOL=FALSE
USES= cmake:outsource kde:4 tar:xz
USE_GL= glu
-USE_KDE= kdelibs libkdeedu automoc4
+USE_KDE= kdelibs libkeduvocdocument automoc4
USE_QT4= corelib declarative gui opengl \
moc_build qmake_build rcc_build uic_build
diff --git a/misc/artikulate-kde4/Makefile b/misc/artikulate-kde4/Makefile
index 13eb441d8b51..cedfd3ab9b41 100644
--- a/misc/artikulate-kde4/Makefile
+++ b/misc/artikulate-kde4/Makefile
@@ -15,7 +15,7 @@ RUN_DEPENDS= ${LOCALBASE}/lib/kde4/imports/org/kde/charts/qmldir:graphics/kqtqui
IGNORE= not usable, links to both GStreamer 0.10.x and 1.x
USES= cmake:outsource kde:4 tar:xz
-USE_KDE= automoc4 kdelibs libkdeedu runtime_run
+USE_KDE= automoc4 kdelibs libkeduvocdocument runtime_run
USE_QT4= moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/misc/kwordquiz-kde4/Makefile b/misc/kwordquiz-kde4/Makefile
index c316608f8921..f889cb714fb9 100644
--- a/misc/kwordquiz-kde4/Makefile
+++ b/misc/kwordquiz-kde4/Makefile
@@ -9,7 +9,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Flash card trainer for KDE 4
USES= cmake:outsource kde:4 tar:xz
-USE_KDE= kdelibs libkdeedu automoc4
+USE_KDE= kdelibs libkeduvocdocument automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/misc/parley-kde4/Makefile b/misc/parley-kde4/Makefile
index 1bea4b07e60f..c27743adedab 100644
--- a/misc/parley-kde4/Makefile
+++ b/misc/parley-kde4/Makefile
@@ -10,7 +10,7 @@ COMMENT= Vocabulary trainer for KDE 4
USES= cmake:outsource kde:4 tar:xz
USE_GNOME= libxml2 libxslt
-USE_KDE= kdelibs libkdeedu attica automoc4
+USE_KDE= kdelibs libkeduvocdocument attica automoc4
USE_QT4= corelib gui moc_build qmake_build rcc_build uic_build
USE_XORG= x11 xrender
diff --git a/sysutils/kf5-baloo/Makefile b/sysutils/kf5-baloo/Makefile
index e46d654535dd..26098cf8b51a 100644
--- a/sysutils/kf5-baloo/Makefile
+++ b/sysutils/kf5-baloo/Makefile
@@ -12,7 +12,7 @@ LIB_DEPENDS= liblmdb.so:databases/lmdb \
USES= cmake:outsource compiler:c++11-lib gettext kde:5 pathfix tar:xz
USE_KDE= auth completion config coreaddons crash dbusaddons \
- filemetadata5 i18n idletime jobwidgets kio service \
+ filemetadata i18n idletime jobwidgets kio service \
solid widgetsaddons
USE_QT5= buildtools_build core dbus gui network qmake_build \
qml quick testlib widgets