aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2017-03-10 02:56:12 +0800
committerbdrewery <bdrewery@FreeBSD.org>2017-03-10 02:56:12 +0800
commit26905cfde755052ea936d991a100b524ca0e73e0 (patch)
treea257b6d6685091e60818c11511410f61d1dce736
parenta84b93bfb7b799308346a2fbb4681aa36737cedd (diff)
downloadfreebsd-ports-26905cfde755052ea936d991a100b524ca0e73e0.tar.gz
freebsd-ports-26905cfde755052ea936d991a100b524ca0e73e0.tar.zst
freebsd-ports-26905cfde755052ea936d991a100b524ca0e73e0.zip
MFH: r435782
Fix MAKE_JOBS support. - This port uses ax_am_jobserver [1] which uses CPU_COUNT from ax_count_cpus [2] to force -j to match the number of CPUs in the system rather than the amount already specified by -j to 'gmake all'. The ax_count_cpus script is broken on FreeBSD and the ax_am_jobserver code has no current support for FreeBSD and uses a bashism, thus this always builds with 1 CPU. Forcing ax_am_jobserver to use our MAKE_JOBS_NUMBER value fixes the problem. I plan to do an exp-run to fix this for the entire tree. [1] https://www.gnu.org/software/autoconf-archive/ax_am_jobserver.html [2] https://www.gnu.org/software/autoconf-archive/ax_count_cpus.html Approved by: portmgr (implicit)
-rw-r--r--databases/libmemcached/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/databases/libmemcached/Makefile b/databases/libmemcached/Makefile
index f5eb0a9a6d34..6b8fe3502de7 100644
--- a/databases/libmemcached/Makefile
+++ b/databases/libmemcached/Makefile
@@ -21,6 +21,7 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-memcached \
--without-sphinx-build \
+ --enable-jobserver=${MAKE_JOBS_NUMBER} \
--enable-libmemcachedprotocol
LIBS+= -L${LOCALBASE}/lib -lexecinfo