aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2017-08-17 20:50:58 +0800
committerfeld <feld@FreeBSD.org>2017-08-17 20:50:58 +0800
commit655810a647c9aefd3bff234ff0c8237766380e77 (patch)
treeea8f7125e2b7d24fdca4b02c9e6b1a2a2556ee04
parent1225327af7a8307b2e279b77bfd0e8f3556aa349 (diff)
downloadfreebsd-ports-655810a647c9aefd3bff234ff0c8237766380e77.tar.gz
freebsd-ports-655810a647c9aefd3bff234ff0c8237766380e77.tar.zst
freebsd-ports-655810a647c9aefd3bff234ff0c8237766380e77.zip
MFH: r447275
Backport fix for issue #3212 PR: 221116 Submitted by: pgj Approved by: araujo (maintainer) Obtained from: https://github.com/sphinx-doc/sphinx/issues/3212 Approved by: ports-secteam (with hat)
-rw-r--r--textproc/py-sphinx/Makefile2
-rw-r--r--textproc/py-sphinx/files/patch-sphinx_writers_html.py27
2 files changed, 28 insertions, 1 deletions
diff --git a/textproc/py-sphinx/Makefile b/textproc/py-sphinx/Makefile
index 4c31c45a0b24..27e600bcb6a1 100644
--- a/textproc/py-sphinx/Makefile
+++ b/textproc/py-sphinx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sphinx
PORTVERSION= 1.4.8
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
diff --git a/textproc/py-sphinx/files/patch-sphinx_writers_html.py b/textproc/py-sphinx/files/patch-sphinx_writers_html.py
new file mode 100644
index 000000000000..dd967c1f7018
--- /dev/null
+++ b/textproc/py-sphinx/files/patch-sphinx_writers_html.py
@@ -0,0 +1,27 @@
+--- sphinx/writers/html.py.orig 2016-10-01 15:14:37 UTC
++++ sphinx/writers/html.py
+@@ -16,6 +16,7 @@ import copy
+ import warnings
+
+ from six import string_types
++import docutils
+ from docutils import nodes
+ from docutils.writers.html4css1 import Writer, HTMLTranslator as BaseTranslator
+
+@@ -497,6 +498,16 @@ class HTMLTranslator(BaseTranslator):
+ if 'height' not in node:
+ node['height'] = str(size[1])
+ BaseTranslator.visit_image(self, node)
++
++ # overwritten
++ def depart_image(self, node):
++ if docutils.__version__ >= "0.13":
++ # since docutils-0.13, HTMLWriter does not push context data on visit_image()
++ if node['uri'].lower().endswith(('svg', 'svgz')):
++ self.body.append(self.context.pop())
++ else:
++ # docutils-0.12 or below, HTML Writer always push context data on visit_image()
++ self.body.append(self.context.pop())
+
+ def visit_toctree(self, node):
+ # this only happens when formatting a toc from env.tocs -- in this